aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:35:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:35:36 +0000
commit5978476c353873821167189c3e7e7d3ce7b9909a (patch)
tree5c7b83e7642fc29f698d59a6bc145001dbd04783 /audio/gtkpod
parent95ab3035bfc8b040822f80592efa7b9f2b7a51b6 (diff)
downloadports-5978476c353873821167189c3e7e7d3ce7b9909a.tar.gz
ports-5978476c353873821167189c3e7e7d3ce7b9909a.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in audio With hat: portmgr
Notes
Notes: svn path=/head/; revision=336166
Diffstat (limited to 'audio/gtkpod')
-rw-r--r--audio/gtkpod/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index ad312ad387e5..76ac125585fe 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -12,8 +12,8 @@ COMMENT= GUI for Apple iPod using GTK2
LICENSE= GPLv2
-LIB_DEPENDS= id3tag:${PORTSDIR}/audio/libid3tag \
- gpod:${PORTSDIR}/audio/libgpod
+LIB_DEPENDS= libid3tag.so:${PORTSDIR}/audio/libid3tag \
+ libgpod.so:${PORTSDIR}/audio/libgpod
USES= gettext gmake pkgconfig
NO_STAGE= yes
@@ -34,19 +34,19 @@ CURL_DESC= Cover art download support via libcurl
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+= --without-ogg
.endif
.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac
.else
CONFIGURE_ARGS+= --without-flac
.endif
.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --without-curl
.endif