aboutsummaryrefslogtreecommitdiff
path: root/audio/istream
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-08-31 15:12:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-08-31 15:12:51 +0000
commitcc4992b9f69f5103dfdd0a9e6cf36d8013b9ca6d (patch)
tree35acfe48e056a59134a98a8e46a81aeef9d75834 /audio/istream
parent941d7c4c966bd552f230685d6a2d031f2213be67 (diff)
downloadports-cc4992b9f69f5103dfdd0a9e6cf36d8013b9ca6d.tar.gz
ports-cc4992b9f69f5103dfdd0a9e6cf36d8013b9ca6d.zip
iStream is a simple GNOME panel applet that lets you play internet radio
streams (local files work too). It uses Gstreamer for playback. Written in C using Gtk+. Configure your streams in ~/.istream file. WWW: http://www.gnomefiles.org/app.php/iStream
Notes
Notes: svn path=/head/; revision=240614
Diffstat (limited to 'audio/istream')
-rw-r--r--audio/istream/Makefile29
-rw-r--r--audio/istream/distinfo3
-rw-r--r--audio/istream/pkg-descr7
-rw-r--r--audio/istream/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/audio/istream/Makefile b/audio/istream/Makefile
new file mode 100644
index 000000000000..294d6fe35864
--- /dev/null
+++ b/audio/istream/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: iStream
+# Date created: 31 August 2009
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= istream
+PORTVERSION= 0.10
+CATEGORIES= audio
+MASTER_SITES= http://www.jochen-baier.de/istream/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Internet radio player applet for GNOME Panel
+
+USE_GMAKE= yes
+USE_GNOME= gnomepanel
+USE_GSTREAMER= yes
+USE_XORG= xtst
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}c
+CONFIGURE_ENV= CPPFLAGS="`pkg-config --cflags libgnomeui-2.0`"
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libdir)/bonobo|prefix)/libdata/bonobo|' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/libexec/istream|${PREFIX}/libexec/istream|' ${WRKSRC}/src/GNOME_istreamApplet.server.in
+
+.include <bsd.port.mk>
diff --git a/audio/istream/distinfo b/audio/istream/distinfo
new file mode 100644
index 000000000000..34d32d5b5321
--- /dev/null
+++ b/audio/istream/distinfo
@@ -0,0 +1,3 @@
+MD5 (istream-0.10.tar.gz) = 0fbcd9709c512af798dd6270e56e6710
+SHA256 (istream-0.10.tar.gz) = 8c7a131e7f50de42fcbb4eb006744dd0f96c1873ae07fd326c05901fa5b8e764
+SIZE (istream-0.10.tar.gz) = 117594
diff --git a/audio/istream/pkg-descr b/audio/istream/pkg-descr
new file mode 100644
index 000000000000..bc62d191d841
--- /dev/null
+++ b/audio/istream/pkg-descr
@@ -0,0 +1,7 @@
+iStream is a simple GNOME panel applet that lets you play internet radio
+streams (local files work too). It uses Gstreamer for playback. Written in C
+using Gtk+.
+
+Configure your streams in ~/.istream file.
+
+WWW: http://www.gnomefiles.org/app.php/iStream
diff --git a/audio/istream/pkg-plist b/audio/istream/pkg-plist
new file mode 100644
index 000000000000..f4fd49d03af1
--- /dev/null
+++ b/audio/istream/pkg-plist
@@ -0,0 +1,5 @@
+libdata/bonobo/servers/GNOME_istreamApplet.server
+libexec/istream
+share/pixmaps/istream.png
+share/pixmaps/istream_background.png
+share/pixmaps/istream_menu.png