aboutsummaryrefslogtreecommitdiff
path: root/audio/lash
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2007-10-03 12:32:55 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2007-10-03 12:32:55 +0000
commitaf1f6eeccea19b21b3b7da0dfd6f9b2f04cb9d1d (patch)
treea84897d817ad198e80b0864ba8657de8c9c0c2ac /audio/lash
parent118bc1dcc5ba056151ea67be7408a9131254f0ac (diff)
downloadports-af1f6eeccea19b21b3b7da0dfd6f9b2f04cb9d1d.tar.gz
ports-af1f6eeccea19b21b3b7da0dfd6f9b2f04cb9d1d.zip
- Fix session restoration.
Notes
Notes: svn path=/head/; revision=200732
Diffstat (limited to 'audio/lash')
-rw-r--r--audio/lash/Makefile1
-rw-r--r--audio/lash/files/patch-lashd-client_event.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/audio/lash/Makefile b/audio/lash/Makefile
index 7ebff7653105..561e5f71b74e 100644
--- a/audio/lash/Makefile
+++ b/audio/lash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lash
PORTVERSION= 0.5.3
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.savannah.gnu.org/releases/lash/
diff --git a/audio/lash/files/patch-lashd-client_event.c b/audio/lash/files/patch-lashd-client_event.c
new file mode 100644
index 000000000000..cc8e2854c728
--- /dev/null
+++ b/audio/lash/files/patch-lashd-client_event.c
@@ -0,0 +1,20 @@
+--- lashd/client_event.c.orig 2007-09-17 19:10:14.000000000 +0200
++++ lashd/client_event.c 2007-09-17 19:10:50.000000000 +0200
+@@ -185,6 +185,7 @@
+ project_set_name(project, name);
+ }
+
++#if 0
+ err = gethostname(server_name, MAXHOSTNAMELEN);
+ if (err == -1) {
+ fprintf(stderr,
+@@ -192,6 +193,9 @@
+ __FUNCTION__, strerror(errno));
+ strcpy(server_name, "localhost");
+ }
++#else
++ strcpy(server_name, "localhost");
++#endif
+
+ server->projects = lash_list_append(server->projects, project);
+