aboutsummaryrefslogtreecommitdiff
path: root/audio/liba52
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-16 13:21:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-16 13:21:53 +0000
commitadc3a553ea124bb22bb23f7c163cece361149f0a (patch)
tree69dce57f67997319a7eb5db851a9a574cc1b12ec /audio/liba52
parenta5d43336b41353f4cfdf6be3cdfb0a2fb3064dc2 (diff)
downloadports-adc3a553ea124bb22bb23f7c163cece361149f0a.tar.gz
ports-adc3a553ea124bb22bb23f7c163cece361149f0a.zip
New port liba52 version 0.7.1b: A free library for decoding ATSC
A/52 streams, aka AC-3
Notes
Notes: svn path=/head/; revision=48839
Diffstat (limited to 'audio/liba52')
-rw-r--r--audio/liba52/Makefile45
-rw-r--r--audio/liba52/distinfo1
-rw-r--r--audio/liba52/files/extra-patch-configure.in48
-rw-r--r--audio/liba52/pkg-comment1
-rw-r--r--audio/liba52/pkg-descr24
-rw-r--r--audio/liba52/pkg-plist16
6 files changed, 135 insertions, 0 deletions
diff --git a/audio/liba52/Makefile b/audio/liba52/Makefile
new file mode 100644
index 000000000000..17a399530237
--- /dev/null
+++ b/audio/liba52/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: liba52
+# Date created: Tue Oct 16 10:43:56 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liba52
+PORTVERSION= 0.7.1.b
+CATEGORIES= audio
+MASTER_SITES= http://liba52.sourceforge.net/files/
+DISTNAME= a52dec-${PORTVERSION:S/.b/b/}
+
+MAINTAINER= lioux@FreeBSD.org
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-oss --enable-shared
+USE_LIBTOOL= yes
+
+MAN1= a52dec.1 extract_a52.1
+
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+USE_AUTOCONF= yes
+
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
+.endif
+
+pre-everything::
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} ">>>"
+ @${ECHO_MSG} ">>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS."
+ @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
+ @${ECHO_MSG} ">>>"
+.endif
+
+post-configure:
+ @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/liba52.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/liba52/distinfo b/audio/liba52/distinfo
new file mode 100644
index 000000000000..9af260e30361
--- /dev/null
+++ b/audio/liba52/distinfo
@@ -0,0 +1 @@
+MD5 (a52dec-0.7.1b.tar.gz) = 888e6ccd8706a1e61b0f0366a142cd85
diff --git a/audio/liba52/files/extra-patch-configure.in b/audio/liba52/files/extra-patch-configure.in
new file mode 100644
index 000000000000..ddeb92c0a7a4
--- /dev/null
+++ b/audio/liba52/files/extra-patch-configure.in
@@ -0,0 +1,48 @@
+--- configure.in.orig Fri Aug 31 06:36:25 2001
++++ configure.in Tue Oct 16 10:53:04 2001
+@@ -16,45 +16,15 @@
+
+ dnl -Wall -Werror moved to the end to not disturb the configure script
+
+- dnl -O3
+ changequote(<<,>>)
+ OPT_CFLAGS=`echo "$CFLAGS"|sed "s/-O[0-9]*//g;"`
+ changequote([,])
+- OPT_CFLAGS="$OPT_CFLAGS -O3"
+ AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS])
+
+ dnl -fomit-frame-pointer
+ OPT_CFLAGS="$CFLAGS -fomit-frame-pointer"
+ AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS])
+
+- dnl arch-specific flags
+- case "$host_alias" in
+- i?86-* | k?-*)
+- case "$host_alias" in
+- i386-*) OPT_CFLAGS="$CFLAGS -mcpu=i386";;
+- i486-*) OPT_CFLAGS="$CFLAGS -mcpu=i486";;
+- i586-*) OPT_CFLAGS="$CFLAGS -mcpu=pentium";;
+- i686-*) OPT_CFLAGS="$CFLAGS -mcpu=pentiumpro";;
+- k6-*) OPT_CFLAGS="$CFLAGS -mcpu=k6";;
+- esac
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- sparc-*)
+- OPT_CFLAGS="$CFLAGS -mcpu=ultrasparc -mvis"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- mips-sgi-irix6.*) dnl do we need to be that specific ?
+- OPT_CFLAGS="$CFLAGS -mabi=64"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- esac
+-else
+- dnl non-gcc flags - we probably need exact configuration triplets here.
+- case "$host_alias" in
+- mips-sgi-irix6.*)
+- OPT_CFLAGS="$CFLAGS -64"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- sparc-sun-solaris*)
+- OPT_CFLAGS="$CFLAGS -xCC -fast -xO5"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- esac
+ fi
+
+ dnl Checks for libtool - this must be done after we set cflags
diff --git a/audio/liba52/pkg-comment b/audio/liba52/pkg-comment
new file mode 100644
index 000000000000..cd6a1ff676d5
--- /dev/null
+++ b/audio/liba52/pkg-comment
@@ -0,0 +1 @@
+A free library for decoding ATSC A/52 streams, aka AC-3
diff --git a/audio/liba52/pkg-descr b/audio/liba52/pkg-descr
new file mode 100644
index 000000000000..80f8b57edc4c
--- /dev/null
+++ b/audio/liba52/pkg-descr
@@ -0,0 +1,24 @@
+[ from developer's site ]
+It is a free library for decoding ATSC A/52 streams, aka AC-3. The
+A/52 standard is used in a variety of applications, e.g., digital
+television and DVD. The main goals in liba52 development are:
+
+Portability - most of the code is written in C, and when we use
+platform-specific optimizations we always have a generic C routine
+to fall back on.
+
+Reuseability - we do not want liba52 to include any project-specific
+code, but it should still include enough features to be used by
+very diverse projects.
+
+Precision - We are trying to implement all of the A/52 standard,
+and to have a very precise output by doing all the calculations in
+floating point. We have a test suite that detects any deviation in
+the output when compared to previous versions. We do not have access
+to official A/52 test vectors though, so we have to use our judgement
+to ensure that such deviations are only intruduced when we fix bugs!
+
+Speed - liba52 is really fast, on any modern PC it should take only
+a few percent of CPU time.
+
+WWW: http://liba52.sourceforge.net/
diff --git a/audio/liba52/pkg-plist b/audio/liba52/pkg-plist
new file mode 100644
index 000000000000..d3634b78d91c
--- /dev/null
+++ b/audio/liba52/pkg-plist
@@ -0,0 +1,16 @@
+Bin/a52dec
+bin/extract_a52
+include/a52dec/a52.h
+include/a52dec/audio_out.h
+include/a52dec/mm_accel.h
+lib/liba52.so.0
+lib/liba52.so
+lib/liba52.la
+lib/liba52.a
+lib/libao.so.0
+lib/libao.so
+lib/libao.la
+lib/libao.a
+%%PORTDOCS%%share/doc/liba52/liba52.txt
+%%PORTDOCS%%@dirrm share/doc/liba52
+@dirrm include/a52dec