aboutsummaryrefslogtreecommitdiff
path: root/audio/libamrwb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:39:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:39:54 +0000
commit08b574207595f41bec773a876c9b3586b11878ae (patch)
treee242ef80f9b5948d4d177e61cff39aafb95af347 /audio/libamrwb
parentbd248d23564c3bf784600de05100437f0b5ceca0 (diff)
downloadports-08b574207595f41bec773a876c9b3586b11878ae.tar.gz
ports-08b574207595f41bec773a876c9b3586b11878ae.zip
- Fix Build
- Makefile cleanup PR: 113641 Submitted by: pointyhat via kris/pav Tatsuki Makino <tatsuki_makino@hotmail.com> (Maintainer) Thanks to: Fredrik Lindberg, linimon Reviewed by: sat
Notes
Notes: svn path=/head/; revision=195611
Diffstat (limited to 'audio/libamrwb')
-rw-r--r--audio/libamrwb/Makefile38
-rw-r--r--audio/libamrwb/distinfo3
-rw-r--r--audio/libamrwb/files/patch-Makefile.in24
-rw-r--r--audio/libamrwb/files/patch-configure15
-rw-r--r--audio/libamrwb/files/patch-prepare_sources.sh31
-rw-r--r--audio/libamrwb/files/pkg-message.in17
-rw-r--r--audio/libamrwb/pkg-descr11
7 files changed, 127 insertions, 12 deletions
diff --git a/audio/libamrwb/Makefile b/audio/libamrwb/Makefile
index ab40db506f20..f8d22e24c87d 100644
--- a/audio/libamrwb/Makefile
+++ b/audio/libamrwb/Makefile
@@ -7,16 +7,20 @@
PORTNAME= libamrwb
PORTVERSION= 7.0.0.1
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/
+MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/ \
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/:3GPP
DISTNAME= amrwb-${DISTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SRC3GPP}:3GPP
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= tatsuki_makino@hotmail.com
-COMMENT= Adaptive Multi-Rate - Wideband (AMR-WB) Speech Codec
+COMMENT= 3GPP Adaptive Multi-Rate - Wideband (AMR-WB) Speech Codec
-BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget \
- ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
- bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
+
+SRC3GPP= 26204-700.zip
USE_BZIP2= yes
USE_GMAKE= yes
@@ -24,11 +28,25 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LANG=C
USE_LDCONFIG= yes
-RESTRICTED= See Important legal notice of http://www.penguin.cz/~utx/amr.en.html
+RESTRICTED= license prohibits redistribution
+RESTRICTED_FILES= ${SRC3GPP}
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
+SUB_FILES= pkg-message
+
+post-extract:
+ @${CP} ${DISTDIR}/${SRC3GPP} ${WRKSRC}/
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s!(/bin/bash)!${LOCALBASE}\\1!" \
- ${WRKSRC}/prepare_sources.sh
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO} -n Install documents:
+ @${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ @${ECHO} -n " ${FILE}"
+. endfor
+ @${ECHO} .
+ @${ECHO}
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/audio/libamrwb/distinfo b/audio/libamrwb/distinfo
index e17dfaa3250f..db97371f6d12 100644
--- a/audio/libamrwb/distinfo
+++ b/audio/libamrwb/distinfo
@@ -1,3 +1,6 @@
MD5 (amrwb-7.0.0.1.tar.bz2) = f823b5e055e1d85142740e225b86ac91
SHA256 (amrwb-7.0.0.1.tar.bz2) = 16248eac1a909012be577333583d5f4bffaad2b7687c764d7f027ddc11f1ec86
SIZE (amrwb-7.0.0.1.tar.bz2) = 220644
+MD5 (26204-700.zip) = 2e5098687d3007a05b7acc8298a5b072
+SHA256 (26204-700.zip) = 1b8ba234f5ac520650cb66aee1079491681afb7dba78eb717dca9534ae3598f0
+SIZE (26204-700.zip) = 255757
diff --git a/audio/libamrwb/files/patch-Makefile.in b/audio/libamrwb/files/patch-Makefile.in
new file mode 100644
index 000000000000..a768eb212d27
--- /dev/null
+++ b/audio/libamrwb/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig Thu Jun 7 00:32:12 2007
++++ Makefile.in Sun Jul 15 00:58:13 2007
+@@ -224,7 +224,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ EXTRA_DIST = amrwb-any-cflags.patch amrwb-dhf-declaration.patch amrwb-intsizes.patch prepare_sources.sh amrwb.spec
+-DISTCLEANFILES = 26204-700.zip 26204-700.doc 26204-700_ANSI-C_source_code.zip
++DISTCLEANFILES = 26204-700.doc 26204-700_ANSI-C_source_code.zip
+ lib_LTLIBRARIES = \
+ libamrwb.la
+
+@@ -807,10 +807,10 @@
+ chmod og-w 26204-700.doc
+
+ 26204-700.zip:
+- $(WGET) -N http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/26204-700.zip
++ test -e 26204-700.zip
+
+ extraclean:
+- rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26204-700.zip $(distdir)/26204-700.doc $(distdir)/26204-700_ANSI-C_source_code.zip
++ rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26204-700.doc $(distdir)/26204-700_ANSI-C_source_code.zip
+
+ # WARNING: These commands use internal automake command and may fail in future version.
+ extradist-gzip: distdir extraclean
diff --git a/audio/libamrwb/files/patch-configure b/audio/libamrwb/files/patch-configure
new file mode 100644
index 000000000000..e0a2568cbea1
--- /dev/null
+++ b/audio/libamrwb/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Fri Jun 22 13:50:03 2007
++++ configure Fri Jun 22 13:50:27 2007
+@@ -20338,12 +20338,6 @@
+ fi
+
+
+-if test x"$WGET" = x -a ! "(" -f "26204-700.zip" -o -f "enc_main.c" ")" ; then
+- { { echo "$as_me:$LINENO: error: You need wget utility to download sources." >&5
+-echo "$as_me: error: You need wget utility to download sources." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-
+ # Checks for libraries.
+ { echo "$as_me:$LINENO: checking for library containing sqrt" >&5
+ echo $ECHO_N "checking for library containing sqrt... $ECHO_C" >&6; }
diff --git a/audio/libamrwb/files/patch-prepare_sources.sh b/audio/libamrwb/files/patch-prepare_sources.sh
new file mode 100644
index 000000000000..3dc6ae8f030c
--- /dev/null
+++ b/audio/libamrwb/files/patch-prepare_sources.sh
@@ -0,0 +1,31 @@
+--- prepare_sources.sh.orig Thu Jun 7 00:29:29 2007
++++ prepare_sources.sh Sun Jul 15 01:00:53 2007
+@@ -1,10 +1,10 @@
+-#! /bin/bash
++#! /bin/sh
+
+ set -o errexit
+-trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" ERR
++trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" 0
+
+ if [ "$0" = prepare_sources.sh ] ; then
+- cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . fi )"
++ cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . ; fi )"
+ else
+ cd "${0%/*}"
+ fi
+@@ -24,7 +24,7 @@
+ patch <amrwb-any-cflags.patch
+ patch <amrwb-dhf-declaration.patch
+
+-for FILE in {dec,enc}_if.{c,h} ; do
++for FILE in dec_if.[ch] enc_if.[ch] ; do
+ echo "modifying file $FILE"
+ if test $FILE = ${FILE%.h} ; then
+ ENDSTRING="^}"
+@@ -47,3 +47,5 @@
+ mv $FILE.new $FILE
+ rm $FILE.def $FILE.all
+ done
++
++trap 0
diff --git a/audio/libamrwb/files/pkg-message.in b/audio/libamrwb/files/pkg-message.in
new file mode 100644
index 000000000000..eed7dd4140e8
--- /dev/null
+++ b/audio/libamrwb/files/pkg-message.in
@@ -0,0 +1,17 @@
+
+AMR codecs incorporate several patents, held by Ericsson,
+Universite de Sherbrooke (VoiceAge) and Nokia.
+VoiceAge claims to provide patent portfolio for AMR codecs. Depending on law in
+your country, manufacturers and developers may need to get a license.
+Because it is a shared library, you may need a special contract for each one
+application, which links against this library, directly or indirectly.
+
+* 3GPP policy on licensing and 3G Patent Platform:
+ http://www.3gpp.org/faq/faq_2005_2.htm#A3.1
+* Intellectual property in ETSI standards:
+ http://webapp.etsi.org/IPR/home.asp
+* On 3GPP legal issues:
+ http://www.3gpp.org/legal/legal.htm
+* On VoiceAge licensing:
+ http://www.voiceage.com/licensing.php
+
diff --git a/audio/libamrwb/pkg-descr b/audio/libamrwb/pkg-descr
index 2ed27cb4eff0..81778201362a 100644
--- a/audio/libamrwb/pkg-descr
+++ b/audio/libamrwb/pkg-descr
@@ -1,6 +1,13 @@
-Adaptive Multi-Rate Wideband decoder and encoder library.
+3GPP Adaptive Multi-Rate - Wideband (AMR-WB) Speech Codec
(3GPP TS 26.204 V7.0.0)
-
http://www.3gpp.org/ftp/Specs/html-info/26204.htm
+AMR-WB is a speech coding standard developed after the AMR using the same
+technology like ACELP. The codec provides better speech quality due to wider
+speech bandwidth of 50-7000 Hz compared to narrowband speech codecs.
+AMR-WB is codified as G.722.2, an ITU-T standard speech codec.
+
+Note that depending on law in your country, you may need a license for
+distribution, any use, commercial use or even development.
+
WWW: http://www.penguin.cz/~utx/amr