aboutsummaryrefslogtreecommitdiff
path: root/audio/libgpod/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-10-10 11:13:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-10-10 11:13:42 +0000
commitacc3d5bcf906328512e59ea50f32f09a4d2f8900 (patch)
tree3ababb9f922b8b490cd89243bdb0a7d70fd1559b /audio/libgpod/Makefile
parent117195712a38797a6e512b193eb81b97be8fdd7e (diff)
downloadports-acc3d5bcf906328512e59ea50f32f09a4d2f8900.tar.gz
ports-acc3d5bcf906328512e59ea50f32f09a4d2f8900.zip
Update libgpod and gtkpod to most recent verions, 0.4.0 and 0.99.8,
respectively. Also rename a knob, commit to UPDATING will follow.
Notes
Notes: svn path=/head/; revision=175190
Diffstat (limited to 'audio/libgpod/Makefile')
-rw-r--r--audio/libgpod/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
index 3a71231e3574..6524e2721d64 100644
--- a/audio/libgpod/Makefile
+++ b/audio/libgpod/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libgpod
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gtkpod
@@ -17,10 +16,17 @@ COMMENT= A library for direct access of iPod's contents
USE_GNOME= gtk20
USE_GETTEXT= yes
-INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+# Disable python bindings for now, something does not work there
+CONFIGURE_ARGS= --without-python
+
+.if !defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --with-html-dir="${TARGETDIR}/share/doc"
+.endif
.include <bsd.port.pre.mk>
@@ -28,9 +34,10 @@ post-extract: .SILENT
${REINPLACE_CMD} -e \
's,libdir)/pkgconfig,prefix)/libdata/pkgconfig,' \
${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} '19323,19345d' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e '25s,^,#include <sys/types.h>,' \
- ${WRKSRC}/src/db-parse-context.c
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's, docs$$,,' ${WRKSRC}/Makefile.in
+.endif
+ ${REINPLACE_CMD} '19987,20009d' ${WRKSRC}/configure
.if defined(GCCVERSION)
. if ${GCCVERSION} < 030000
${REINPLACE_CMD} -e 's,\[\],[0],' ${WRKSRC}/src/db-itunes-parser.h