aboutsummaryrefslogtreecommitdiff
path: root/audio/liblastfm/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-10 02:06:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-10 02:06:36 +0000
commitcc02ac7ea8e702fff0c8ba80466c488cd4506f2c (patch)
tree129c4e1eb30b8be6436b1b09af786400cee71966 /audio/liblastfm/Makefile
parent06be2cc63e55a7d55ff10a3f1473b2564a3a3c13 (diff)
downloadports-cc02ac7ea8e702fff0c8ba80466c488cd4506f2c.tar.gz
ports-cc02ac7ea8e702fff0c8ba80466c488cd4506f2c.zip
liblastfm is a collection of libraries to help you integrate Last.fm services
into your rich desktop software. It depends on Qt 4.4. WWW: http://github.com/mxcl/liblastfm/tree/master PR: 135347 Submitted by: Matt Tosto <datahead4@gmail.com>
Notes
Notes: svn path=/head/; revision=235518
Diffstat (limited to 'audio/liblastfm/Makefile')
-rw-r--r--audio/liblastfm/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/audio/liblastfm/Makefile b/audio/liblastfm/Makefile
new file mode 100644
index 000000000000..2441c7ed1d3a
--- /dev/null
+++ b/audio/liblastfm/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: liblastfm
+# Date created: Wed Jan 1 00:48:58 EST 2006
+# Whom: Matt Tosto <datahead4@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblastfm
+PORTVERSION= 0.2.1
+CATEGORIES= audio
+MASTER_SITES= http://cdn.last.fm/src/
+
+MAINTAINER= datahead4@gmail.com
+COMMENT= Collection of libraries to help integrate Last.fm services
+
+LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ fftw3f.5:${PORTSDIR}/math/fftw3-float \
+ mad.2:${PORTSDIR}/audio/libmad
+
+USE_BZIP2= yes
+USE_RUBY= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib xml network sql gui qtestlib \
+ qmake_build moc_build rcc_build uic_build
+HAS_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+
+USE_LDCONFIG= yes
+
+post-extract:
+ ${FIND} ${WRKSRC}/admin -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|\#\!\/usr\/bin\/ruby|\#\!\/usr\/local\/bin\/ruby|'
+
+.include <bsd.port.mk>