aboutsummaryrefslogtreecommitdiff
path: root/audio/libogg
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-12-20 15:22:56 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-12-20 15:22:56 +0000
commit4a8a94afaf2b48b5a09619c5a9af1590fa7fa2d4 (patch)
tree38cbfc09931e59714b498a427ca50b5ab0d388d4 /audio/libogg
parent325e1c0c0162b51ab70490304821f29c65f7b738 (diff)
downloadports-4a8a94afaf2b48b5a09619c5a9af1590fa7fa2d4.tar.gz
ports-4a8a94afaf2b48b5a09619c5a9af1590fa7fa2d4.zip
Update to Ogg Vorbis 1.0.1.
Major user-visible change: vorbis-tools now integrates some support for flac and speex files.
Notes
Notes: svn path=/head/; revision=96268
Diffstat (limited to 'audio/libogg')
-rw-r--r--audio/libogg/Makefile9
-rw-r--r--audio/libogg/distinfo2
-rw-r--r--audio/libogg/files/patch-configure22
-rw-r--r--audio/libogg/files/patch-src_bitwise.c43
-rw-r--r--audio/libogg/pkg-plist11
5 files changed, 67 insertions, 20 deletions
diff --git a/audio/libogg/Makefile b/audio/libogg/Makefile
index a219d6cf0330..b5ba0a364add 100644
--- a/audio/libogg/Makefile
+++ b/audio/libogg/Makefile
@@ -6,19 +6,16 @@
#
PORTNAME= libogg
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.1
PORTEPOCH= 3
CATEGORIES= audio
-MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
- ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
- http://www.casterclub.com/vorbis/unix/ \
- http://www.math.utoledo.edu/~chaese/Vorbis/unix/
+MASTER_SITES= http://www.vorbis.com/files/1.0.1/unix/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Ogg bitstream library
USE_LIBTOOL= yes
+USE_GNOME= gnomehack
INSTALLS_SHLIB= yes
.if defined(NOPORTDOCS)
diff --git a/audio/libogg/distinfo b/audio/libogg/distinfo
index bc078b4c0c81..f9f0f4ea4945 100644
--- a/audio/libogg/distinfo
+++ b/audio/libogg/distinfo
@@ -1 +1 @@
-MD5 (libogg-1.0.tar.gz) = 382a7089f42e6f82e7d658c1cb8ee236
+MD5 (libogg-1.1.tar.gz) = 461d7097bf47864b872085a94ff94e10
diff --git a/audio/libogg/files/patch-configure b/audio/libogg/files/patch-configure
index 93237bff479d..3d1608d55600 100644
--- a/audio/libogg/files/patch-configure
+++ b/audio/libogg/files/patch-configure
@@ -1,9 +1,9 @@
$FreeBSD$
---- configure.orig Fri Jul 19 16:13:10 2002
-+++ configure Sat Oct 5 17:51:53 2002
-@@ -5363,6 +5363,7 @@
+--- configure.orig Mon Nov 17 17:34:08 2003
++++ configure Mon Nov 24 18:26:28 2003
+@@ -7793,6 +7793,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -11,25 +11,23 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -5388,7 +5389,7 @@
+@@ -7818,7 +7819,7 @@
;;
*)
DEBUG="-g"
- CFLAGS="-O"
+ CFLAGS=""
- PROFILE="-g -p"
+ PROFILE="-g -p"
;;
esac
-@@ -5410,9 +5411,9 @@
- PROFILE="-fno-common -O4 -Wall -pg -g -fsigned-char -ffast-math"
+@@ -7841,8 +7842,8 @@
;;
*)
-- DEBUG="-g -Wall -fsigned-char"
+ DEBUG="-g -Wall -fsigned-char"
- CFLAGS="-O20 -fsigned-char"
-- PROFILE="-O20 -g -pg -fsigned-char"
-+ DEBUG="-g -Wall"
-+ CFLAGS=""
-+ PROFILE="-g -pg"
+- PROFILE="-O20 -g -pg -fsigned-char"
++ CFLAGS="-fsigned-char"
++ PROFILE="-g -pg -fsigned-char"
;;
esac
fi
diff --git a/audio/libogg/files/patch-src_bitwise.c b/audio/libogg/files/patch-src_bitwise.c
new file mode 100644
index 000000000000..22cd75dc4480
--- /dev/null
+++ b/audio/libogg/files/patch-src_bitwise.c
@@ -0,0 +1,43 @@
+
+$FreeBSD$
+
+--- src/bitwise.c.orig Mon Nov 10 14:06:08 2003
++++ src/bitwise.c Sun Dec 7 02:36:26 2003
+@@ -251,7 +251,8 @@
+ /* Read in bits without advancing the bitptr; bits <= 32 */
+ long oggpackB_look(oggpack_buffer *b,int bits){
+ unsigned long ret;
+- int m=32-bits;
++ unsigned long m=mask[bits];
++ int s=32-bits;
+
+ bits+=b->endbit;
+
+@@ -272,7 +273,7 @@
+ }
+ }
+ }
+- return (ret>>(m>>1))>>((m+1)>>1);
++ return ((ret>>(s>>1))>>((s+1)>>1)&m);
+ }
+
+ long oggpack_look1(oggpack_buffer *b){
+@@ -347,7 +348,8 @@
+ /* bits <= 32 */
+ long oggpackB_read(oggpack_buffer *b,int bits){
+ unsigned long ret;
+- long m=32-bits;
++ unsigned long m=mask[bits];
++ long s=32-bits;
+
+ bits+=b->endbit;
+
+@@ -369,7 +371,7 @@
+ }
+ }
+ }
+- ret=(ret>>(m>>1))>>((m+1)>>1);
++ ret=((ret>>(s>>1))>>((s+1)>>1)&m);
+
+ overflow:
+
diff --git a/audio/libogg/pkg-plist b/audio/libogg/pkg-plist
index a922d0f5a7ee..314b7008ba03 100644
--- a/audio/libogg/pkg-plist
+++ b/audio/libogg/pkg-plist
@@ -4,7 +4,8 @@ include/ogg/ogg.h
include/ogg/os_types.h
lib/libogg.a
lib/libogg.so
-lib/libogg.so.4
+lib/libogg.so.5
+libdata/pkgconfig/ogg.pc
share/aclocal/ogg.m4
%%PORTDOCS%%%%DOCSDIR%%/framing.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
@@ -33,9 +34,11 @@ share/aclocal/ogg.m4
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_init.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_packetin.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_packetout.html
+%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_packetpeek.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_pagein.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_pageout.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_reset.html
+%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_reset_serialno.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_state.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_sync_buffer.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_sync_clear.html
@@ -59,15 +62,21 @@ share/aclocal/ogg.m4
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_readinit.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_reset.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_write.html
+%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writealign.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writeclear.html
+%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writecopy.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writeinit.html
+%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writetrunc.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/overview.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/reference.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/style.css
%%PORTDOCS%%%%DOCSDIR%%/ogg/vorbis_comment.html
%%PORTDOCS%%%%DOCSDIR%%/ogg/vorbis_info.html
%%PORTDOCS%%%%DOCSDIR%%/oggstream.html
+%%PORTDOCS%%%%DOCSDIR%%/rfc3533.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc3534.txt
%%PORTDOCS%%%%DOCSDIR%%/stream.png
+%%PORTDOCS%%%%DOCSDIR%%/vorbisword2.png
%%PORTDOCS%%%%DOCSDIR%%/white-ogg.png
%%PORTDOCS%%%%DOCSDIR%%/white-xifish.png
@dirrm include/ogg