aboutsummaryrefslogtreecommitdiff
path: root/audio/liboggz/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-10-07 22:43:36 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-10-07 22:43:36 +0000
commitf28a19a3a9d714f554bcb96b1ab9bb04a9d3363f (patch)
tree033303bae77fee1dea8a9995f3b0e9218f7fea69 /audio/liboggz/Makefile
parent7da7bf385a4b417ac87604e763120c84ee813dad (diff)
downloadports-f28a19a3a9d714f554bcb96b1ab9bb04a9d3363f.tar.gz
ports-f28a19a3a9d714f554bcb96b1ab9bb04a9d3363f.zip
Add port audio/liboggz:
Oggz provides a simple programming interface for reading and writing Ogg files and streams. Ogg is an interleaving data container developed by Monty at Xiph.Org, originally to support the Ogg Vorbis audio format. liboggz supports the flexibility afforded by the Ogg file format while presenting the following API niceties: * Strict adherence to the formatting requirements of Ogg bitstreams, to ensure that only valid bitstreams are generated * A simple, callback based open/read/close or open/write/close interface to raw Ogg files * A customisable seeking abstraction for seeking on multitrack Ogg data * A packet queue for feeding incoming packets for writing, with callback based notification when this queue is empty * A means of overriding the IO functions used by Oggz, for easier integration with media frameworks and similar systems. * A handy table structure for storing information on each logical bitstream WWW: http://www.annodex.net/software/liboggz/html/
Notes
Notes: svn path=/head/; revision=174869
Diffstat (limited to 'audio/liboggz/Makefile')
-rw-r--r--audio/liboggz/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/liboggz/Makefile b/audio/liboggz/Makefile
new file mode 100644
index 000000000000..8207a5bca441
--- /dev/null
+++ b/audio/liboggz/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: liboggz
+# Date created: 08 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboggz
+DISTVERSION= 0.9.5
+CATEGORIES= audio
+MASTER_SITES= http://www.annodex.net/software/liboggz/download/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simple Ogg API
+
+LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ogg=${LOCALBASE} --program-transform-name=""
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s!=.*!= ${PREFIX}/libdata/pkgconfig!' ${WRKSRC}/Makefile.in
+.ifdef NOPORTDOCS
+ @${REINPLACE_CMD} -e '/^install-data-am/s!install-data-local!!' ${WRKSRC}/doc/Makefile.in
+.endif
+
+.include <bsd.port.mk>