aboutsummaryrefslogtreecommitdiff
path: root/audio/libtunepimp/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-14 22:03:48 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-14 22:03:48 +0000
commitc843f82c984557c1bd0c5d4391d5bf02de084835 (patch)
treeaf178e625678bdc13851c452276c53bd0a16339a /audio/libtunepimp/Makefile
parentef866e788f4ca20b7e23b9719dfb01e920afd9b4 (diff)
downloadports-c843f82c984557c1bd0c5d4391d5bf02de084835.tar.gz
ports-c843f82c984557c1bd0c5d4391d5bf02de084835.zip
Respect PTHREAD_LIBS, fix build on -STABLE.
Notes
Notes: svn path=/head/; revision=116225
Diffstat (limited to 'audio/libtunepimp/Makefile')
-rw-r--r--audio/libtunepimp/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/audio/libtunepimp/Makefile b/audio/libtunepimp/Makefile
index 6e42d2cdbd20..fd05a1850366 100644
--- a/audio/libtunepimp/Makefile
+++ b/audio/libtunepimp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libtunepimp
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/
@@ -32,5 +33,7 @@ USE_LIBTOOL_VER=15
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
s|^CXXFLAGS=|#CXXFLAGS=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lthr|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/lib/threads/posix/Makefile.in
.include <bsd.port.mk>