aboutsummaryrefslogtreecommitdiff
path: root/audio/libvorbis
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-01-16 14:42:33 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-01-16 14:42:33 +0000
commit4d71f07b6f28e4e43ce7988bd84e1069910edf37 (patch)
treea98221ba45e4c4dff45e3e0b4149b6bb271e3923 /audio/libvorbis
parent696ac36cdc08a26b08a1c72da9b25a0cbc3b9bc8 (diff)
downloadports-4d71f07b6f28e4e43ce7988bd84e1069910edf37.tar.gz
ports-4d71f07b6f28e4e43ce7988bd84e1069910edf37.zip
Upgrade to Ogg Vorbis RC3.
PR: 33727, 33728, 33729, 33731
Notes
Notes: svn path=/head/; revision=53173
Diffstat (limited to 'audio/libvorbis')
-rw-r--r--audio/libvorbis/Makefile12
-rw-r--r--audio/libvorbis/distinfo2
-rw-r--r--audio/libvorbis/files/patch-configure45
-rw-r--r--audio/libvorbis/files/patch-lib_floor1.c14
-rw-r--r--audio/libvorbis/files/patch-lib_psy.c167
-rw-r--r--audio/libvorbis/pkg-plist14
6 files changed, 29 insertions, 225 deletions
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index 16ae9211a7be..22c7f83cced4 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -6,18 +6,20 @@
#
PORTNAME= libvorbis
-PORTVERSION= 1.0.r2
+PORTVERSION= 1.0.r3
PORTEPOCH= 2
CATEGORIES= audio
-MASTER_SITES= http://www.vorbis.com/files/rc2/unix/
+MASTER_SITES= http://www.xiph.org/ogg/vorbis/download/ \
+ http://www.vorbis.com/files/rc2/unix/ \
+ http://www.oddsock.org/vorbisrc3/files/rc3/unix/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= naddy@FreeBSD.org
-LIB_DEPENDS= ogg.2:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= ogg.3:${PORTSDIR}/audio/libogg
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-ogg-prefix=${LOCALBASE}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ogg=${LOCALBASE}
.if defined(NOPORTDOCS)
MAKE_ENV= DOC=""
diff --git a/audio/libvorbis/distinfo b/audio/libvorbis/distinfo
index dc6a89e91382..ccb1989817b8 100644
--- a/audio/libvorbis/distinfo
+++ b/audio/libvorbis/distinfo
@@ -1 +1 @@
-MD5 (libvorbis-1.0rc2.tar.gz) = e5dfe5c71ee451313ec11af1387bd8f7
+MD5 (libvorbis-1.0rc3.tar.gz) = e3a0ce7718f698326504c76562315df2
diff --git a/audio/libvorbis/files/patch-configure b/audio/libvorbis/files/patch-configure
index b7ea0b4a7bf6..39b3be55e8a4 100644
--- a/audio/libvorbis/files/patch-configure
+++ b/audio/libvorbis/files/patch-configure
@@ -1,7 +1,9 @@
+
$FreeBSD$
---- configure.orig Mon Jun 18 18:12:43 2001
-+++ configure Tue Jul 17 00:26:16 2001
-@@ -1621,7 +1621,7 @@ if test -z "$GCC"; then
+
+--- configure.orig Tue Jan 1 22:47:11 2002
++++ configure Tue Jan 1 22:54:27 2002
+@@ -5337,7 +5337,7 @@
PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
*)
DEBUG="-g"
@@ -10,43 +12,16 @@ $FreeBSD$
PROFILE="-g -p" ;;
esac
else
-@@ -1712,9 +1712,9 @@ rm -f conftest*
+@@ -5428,9 +5428,9 @@
CFLAGS="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -O4 -ffast-math -fsigned-char"
PROFILE="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -pg -O4 -ffast-math -fsigned-char";;
*)
-- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
+- DEBUG="-g -Wall -W -D__NO_MATH_INLINES -fsigned-char"
- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
-+ DEBUG="-g -Wall"
-+ CFLAGS=""
-+ PROFILE="-g -pg"
++ DEBUG="-g -Wall -W -fsigned-char"
++ CFLAGS="-fsigned-char"
++ PROFILE="-g -pg -fsigned-char" ;;
esac
fi
CFLAGS="$CFLAGS $cflags_save"
-@@ -1800,14 +1800,14 @@ else
- LIBS=""
- fi
-
--echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
--echo "configure:1805: checking for pthread_create in -lpthread" >&5
-+echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
-+echo "configure:1805: checking for pthread_create in -pthread" >&5
- ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lpthread $LIBS"
-+LIBS="-pthread $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 1813 "configure"
- #include "confdefs.h"
-@@ -1835,7 +1835,7 @@ LIBS="$ac_save_LIBS"
- fi
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- pthread_lib="-lpthread"
-+ pthread_lib="-pthread"
- else
- echo "$ac_t""no" 1>&6
- :
diff --git a/audio/libvorbis/files/patch-lib_floor1.c b/audio/libvorbis/files/patch-lib_floor1.c
deleted file mode 100644
index 94264d168a5e..000000000000
--- a/audio/libvorbis/files/patch-lib_floor1.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/floor1.c.orig Mon Aug 13 13:33:39 2001
-+++ lib/floor1.c Fri Aug 17 01:09:12 2001
-@@ -226,7 +226,7 @@
-
- /* also store a sorted position index */
- for(i=0;i<n;i++)sortpointer[i]=info->postlist+i;
-- qsort(sortpointer,n,sizeof(int),icomp);
-+ qsort(sortpointer,n,sizeof(int *),icomp);
-
- /* points from sort order back to range number */
- for(i=0;i<n;i++)look->forward_index[i]=sortpointer[i]-info->postlist;
diff --git a/audio/libvorbis/files/patch-lib_psy.c b/audio/libvorbis/files/patch-lib_psy.c
deleted file mode 100644
index 5d9cc6a4f8c6..000000000000
--- a/audio/libvorbis/files/patch-lib_psy.c
+++ /dev/null
@@ -1,167 +0,0 @@
-
-$FreeBSD$
-
---- lib/psy.c.orig Mon Aug 13 03:36:57 2001
-+++ lib/psy.c Tue Aug 28 01:47:19 2001
-@@ -594,95 +594,11 @@
-
- }
-
--static void bark_noise_pointmp(int n,const long *b,
-- const float *f,
-- float *noise,
-- const int fixed){
-- long i,hi=0,lo=0,hif=0,lof=0;
-- double xa=0,xb=0;
-- double ya=0,yb=0;
-- double x2a=0,x2b=0;
-- double y2a=0,y2b=0;
-- double xya=0,xyb=0;
-- double na=0,nb=0;
--
-- for(i=0;i<n;i++){
-- if(hi<n){
-- /* find new lo/hi */
-- int bi=b[i]>>16;
-- for(;hi<bi;hi++){
-- double bin=(f[hi]<-140.f?0.:f[hi]+140.);
-- double nn= bin*bin;
-- na += nn;
-- xa += hi*nn;
-- ya += bin*nn;
-- x2a += hi*hi*nn;
-- y2a += bin*bin*nn;
-- xya += hi*bin*nn;
-- }
-- bi=b[i]&0xffff;
-- for(;lo<bi;lo++){
-- double bin=(f[lo]<-140.f?0.:f[lo]+140.);
-- double nn= bin*bin;
-- na -= nn;
-- xa -= lo*nn;
-- ya -= bin*nn;
-- x2a -= lo*lo*nn;
-- y2a -= bin*bin*nn;
-- xya -= lo*bin*nn;
-- }
-- }
--
-- if(hif<n && fixed>0){
-- int bi=i+fixed/2;
-- if(bi>n)bi=n;
-- for(;hif<bi;hif++){
-- double bin=(f[hif]<-140.f?0.:f[hif]+140.);
-- double nn= bin*bin;
-- nb += nn;
-- xb += hif*nn;
-- yb += bin*nn;
-- x2b += hif*hif*nn;
-- y2b += bin*bin*nn;
-- xyb += hif*bin*nn;
-- }
-- bi=i-(fixed+1)/2;
-- if(bi<0)bi=0;
-- for(;lof<bi;lof++){
-- double bin=(f[lof]<-140.f?0.:f[lof]+140.);
-- double nn= bin*bin;
-- nb -= nn;
-- xb -= lof*nn;
-- yb -= bin*nn;
-- x2b -= lof*lof*nn;
-- y2b -= bin*bin*nn;
-- xyb -= lof*bin*nn;
-- }
-- }
--
-- {
-- double denom=1./(na*x2a-xa*xa);
-- double a=(ya*x2a-xya*xa)*denom;
-- double b=(na*xya-xa*ya)*denom;
-- double va=a+b*i;
--
-- if(fixed>0){
-- double denomf=1./(nb*x2b-xb*xb);
-- double af=(yb*x2b-xyb*xb)*denomf;
-- double bf=(nb*xyb-xb*yb)*denomf;
-- double vb=af+bf*i;
-- if(va>vb)va=vb;
-- }
--
-- noise[i]=va-140.f;
-- }
-- }
--}
--
- static void bark_noise_hybridmp(int n,const long *b,
-- const float *f,
-- float *noise,
-- const int fixed){
-+ const float *f,
-+ float *noise,
-+ const float offset,
-+ const int fixed){
- long i,hi=0,lo=0,hif=0,lof=0;
- double xa=0,xb=0;
- double ya=0,yb=0;
-@@ -699,7 +615,7 @@
- /* find new lo/hi */
- int bi=b[i]>>16;
- for(;hi<bi;hi++){
-- double bin=f[hi];
-+ double bin=(f[hi]<-offset?0.:f[hi]+offset);
- if(bin>0.f){
- double nn= bin*bin;
- nn*=nn;
-@@ -716,7 +632,7 @@
- }
- bi=b[i]&0xffff;
- for(;lo<bi;lo++){
-- double bin=f[lo];
-+ double bin=(f[lo]<-offset?0.:f[lo]+offset);
- if(bin>0.f){
- double nn= bin*bin;
- nn*=nn;
-@@ -744,7 +660,7 @@
- if(bi>n)bi=n;
-
- for(;hif<bi;hif++){
-- double bin=f[hif];
-+ double bin=(f[hif]<-offset?0.:f[hif]+offset);
- if(bin>0.f){
- double nn= bin*bin;
- nn*=nn;
-@@ -762,7 +678,7 @@
- bi=i-(fixed+1)/2;
- if(bi<0)bi=0;
- for(;lof<bi;lof++){
-- double bin=f[lof];
-+ double bin=(f[lof]<-offset?0.:f[lof]+offset);
- if(bin>0.f){
- double nn= bin*bin;
- nn*=nn;
-@@ -817,7 +733,7 @@
-
- }
-
-- noise[i]=va;
-+ noise[i]=va-offset;
- }
- }
- }
-@@ -859,13 +775,13 @@
- if(p->vi->noisemaskp){
- float *work=alloca(n*sizeof(float));
-
-- bark_noise_pointmp(n,p->bark,logmdct,logmask,
-- -1);
-+ bark_noise_hybridmp(n,p->bark,logmdct,logmask,
-+ 140.,-1);
-
- for(i=0;i<n;i++)work[i]=logmdct[i]-logmask[i];
-
- _analysis_output("medianmdct",seq,work,n,1,0);
-- bark_noise_hybridmp(n,p->bark,work,logmask,
-+ bark_noise_hybridmp(n,p->bark,work,logmask,0.,
- p->vi->noisewindowfixed);
-
- for(i=0;i<n;i++)work[i]=logmdct[i]-work[i];
diff --git a/audio/libvorbis/pkg-plist b/audio/libvorbis/pkg-plist
index ae959e455619..598d3a004e93 100644
--- a/audio/libvorbis/pkg-plist
+++ b/audio/libvorbis/pkg-plist
@@ -3,14 +3,17 @@ include/vorbis/codec.h
include/vorbis/vorbisenc.h
include/vorbis/vorbisfile.h
lib/libvorbis.a
+lib/libvorbis.la
lib/libvorbis.so
-lib/libvorbis.so.0
+lib/libvorbis.so.1
lib/libvorbisenc.a
+lib/libvorbisenc.la
lib/libvorbisenc.so
-lib/libvorbisenc.so.0
+lib/libvorbisenc.so.1
lib/libvorbisfile.a
+lib/libvorbisfile.la
lib/libvorbisfile.so
-lib/libvorbisfile.so.1
+lib/libvorbisfile.so.2
share/aclocal/vorbis.m4
%%PORTDOCS%%share/doc/libvorbis/programming.html
%%PORTDOCS%%share/doc/libvorbis/v-comment.html
@@ -23,6 +26,7 @@ share/aclocal/vorbis.m4
%%PORTDOCS%%share/doc/libvorbis/vorbisenc/style.css
%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_encode_ctl.html
%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_encode_init.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_encode_init_vbr.html
%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_info.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/OggVorbis_File.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/chaining_example_c.html
@@ -49,9 +53,13 @@ share/aclocal/vorbis.m4
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_raw_tell.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_raw_total.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_read.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_read_float.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_seekable.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_serialnumber.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_streams.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_test.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_test_callbacks.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_test_open.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_time_seek.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_time_tell.html
%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_time_total.html