aboutsummaryrefslogtreecommitdiff
path: root/audio/libvorbis
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-07-19 06:29:35 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-07-19 06:29:35 +0000
commit3dc8097aac854240d9eebda13ee5bea844a09017 (patch)
tree3fef8894b292a7b19d738b3c8bcecdc0cd119587 /audio/libvorbis
parenta6cf39e07bdcf7b34ecf07fce54a2013d6ca94f4 (diff)
downloadports-3dc8097aac854240d9eebda13ee5bea844a09017.tar.gz
ports-3dc8097aac854240d9eebda13ee5bea844a09017.zip
o update to 1.0 RC1.
PORTEPOCH bumped due to PKGNAME now strictly follows handbook. (1.0b4,1 > 1.0.r1,1 vs. 1.0b4,1 < 1.0.r1,2) o support NOPORTDOCS. o remove stale MASTER_SITES. PR: 29036 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=45236
Diffstat (limited to 'audio/libvorbis')
-rw-r--r--audio/libvorbis/Makefile18
-rw-r--r--audio/libvorbis/distinfo2
-rw-r--r--audio/libvorbis/files/patch-Makefile.in12
-rw-r--r--audio/libvorbis/files/patch-configure36
-rw-r--r--audio/libvorbis/files/patch-lib_psy.c12
-rw-r--r--audio/libvorbis/pkg-plist122
6 files changed, 101 insertions, 101 deletions
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index 803bdc97acb2..e5695df9c610 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -6,21 +6,25 @@
#
PORTNAME= libvorbis
-PORTVERSION= 1.0b4
-PORTREVISION= 1
-PORTEPOCH= 1
+PORTVERSION= 1.0.r1
+PORTEPOCH= 2
CATEGORIES= audio
-MASTER_SITES= http://www.vorbis.com/files/beta4/unix/ \
- http://home.student.utwente.nl/t.vanklaveren/distfiles/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
+MASTER_SITES= http://www.vorbis.com/files/rc1/unix/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= naddy@mips.inka.de
-LIB_DEPENDS= ogg.1:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= ogg.2:${PORTSDIR}/audio/libogg
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-ogg-prefix=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(NOPORTDOCS)
+MAKE_ENV= DOC=""
+.else
+MAKE_ENV= DOC=doc
+.endif
+
.include <bsd.port.mk>
diff --git a/audio/libvorbis/distinfo b/audio/libvorbis/distinfo
index f2a994281a0c..7524d6c28ef3 100644
--- a/audio/libvorbis/distinfo
+++ b/audio/libvorbis/distinfo
@@ -1 +1 @@
-MD5 (libvorbis-1.0beta4.tar.gz) = 6954d72386cbf88c613e1ffebb7b4bac
+MD5 (libvorbis-1.0rc1.tar.gz) = 95b34a6a4f2b037fc6cca78a7ebe9758
diff --git a/audio/libvorbis/files/patch-Makefile.in b/audio/libvorbis/files/patch-Makefile.in
new file mode 100644
index 000000000000..34617ba89d39
--- /dev/null
+++ b/audio/libvorbis/files/patch-Makefile.in
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- Makefile.in.orig Tue Jul 17 02:38:23 2001
++++ Makefile.in Tue Jul 17 02:40:02 2001
+@@ -87,7 +87,7 @@ pthread_lib = @pthread_lib@
+
+ AUTOMAKE_OPTIONS = foreign dist-zip
+
+-SUBDIRS = lib include doc examples win32 debian vq
++SUBDIRS = lib include $(DOC) examples win32 debian vq
+
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = vorbis.m4
diff --git a/audio/libvorbis/files/patch-configure b/audio/libvorbis/files/patch-configure
index bc1c134bfd43..b7ea0b4a7bf6 100644
--- a/audio/libvorbis/files/patch-configure
+++ b/audio/libvorbis/files/patch-configure
@@ -1,40 +1,36 @@
$FreeBSD$
---- configure.orig Mon Feb 26 14:34:27 2001
-+++ configure Wed Mar 21 15:45:36 2001
-@@ -1617,9 +1617,9 @@
- CFLAGS="-xO4 -fast -w -fsimple -native -xcg92"
+--- configure.orig Mon Jun 18 18:12:43 2001
++++ configure Tue Jul 17 00:26:16 2001
+@@ -1621,7 +1621,7 @@ if test -z "$GCC"; then
PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
*)
-- DEBUG="-g"
+ DEBUG="-g"
- CFLAGS="-O"
-- PROFILE="-g -p" ;;
-+ DEBUG="$CFLAGS -g"
-+ CFLAGS="$CFLAGS"
-+ PROFILE="$CFLAGS -g -p" ;;
++ CFLAGS=""
+ PROFILE="-g -p" ;;
esac
else
-
-@@ -1709,9 +1709,9 @@
+@@ -1712,9 +1712,9 @@ rm -f conftest*
CFLAGS="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -O4 -ffast-math -fsigned-char"
PROFILE="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -pg -O4 -ffast-math -fsigned-char";;
*)
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
-+ DEBUG="$CFLAGS -g -Wall -D__NO_MATH_INLINES -fsigned-char"
-+ CFLAGS="$CFLAGS -fsigned-char"
-+ PROFILE="$CFLAGS -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
++ DEBUG="-g -Wall"
++ CFLAGS=""
++ PROFILE="-g -pg"
esac
fi
-
-@@ -1795,14 +1795,14 @@
+ CFLAGS="$CFLAGS $cflags_save"
+@@ -1800,14 +1800,14 @@ else
LIBS=""
fi
-echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
--echo "configure:1800: checking for pthread_create in -lpthread" >&5
+-echo "configure:1805: checking for pthread_create in -lpthread" >&5
+echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
-+echo "configure:1800: checking for pthread_create in -pthread" >&5
++echo "configure:1805: checking for pthread_create in -pthread" >&5
ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -43,9 +39,9 @@ $FreeBSD$
-LIBS="-lpthread $LIBS"
+LIBS="-pthread $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 1808 "configure"
+ #line 1813 "configure"
#include "confdefs.h"
-@@ -1830,7 +1830,7 @@
+@@ -1835,7 +1835,7 @@ LIBS="$ac_save_LIBS"
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
diff --git a/audio/libvorbis/files/patch-lib_psy.c b/audio/libvorbis/files/patch-lib_psy.c
deleted file mode 100644
index c736d2bc7b4d..000000000000
--- a/audio/libvorbis/files/patch-lib_psy.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
---- lib/psy.c.orig Mon Feb 26 05:37:59 2001
-+++ lib/psy.c Wed Mar 21 15:50:10 2001
-@@ -191,7 +191,7 @@
- p->total_octave_lines=maxoc-p->firstoc+1;
-
- p->ath=_ogg_malloc(n*sizeof(float));
-- p->octave=_ogg_malloc(n*sizeof(int));
-+ p->octave=_ogg_malloc(n*sizeof(long));
- p->bark=_ogg_malloc(n*sizeof(float));
- p->vi=vi;
- p->n=n;
diff --git a/audio/libvorbis/pkg-plist b/audio/libvorbis/pkg-plist
index c97b7db6375e..ae959e455619 100644
--- a/audio/libvorbis/pkg-plist
+++ b/audio/libvorbis/pkg-plist
@@ -10,66 +10,66 @@ lib/libvorbisenc.so
lib/libvorbisenc.so.0
lib/libvorbisfile.a
lib/libvorbisfile.so
-lib/libvorbisfile.so.0
+lib/libvorbisfile.so.1
share/aclocal/vorbis.m4
-share/doc/libvorbis/programming.html
-share/doc/libvorbis/v-comment.html
-share/doc/libvorbis/vorbis-clip.txt
-share/doc/libvorbis/vorbis-errors.txt
-share/doc/libvorbis/vorbis.html
-share/doc/libvorbis/vorbisenc/index.html
-share/doc/libvorbis/vorbisenc/overview.html
-share/doc/libvorbis/vorbisenc/reference.html
-share/doc/libvorbis/vorbisenc/style.css
-share/doc/libvorbis/vorbisenc/vorbis_encode_ctl.html
-share/doc/libvorbis/vorbisenc/vorbis_encode_init.html
-share/doc/libvorbis/vorbisenc/vorbis_info.html
-share/doc/libvorbis/vorbisfile/OggVorbis_File.html
-share/doc/libvorbis/vorbisfile/chaining_example_c.html
-share/doc/libvorbis/vorbisfile/chainingexample.html
-share/doc/libvorbis/vorbisfile/datastructures.html
-share/doc/libvorbis/vorbisfile/decoding.html
-share/doc/libvorbis/vorbisfile/example.html
-share/doc/libvorbis/vorbisfile/exampleindex.html
-share/doc/libvorbis/vorbisfile/fileinfo.html
-share/doc/libvorbis/vorbisfile/index.html
-share/doc/libvorbis/vorbisfile/initialization.html
-share/doc/libvorbis/vorbisfile/ov_bitrate.html
-share/doc/libvorbis/vorbisfile/ov_bitrate_instant.html
-share/doc/libvorbis/vorbisfile/ov_callbacks.html
-share/doc/libvorbis/vorbisfile/ov_clear.html
-share/doc/libvorbis/vorbisfile/ov_comment.html
-share/doc/libvorbis/vorbisfile/ov_info.html
-share/doc/libvorbis/vorbisfile/ov_open.html
-share/doc/libvorbis/vorbisfile/ov_open_callbacks.html
-share/doc/libvorbis/vorbisfile/ov_pcm_seek.html
-share/doc/libvorbis/vorbisfile/ov_pcm_tell.html
-share/doc/libvorbis/vorbisfile/ov_pcm_total.html
-share/doc/libvorbis/vorbisfile/ov_raw_seek.html
-share/doc/libvorbis/vorbisfile/ov_raw_tell.html
-share/doc/libvorbis/vorbisfile/ov_raw_total.html
-share/doc/libvorbis/vorbisfile/ov_read.html
-share/doc/libvorbis/vorbisfile/ov_seekable.html
-share/doc/libvorbis/vorbisfile/ov_serialnumber.html
-share/doc/libvorbis/vorbisfile/ov_streams.html
-share/doc/libvorbis/vorbisfile/ov_time_seek.html
-share/doc/libvorbis/vorbisfile/ov_time_tell.html
-share/doc/libvorbis/vorbisfile/ov_time_total.html
-share/doc/libvorbis/vorbisfile/overview.html
-share/doc/libvorbis/vorbisfile/reference.html
-share/doc/libvorbis/vorbisfile/seekexample.html
-share/doc/libvorbis/vorbisfile/seeking.html
-share/doc/libvorbis/vorbisfile/seeking_test_c.html
-share/doc/libvorbis/vorbisfile/style.css
-share/doc/libvorbis/vorbisfile/seekingexample.html
-share/doc/libvorbis/vorbisfile/vorbis_comment.html
-share/doc/libvorbis/vorbisfile/vorbis_info.html
-share/doc/libvorbis/vorbisfile/vorbisfile_example_c.html
-share/doc/libvorbis/vorbisword2.png
-share/doc/libvorbis/wait.png
-share/doc/libvorbis/white-ogg.png
-share/doc/libvorbis/white-xifish.png
+%%PORTDOCS%%share/doc/libvorbis/programming.html
+%%PORTDOCS%%share/doc/libvorbis/v-comment.html
+%%PORTDOCS%%share/doc/libvorbis/vorbis-clip.txt
+%%PORTDOCS%%share/doc/libvorbis/vorbis-errors.txt
+%%PORTDOCS%%share/doc/libvorbis/vorbis.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/index.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/overview.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/reference.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/style.css
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_encode_ctl.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_encode_init.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisenc/vorbis_info.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/OggVorbis_File.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/chaining_example_c.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/chainingexample.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/datastructures.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/decoding.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/example.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/exampleindex.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/fileinfo.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/index.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/initialization.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_bitrate.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_bitrate_instant.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_callbacks.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_clear.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_comment.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_info.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_open.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_open_callbacks.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_pcm_seek.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_pcm_tell.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_pcm_total.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_raw_seek.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_raw_tell.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_raw_total.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_read.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_seekable.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_serialnumber.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_streams.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_time_seek.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_time_tell.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/ov_time_total.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/overview.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/reference.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/seekexample.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/seeking.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/seeking_test_c.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/style.css
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/seekingexample.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/vorbis_comment.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/vorbis_info.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisfile/vorbisfile_example_c.html
+%%PORTDOCS%%share/doc/libvorbis/vorbisword2.png
+%%PORTDOCS%%share/doc/libvorbis/wait.png
+%%PORTDOCS%%share/doc/libvorbis/white-ogg.png
+%%PORTDOCS%%share/doc/libvorbis/white-xifish.png
@dirrm include/vorbis
-@dirrm share/doc/libvorbis/vorbisenc
-@dirrm share/doc/libvorbis/vorbisfile
-@dirrm share/doc/libvorbis
+%%PORTDOCS%%@dirrm share/doc/libvorbis/vorbisenc
+%%PORTDOCS%%@dirrm share/doc/libvorbis/vorbisfile
+%%PORTDOCS%%@dirrm share/doc/libvorbis