aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-f10-mikmod
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /audio/linux-f10-mikmod
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'audio/linux-f10-mikmod')
-rw-r--r--audio/linux-f10-mikmod/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/audio/linux-f10-mikmod/Makefile b/audio/linux-f10-mikmod/Makefile
index cd760aafe808..10b7a26d9201 100644
--- a/audio/linux-f10-mikmod/Makefile
+++ b/audio/linux-f10-mikmod/Makefile
@@ -5,8 +5,7 @@ PORTNAME= mikmod
PORTVERSION= 3.2.0
CATEGORIES= audio linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${LINUX_NAME}-${PORTVERSION}-${RPMVERSION}
+DISTNAME= lib${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= MikMod Sound Library (Linux Fedora 10)
@@ -14,8 +13,9 @@ COMMENT= MikMod Sound Library (Linux Fedora 10)
CONFLICTS= linux-mikmod-[0-9]* linux-f8-mikmod-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= f10
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 10
+
RPMVERSION= 3.beta2.fc9
LINUX_NAME= lib${PORTNAME}
USE_LDCONFIG= yes
@@ -25,6 +25,4 @@ DOCSDIR= ${PREFIX}/usr/share/doc/${LINUX_NAME}-${PORTVERSION}
PORTDOCS= AUTHORS COPYING.LESSER COPYING.LIB NEWS README TODO
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>