aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-08-23 19:11:58 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-08-23 19:11:58 +0000
commit350c62cd5d2d4daca7b519dc4d9be13dff2f574a (patch)
treed4b778b20dc1f7c5cd23c4db4ba5da22103b0c06 /audio/linuxsampler
parent5d7a74787a161ae0d5277e038aeacfe4504876d2 (diff)
downloadports-350c62cd5d2d4daca7b519dc4d9be13dff2f574a.tar.gz
ports-350c62cd5d2d4daca7b519dc4d9be13dff2f574a.zip
The LinuxSampler project was founded with the goal to produce a
free, streaming capable open source pure software audio sampler with professional grade features, comparable to both hardware and commercial Windows/Mac software samplers and to introduce new features not yet available by any other sampler in the world. WWW: http://www.linuxsampler.org/
Notes
Notes: svn path=/head/; revision=240220
Diffstat (limited to 'audio/linuxsampler')
-rw-r--r--audio/linuxsampler/Makefile32
-rw-r--r--audio/linuxsampler/distinfo3
-rw-r--r--audio/linuxsampler/files/patch-src-common-Mutex.cpp10
-rw-r--r--audio/linuxsampler/files/patch-src-common-atomic.h11
-rw-r--r--audio/linuxsampler/files/patch-src-drivers-audio-AudioChannel.cpp11
-rw-r--r--audio/linuxsampler/pkg-descr7
-rw-r--r--audio/linuxsampler/pkg-plist43
7 files changed, 117 insertions, 0 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
new file mode 100644
index 000000000000..23337c7ac235
--- /dev/null
+++ b/audio/linuxsampler/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: linuxsampler
+# Date created: 2007-01-24
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linuxsampler
+PORTVERSION= 1.0.0
+CATEGORIES= audio
+MASTER_SITES= http://download.linuxsampler.org/packages/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Modular MIDI sampler
+
+LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
+ gig.10:${PORTSDIR}/audio/libgig \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= "HAVE_UNIX98=1"
+CFLAGS+= "-I${LOCALBASE}/include"
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget
+USE_LDCONFIG= yes
+
+RESTRICTED= "no commercial use"
+
+MAN1= linuxsampler.1
+
+.include <bsd.port.mk>
diff --git a/audio/linuxsampler/distinfo b/audio/linuxsampler/distinfo
new file mode 100644
index 000000000000..668193efeac8
--- /dev/null
+++ b/audio/linuxsampler/distinfo
@@ -0,0 +1,3 @@
+MD5 (linuxsampler-1.0.0.tar.bz2) = a97136791a3228d840b006e5481fc39d
+SHA256 (linuxsampler-1.0.0.tar.bz2) = bf4f4f83b9ab706e8e8b017aafb560c363bb7663413aeae46d49f1f56110c9cf
+SIZE (linuxsampler-1.0.0.tar.bz2) = 701591
diff --git a/audio/linuxsampler/files/patch-src-common-Mutex.cpp b/audio/linuxsampler/files/patch-src-common-Mutex.cpp
new file mode 100644
index 000000000000..002d905521cc
--- /dev/null
+++ b/audio/linuxsampler/files/patch-src-common-Mutex.cpp
@@ -0,0 +1,10 @@
+--- src/common/Mutex.cpp.orig Tue Mar 6 20:42:00 2007
++++ src/common/Mutex.cpp Tue Mar 6 20:42:06 2007
+@@ -35,7 +35,6 @@
+
+ #if !defined(_XOPEN_SOURCE) || _XOPEN_SOURCE < 500
+ # undef _XOPEN_SOURCE
+-# define _XOPEN_SOURCE 500 /* to define PTHREAD_MUTEX_ERRORCHECK */
+ # warning "Seems you don't have a UNIX98 compatible system."
+ # warning "Please run LinuxSampler's selftest to make sure this won't be a problem!"
+ # warning "(compile tests with 'make tests', run them with 'src/testcases/linuxsamplertest')"
diff --git a/audio/linuxsampler/files/patch-src-common-atomic.h b/audio/linuxsampler/files/patch-src-common-atomic.h
new file mode 100644
index 000000000000..8a17bb03058f
--- /dev/null
+++ b/audio/linuxsampler/files/patch-src-common-atomic.h
@@ -0,0 +1,11 @@
+--- src/common/atomic.h.orig 2009-03-29 20:43:39.000000000 +0200
++++ src/common/atomic.h 2009-08-22 11:21:38.000000000 +0200
+@@ -38,7 +38,7 @@
+ #define CONFIG_SMP /* ... the macro the kernel headers use */
+ #endif
+
+-#if defined(__linux__) || defined(WIN32) || defined(__APPLE__)
++#if defined(__linux__) || defined(WIN32) || defined(__APPLE__) || defined(__FreeBSD__)
+ #ifdef _ARCH_PPC
+
+ /*
diff --git a/audio/linuxsampler/files/patch-src-drivers-audio-AudioChannel.cpp b/audio/linuxsampler/files/patch-src-drivers-audio-AudioChannel.cpp
new file mode 100644
index 000000000000..713c1a6f0410
--- /dev/null
+++ b/audio/linuxsampler/files/patch-src-drivers-audio-AudioChannel.cpp
@@ -0,0 +1,11 @@
+--- src/drivers/audio/AudioChannel.cpp.orig 2007-11-15 00:42:05.000000000 +0100
++++ src/drivers/audio/AudioChannel.cpp 2008-11-16 01:55:40.000000000 +0100
+@@ -26,7 +26,7 @@
+ #include "../../common/global_private.h"
+ #include "../../common/Thread.h" // needed for allocAlignedMem() and freeAlignedMem()
+
+-#if defined(__APPLE__)
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ # include <stdlib.h>
+ #else
+ # include <malloc.h>
diff --git a/audio/linuxsampler/pkg-descr b/audio/linuxsampler/pkg-descr
new file mode 100644
index 000000000000..0fcb5c9e89c4
--- /dev/null
+++ b/audio/linuxsampler/pkg-descr
@@ -0,0 +1,7 @@
+The LinuxSampler project was founded with the goal to produce a
+free, streaming capable open source pure software audio sampler
+with professional grade features, comparable to both hardware and
+commercial Windows/Mac software samplers and to introduce new
+features not yet available by any other sampler in the world.
+
+WWW: http://www.linuxsampler.org/
diff --git a/audio/linuxsampler/pkg-plist b/audio/linuxsampler/pkg-plist
new file mode 100644
index 000000000000..9951ecbcc0e7
--- /dev/null
+++ b/audio/linuxsampler/pkg-plist
@@ -0,0 +1,43 @@
+bin/linuxsampler
+include/linuxsampler/engines/Engine.h
+include/linuxsampler/engines/EngineChannel.h
+include/linuxsampler/engines/FxSend.h
+include/linuxsampler/engines/InstrumentManager.h
+include/linuxsampler/common/lsatomic.h
+include/linuxsampler/common/Exception.h
+include/linuxsampler/common/Thread.h
+include/linuxsampler/common/global.h
+include/linuxsampler/common/optional.h
+include/linuxsampler/common/Mutex.h
+include/linuxsampler/common/SynchronizedConfig.h
+include/linuxsampler/common/Condition.h
+include/linuxsampler/drivers/audio/AudioChannel.h
+include/linuxsampler/drivers/audio/AudioOutputDevice.h
+include/linuxsampler/drivers/midi/midi.h
+include/linuxsampler/drivers/midi/MidiInputPort.h
+include/linuxsampler/drivers/midi/MidiInputDevice.h
+include/linuxsampler/drivers/midi/MidiInstrumentMapper.h
+include/linuxsampler/drivers/midi/VirtualMidiDevice.h
+include/linuxsampler/drivers/Device.h
+include/linuxsampler/drivers/DeviceParameter.h
+include/linuxsampler/plugins/InstrumentEditor.h
+include/linuxsampler/plugins/InstrumentEditorFactory.h
+include/linuxsampler/effects/Effect.h
+include/linuxsampler/effects/EffectChain.h
+include/linuxsampler/Sampler.h
+include/linuxsampler/EventListeners.h
+@dirrm include/linuxsampler/engines
+@dirrm include/linuxsampler/common
+@dirrm include/linuxsampler/drivers/audio
+@dirrm include/linuxsampler/drivers/midi
+@dirrm include/linuxsampler/drivers
+@dirrm include/linuxsampler/plugins
+@dirrm include/linuxsampler/effects
+@dirrm include/linuxsampler
+lib/linuxsampler/liblinuxsampler.so.3
+lib/linuxsampler/liblinuxsampler.so
+lib/linuxsampler/liblinuxsampler.la
+lib/linuxsampler/liblinuxsampler.a
+libdata/pkgconfig/linuxsampler.pc
+@dirrm lib/linuxsampler/plugins
+@dirrm lib/linuxsampler