aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-25 11:19:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-25 11:19:24 +0000
commitfb90f3243a57d250d1a20bfa7013ae705f9c835a (patch)
tree93a7647d099bf5b808f816433ea701996ac0283c /audio/linuxsampler
parentb7dcbee1665f3cbf4dbf366b340586d3a8f52db0 (diff)
downloadports-fb90f3243a57d250d1a20bfa7013ae705f9c835a.tar.gz
ports-fb90f3243a57d250d1a20bfa7013ae705f9c835a.zip
- Remove BROKEN and DPRECATED
- Fix build PR: 155858 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=271673
Diffstat (limited to 'audio/linuxsampler')
-rw-r--r--audio/linuxsampler/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 59f5fada74d2..2debfb6a7c4d 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -15,28 +15,34 @@ COMMENT= Modular MIDI sampler
LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
gig.10:${PORTSDIR}/audio/libgig \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
-ONLY_FOR_ARCHS= "i386 amd64"
+RESTRICTED= no commercial use
+
+ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported"
-BROKEN= does not fetch
-DEPRECATED= "${BROKEN}"
-EXPIRATION_DATE= 2011-03-26
USE_BZIP2= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= "HAVE_UNIX98=1"
-CFLAGS+= "-I${LOCALBASE}/include"
+USE_GNOME= gnomehack
+USE_SQLITE= 3
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget
+USE_AUTOTOOLS= libtool
+CONFIGURE_ENV= HAVE_UNIX98=1
+CONFIGURE_ARGS= LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
-RESTRICTED= no commercial use
+
MAN1= linuxsampler.1
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000 || ${OSVERSION} >= 900000
-BROKEN= Does not compile
-.endif
+#.if ${OSVERSION} >= 900000
+#BROKEN= Does not compile
+#.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|CXX_CPU_SWITCH=.*|CXX_CPU_SWITCH=|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>