aboutsummaryrefslogtreecommitdiff
path: root/audio/mhwaveedit
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-27 18:01:58 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-27 18:01:58 +0000
commit5e5ba15b63c1e06240e519b2da655161574d4e5a (patch)
tree3e1940c7d68ea453c678e0d3fb8290d87ec4229f /audio/mhwaveedit
parent8a6c5769d92a4508961f01bcae9d25a94592442b (diff)
downloadports-5e5ba15b63c1e06240e519b2da655161574d4e5a.tar.gz
ports-5e5ba15b63c1e06240e519b2da655161574d4e5a.zip
Update to version 1.3.0
PR: ports/68368 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=112380
Diffstat (limited to 'audio/mhwaveedit')
-rw-r--r--audio/mhwaveedit/Makefile18
-rw-r--r--audio/mhwaveedit/distinfo4
-rw-r--r--audio/mhwaveedit/files/patch-src::recorddialog.c12
3 files changed, 18 insertions, 16 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index 6f4a328e1403..d510d6ac9023 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,21 +7,23 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.9
+PORTVERSION= 1.3.0
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical program for editing sound files
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
portaudio.0:${PORTSDIR}/audio/portaudio
USE_GNOME= gnomehack gnometarget gtk20
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-optimization --without-sdl
+CONFIGURE_ARGS= --disable-optimization --without-alsalib --without-sdl
PLIST_FILES= bin/mhwaveedit
@@ -29,6 +31,12 @@ PLIST_FILES= bin/mhwaveedit
CONFIGURE_ARGS+= --with-double-samples
.endif
+.if defined(WITH_JACK)
+LIB_DPENDS+= jack:${PORTSDIR}/audio/jack
+.else
+CONFIGURE_ARGS+= --without-jack
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "mhWaveEdit has the following tunable option:"
@@ -38,5 +46,11 @@ pre-everything::
@${ECHO_MSG} " processing (slows down program but may increase"
@${ECHO_MSG} " quality for 24/32-bit samplerates)"
@${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_JACK=yes"
+ @${ECHO_MSG} " Support JACK driver"
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
index 2e13df53852c..ed8f29120b61 100644
--- a/audio/mhwaveedit/distinfo
+++ b/audio/mhwaveedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (mhwaveedit-1.2.9.tar.gz) = 94b4caee594a39bb2175dfc36b1287c7
-SIZE (mhwaveedit-1.2.9.tar.gz) = 256750
+MD5 (mhwaveedit-1.3.0.tar.gz) = ea17d4639af5983d2a2b33e343c41fb3
+SIZE (mhwaveedit-1.3.0.tar.gz) = 292965
diff --git a/audio/mhwaveedit/files/patch-src::recorddialog.c b/audio/mhwaveedit/files/patch-src::recorddialog.c
deleted file mode 100644
index 972a959c5453..000000000000
--- a/audio/mhwaveedit/files/patch-src::recorddialog.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/recorddialog.c.orig Sat Apr 17 12:41:52 2004
-+++ src/recorddialog.c Mon Apr 19 19:27:35 2004
-@@ -590,8 +590,7 @@
- void record_dialog_init(RecordDialog *obj)
- {
- GtkWidget *a,*b,*c,*d,*e;
--GtkAccelGroup* ag;
--ag = gtk_accel_group_new();
-+ GtkAccelGroup* ag = gtk_accel_group_new();
- GList *l2 = NULL;
- RecordFormat *rf;
- guint i;