aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3stat
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-26 06:22:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-26 06:22:58 +0000
commit3b5ccf536a9095ea1ec937ab3ae26127b8791ca3 (patch)
tree722d8d1abfa30bc8f04b6abaf8d0d4c39d3281aa /audio/mp3stat
parent4d4a5773b5e0fb86f09ed756cd1cc0d62a7cbf00 (diff)
downloadports-3b5ccf536a9095ea1ec937ab3ae26127b8791ca3.tar.gz
ports-3b5ccf536a9095ea1ec937ab3ae26127b8791ca3.zip
upgrade to 2.5.6
Notes
Notes: svn path=/head/; revision=56677
Diffstat (limited to 'audio/mp3stat')
-rw-r--r--audio/mp3stat/Makefile2
-rw-r--r--audio/mp3stat/distinfo2
-rw-r--r--audio/mp3stat/files/patch-Makefile43
-rw-r--r--audio/mp3stat/files/patch-Makefile.rules36
4 files changed, 44 insertions, 39 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index 8d88d52459e8..18f42ad48d47 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mp3stat
-PORTVERSION= 2.5.5
+PORTVERSION= 2.5.6
CATEGORIES= audio
MASTER_SITES= http://safemode.homeip.net/
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/audio/mp3stat/distinfo b/audio/mp3stat/distinfo
index 44e89ddd7937..b3feb4b305e5 100644
--- a/audio/mp3stat/distinfo
+++ b/audio/mp3stat/distinfo
@@ -1 +1 @@
-MD5 (mp3stat_2.5.5.tar.gz) = 92811ae5b9cafd9607bbf405092e5c8b
+MD5 (mp3stat_2.5.6.tar.gz) = 1d865b3d0d6c048e6f2f03ddaeff3854
diff --git a/audio/mp3stat/files/patch-Makefile b/audio/mp3stat/files/patch-Makefile
index 110d59ae2444..e09b11024a00 100644
--- a/audio/mp3stat/files/patch-Makefile
+++ b/audio/mp3stat/files/patch-Makefile
@@ -1,24 +1,18 @@
---- Makefile.orig Fri Mar 22 17:00:23 2002
-+++ Makefile Sat Mar 23 02:46:59 2002
-@@ -4,26 +4,28 @@
- #since we're using c++, we use CXXFLAGS since that's standard.
- #If you only set CFLAGS, you should also look into setting CXXFLAGS
+--- Makefile.orig Tue Mar 26 14:15:51 2002
++++ Makefile Tue Mar 26 14:20:29 2002
+@@ -6,24 +6,26 @@
--TBUILDFLAGS = -Wall -lvorbis -lvorbisfile -lm $(CXXFLAGS)
-+TBUILDFLAGS = -L${LOCALBASE}/lib -lvorbis -lvorbisfile -lm $(CXXFLAGS)
+ BFLAGS = $(CXXFLAGS)
--BUILDFLAGS = -Wall -lvorbis -lvorbisfile `glib-config --cflags` `gtk-config --cflags` `gtk-config --libs` `glib-config --libs` -lm $(CXXFLAGS)
-+BUILDFLAGS = -L${LOCALBASE}/lib -lvorbis -lvorbisfile `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` -lm $(CXXFLAGS)
- #comment out below and comment above to enable experimental gtk2 ui
- #BUILDFLAGS = -Wall -lvorbis -lvorbisfile `pkg-config --cflags gtk+-2.0` `pkg-config --libs gtk+-2.0` -lm $(CXXFLAGS)
+-BUILDFLAGS = -Wall -lvorbis -lvorbisfile -logg `glib-config --cflags` `gtk-config --cflags` `gtk-config --libs` `glib-config --libs` -lm $(BFLAGS)
++BUILDFLAGS = -L${LOCALBASE}/lib -lvorbis -lvorbisfile -logg `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` -lm $(BFLAGS)
+ #comment out below to enable experimental gtk2 ui
+ #BUILDFLAGS = -Wall -lvorbis -lvorbisfile -logg `pkg-config --cflags gtk+-2.0` `pkg-config --libs gtk+-2.0` -lm $(BFLAGS)
--TBUILD2FLAGS = -Wall -lm $(CXXFLAGS)
-+TBUILD2FLAGS = -lm $(CXXFLAGS)
-
--BUILD2FLAGS = -Wall `glib-config --cflags` `gtk-config --cflags` `gtk-config --libs` `glib-config --libs` -lm $(CXXFLAGS)
-+BUILD2FLAGS = `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` -lm $(CXXFLAGS)
- #comment out below and comment above to enable experimental gtk2 ui
- #BUILD2FLAGS = -Wall `pkg-config --cflags gtk+-2.0` `pkg-config --libs gtk+-2.0` -lm $(CXXFLAGS)
+-BUILD2FLAGS = -Wall `glib-config --cflags` `gtk-config --cflags` `gtk-config --libs` `glib-config --libs` -lm $(BFLAGS)
++BUILD2FLAGS = `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` -lm $(BFLAGS)
+ #comment out below to enable experimental gtk2 ui
+ #BUILD2FLAGS = -Wall `pkg-config --cflags gtk+-2.0` `pkg-config --libs gtk+-2.0` -lm $(BFLAGS)
#To disable Vorbis support, comment out next line
-VORBIS = -DVORBIS
@@ -29,7 +23,18 @@
#To compile text only utility, comment out next line
GTK = -DGTK
- CPPFLAGS = -Wall -DVERSION=\"$(VER)\" $(VORBIS)
+
+ #Text ui for win32 and *nix (only built when GTK is commented out)
+-TBUILDFLAGS = -Wall -lvorbis -lvorbisfile -lm $(BFLAGS)
+-TBUILD2FLAGS = -Wall -lm $(BFLAGS)
++TBUILDFLAGS = -L${LOCALBASE}/lib -lvorbis -lvorbisfile -lm $(BFLAGS)
++TBUILD2FLAGS = -lm $(BFLAGS)
+
+ #Win32 gtk build flags. Uncomment these when building in win32 (only tested with gtk2)
+ #prebuilt vorbis and ogg libs found at xiph.org do not seem to work when used with cygwin
+@@ -38,6 +40,6 @@
+
+ CPPFLAGS = -Wall -DVERSION=\"$(VER)\" $(VORBIS) $(WIN32)
-CXX = g++
+#CXX = g++
diff --git a/audio/mp3stat/files/patch-Makefile.rules b/audio/mp3stat/files/patch-Makefile.rules
index fc8e80c7e473..28e14a4b01fb 100644
--- a/audio/mp3stat/files/patch-Makefile.rules
+++ b/audio/mp3stat/files/patch-Makefile.rules
@@ -1,30 +1,30 @@
---- Makefile.rules.orig Fri Mar 22 17:00:23 2002
-+++ Makefile.rules Sat Mar 23 02:51:37 2002
-@@ -18,63 +18,26 @@
- WEBPAGE = "http://safemode.homeip.net"
+--- Makefile.rules.orig Tue Mar 26 14:21:02 2002
++++ Makefile.rules Tue Mar 26 14:22:36 2002
+@@ -18,63 +18,25 @@
+ WEBPAGE = "http://safemode.homeip.net"
all:
- @if test -n "$(VORBIS)"; then \
- echo "";\
- echo "___ building backend ___";\
-- echo "Using flags: $(CXXFLAGS)";\
+- echo "Using flags: $(BFLAGS)";\
- echo "";\
- echo "building $(OBJ)";\
-- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -c -o $(OBJ) $(OBJSRC);\
+- $(CXX) $(BFLAGS) $(CPPFLAGS) -c -o $(OBJ) $(OBJSRC);\
- echo "building $(OBJ2)";\
-- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -c -o $(OBJ2) $(OBJ2SRC);\
+- $(CXX) $(BFLAGS) $(CPPFLAGS) -c -o $(OBJ2) $(OBJ2SRC);\
- echo "";\
- echo "___ building frontend ___";\
- if test -n "$(GTK)"; then \
-- echo "Using flags: $(CXXFLAGS) $(BUILDFLAGS)";\
+- echo "Using flags: $(BUILDFLAGS)";\
- echo "";\
- echo "building and linking $(TARGET)";\
-- $(CXX) $(BUILDFLAGS) $(CPPFLAGS) -o $(TARGET) $(SRC) $(OBJ) $(OBJ2);\
+- $(CXX) $(CPPFLAGS) -o $(TARGET) $(SRC) $(OBJ) $(OBJ2) $(BUILDFLAGS);\
- else \
-- echo "Using flags: $(CXXFLAGS) $(TBUILDFLAGS)";\
+- echo "Using flags: $(TBUILDFLAGS)";\
- echo "";\
- echo "building and linking $(TARGET)";\
-- $(CXX) $(TBUILDFLAGS) $(CPPFLAGS) -o $(TARGET) $(TSRC) $(OBJ) $(OBJ2);\
+- $(CXX) $(CPPFLAGS) -o $(TARGET) $(TSRC) $(OBJ) $(OBJ2) $(TBUILDFLAGS);\
- fi\
- else \
- echo "";\
@@ -32,19 +32,19 @@
- echo "Using flags: $(CXXFLAGS)";\
- echo "";\
- echo "building $(OBJ)";\
-- $(CXX) $(CXXFLAGS) $(CPPFLAGS) -c -o $(OBJ) $(OBJSRC);\
+- $(CXX) $(BFLAGS) $(CPPFLAGS) -c -o $(OBJ) $(OBJSRC);\
- echo "";\
- echo "___ building frontend ___";\
- if test -n "$(GTK)"; then \
-- echo "Using flags: $(CXXFLAGS) $(BUILD2FLAGS)";\
+- echo "Using flags: $(BUILD2FLAGS)";\
- echo "";\
- echo "building and linking $(TARGET)";\
-- $(CXX) $(BUILD2FLAGS) $(CPPFLAGS) -o $(TARGET) $(SRC) $(OBJ);\
+- $(CXX) $(CPPFLAGS) -o $(TARGET) $(SRC) $(OBJ) $(BUILD2FLAGS);\
- else \
-- echo "Using flags: $(CXXFLAGS) $(TBUILD2FLAGS)";\
+- echo "Using flags: $(TBUILD2FLAGS)";\
- echo "";\
- echo "building and linking $(TARGET)";\
-- $(CXX) $(TBUILD2FLAGS) $(CPPFLAGS) -o $(TARGET) $(TSRC) $(OBJ);\
+- $(CXX) $(CPPFLAGS) -o $(TARGET) $(TSRC) $(OBJ) $(TBUILD2FLAGS);\
- fi\
- fi
- @echo " "
@@ -53,7 +53,7 @@
- @echo "to disable edit Makefile and comment VORBIS"
- @echo " "
- @echo "gtk 1.2 ui built by default, to enable"
-- @echo "gtk 2.0 ui, read the Makefile"
+- @echo "gtk 2.0 ui read the Makefile"
- @echo "To disable, edit Makefile and comment GTK"
- @echo "-------------------------------------------"
+ifdef VORBIS
@@ -79,5 +79,5 @@
install:
- strip $(TARGET)
- cp $(TARGET) /usr/local/bin
+-
+ ${BSD_INSTALL_PROGRAM} $(TARGET) ${PREFIX}/bin
-