aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg123
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>1998-11-25 01:30:34 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>1998-11-25 01:30:34 +0000
commit0d64b3f06580a841b409e780b49a1b058a0cdf7d (patch)
treeceb5155f60c0ce2a0815f838dc0cba7b1954f1d2 /audio/mpg123
parent2f6559eaa9f607f39b2c6604722ecfbfd80aae0f (diff)
downloadports-0d64b3f06580a841b409e780b49a1b058a0cdf7d.tar.gz
ports-0d64b3f06580a841b409e780b49a1b058a0cdf7d.zip
Add a call to fpsetmask(3) to suppress FP related signals {new 'patch-ab'}.
The patch can probably be made less specific to FreeBSD; to be visited after the 2.2.8 ports freeze ... Tweak work/.../Makefile to add -O2 to compiles. Submitted by: Matthew Hunt <mph@FreeBSD.ORG>
Notes
Notes: svn path=/head/; revision=14885
Diffstat (limited to 'audio/mpg123')
-rw-r--r--audio/mpg123/files/patch-aa8
-rw-r--r--audio/mpg123/files/patch-ab25
2 files changed, 29 insertions, 4 deletions
diff --git a/audio/mpg123/files/patch-aa b/audio/mpg123/files/patch-aa
index 4ace488fe52f..b74ce8d7b4f9 100644
--- a/audio/mpg123/files/patch-aa
+++ b/audio/mpg123/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Feb 9 02:23:04 1998
-+++ Makefile Sat Nov 14 22:58:27 1998
+--- Makefile.orig Sun Feb 8 23:53:04 1998
++++ Makefile Wed Nov 25 07:05:28 1998
@@ -21,6 +21,7 @@
@echo ""
@echo "make linux-help Linux, more help"
@@ -14,7 +14,7 @@
OBJECTS='decode_i386.o dct64_i386.o getbits_.o audio_oss.o' \
- CFLAGS='-Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
- -funroll-all-loops -ffast-math -DROT_I386 \
-+ CFLAGS+='-Wall -ansi -pedantic -fomit-frame-pointer \
++ CFLAGS+='-Wall -O2 -ansi -pedantic -fomit-frame-pointer \
+ -funroll-all-loops -ffast-math -DROT_I386 -DREAD_MMAP \
+ -DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP -DOSS' \
+ mpg123-make
@@ -22,7 +22,7 @@
+freebsd-elf:
+ $(MAKE) CC=cc LDFLAGS= \
+ OBJECTS='decode_i386.o dct64_i386.o getbits.o audio_oss.o' \
-+ CFLAGS+='-Wall -ansi -pedantic -fomit-frame-pointer \
++ CFLAGS+='-Wall -O2 -ansi -pedantic -fomit-frame-pointer \
+ -funroll-all-loops -ffast-math -DROT_I386 -DREAD_MMAP \
-DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP -DOSS' \
mpg123-make
diff --git a/audio/mpg123/files/patch-ab b/audio/mpg123/files/patch-ab
new file mode 100644
index 000000000000..638ff0c92c2a
--- /dev/null
+++ b/audio/mpg123/files/patch-ab
@@ -0,0 +1,25 @@
+--- mpg123.c.orig Tue Nov 24 08:46:40 1998
++++ mpg123.c Tue Nov 24 08:47:25 1998
+@@ -14,6 +14,10 @@
+ #include <sys/resource.h>
+ #endif
+
++#ifdef __FreeBSD__
++#include <floatingpoint.h>
++#endif
++
+ /* #define SET_PRIO */
+
+ #include "mpg123.h"
+@@ -652,6 +656,10 @@
+
+ #ifdef OS2
+ _wildcard(&argc,&argv);
++#endif
++
++#ifdef __FreeBSD__
++ fpsetmask(0);
+ #endif
+
+ if(sizeof(short) != 2) {
+