aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg123
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-26 07:37:49 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-26 07:37:49 +0000
commit3c806f4c9f925b771ad2e3ceeaea682d518e78ad (patch)
tree8da2e8ff9afde4d93f4da4b1c0bed48767bdb260 /audio/mpg123
parent88c1dba56d75925fca76762a4d6f79853eeef7bc (diff)
downloadports-3c806f4c9f925b771ad2e3ceeaea682d518e78ad.tar.gz
ports-3c806f4c9f925b771ad2e3ceeaea682d518e78ad.zip
Support IPv6.
No response from: maintainer
Notes
Notes: svn path=/head/; revision=25090
Diffstat (limited to 'audio/mpg123')
-rw-r--r--audio/mpg123/Makefile10
-rw-r--r--audio/mpg123/distinfo1
-rw-r--r--audio/mpg123/files/patch-aa32
3 files changed, 30 insertions, 13 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 9036b9b4d34e..ab9c60e71265 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -7,12 +7,16 @@
#
DISTNAME= mpg123-0.59r
-CATEGORIES= audio
+CATEGORIES= audio ipv6
MASTER_SITES= http://www.mpg123.de/mpg123/ \
http://www-ti.informatik.uni-tuebingen.de/~hippm/mpg123/ \
ftp://ftp.tu-clausthal.de/pub/unix/audio/mpg123/ \
http://ftp.tu-clausthal.de/pub/unix/audio/mpg123/
+PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
+PATCHFILES= mpg123-059r-v6-20000111.diff.gz
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= jkoshy@freebsd.org
.if defined(OPT_ESOUND)
@@ -25,6 +29,10 @@ MAN1= mpg123.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 400014
+MAKE_ENV+= USE_INET6=yes
+.endif
+
.if defined(OPT_ESOUND)
ALL_TARGET= freebsd-esd
.else
diff --git a/audio/mpg123/distinfo b/audio/mpg123/distinfo
index e99967eaf0b4..72595c6eb2f1 100644
--- a/audio/mpg123/distinfo
+++ b/audio/mpg123/distinfo
@@ -1 +1,2 @@
MD5 (mpg123-0.59r.tar.gz) = 95df59ad1651dd2346d49fafc83747e7
+MD5 (mpg123-059r-v6-20000111.diff.gz) = e563e5fe1276cc1e8a9b01aef53dda6d
diff --git a/audio/mpg123/files/patch-aa b/audio/mpg123/files/patch-aa
index a4c7c77010fd..af38385d757e 100644
--- a/audio/mpg123/files/patch-aa
+++ b/audio/mpg123/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.orig Wed Jun 16 02:09:06 1999
-+++ Makefile Thu Nov 11 10:21:40 1999
-@@ -4,7 +4,7 @@
+--- Makefile.orig Tue Jan 11 05:17:23 2000
++++ Makefile Tue Jan 11 05:18:07 2000
+@@ -4,13 +4,15 @@
# Where to install binary and manpage on "make install":
@@ -9,9 +9,18 @@
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/man
SECTION=1
-@@ -285,35 +285,42 @@
- #CFLAGS='-DI386_ASSEM -O2 -DREAL_IS_FLOAT -DLINUX -Wall -g'
- #CFLAGS='-DI386_ASSEM -DREAL_IS_FLOAT -DLINUX -Wall -O2 -m486 -fomit-frame-pointer -funroll-all-loops -finline-functions -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2'
+
+ # Enable the below line If your plathome support IPv6
+-#CFLAGS+= -DINET6
++.if defined(USE_INET6)
++CFLAGS+= -DINET6
++.endif
+ # Additional LIBDIR and libraries if exist
+ IPV6LIBDIR=
+ IPV6LIB=
+@@ -300,35 +302,42 @@
+ #CFLAGS='$(CFLAGS) -DI386_ASSEM -O2 -DREAL_IS_FLOAT -DLINUX -Wall -g'
+ #CFLAGS='$(CFLAGS) -DI386_ASSEM -DREAL_IS_FLOAT -DLINUX -Wall -O2 -m486 -fomit-frame-pointer -funroll-all-loops -finline-functions -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2'
+CC ?= cc
+LDFLAGS =
@@ -40,19 +49,18 @@
freebsd:
- $(MAKE) CC=cc LDFLAGS= \
- OBJECTS='decode_i386.o dct64_i386.o audio_oss.o' \
-- CFLAGS='-Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
+- CFLAGS='$(CFLAGS) -Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
- -funroll-all-loops -ffast-math -DROT_I386 \
- -DREAD_MMAP \
- -DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP -DOSS' \
-- mpg123-make
+ ${MAKE} OBJECTS='decode_i386.o ${ARCHFILES} dct64_i386.o audio_oss.o term.o' \
-+ mpg123-make
+ mpg123-make
freebsd-esd:
- $(MAKE) CC=cc LDFLAGS= \
- AUDIO_LIB='-lesd -laudiofile' \
- OBJECTS='decode_i386.o dct64_i386.o $(GETBITS) audio_esd.o' \
-- CFLAGS='-Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
+- CFLAGS='$(CFLAGS) -Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
- -funroll-all-loops -ffast-math -DROT_I386 \
- -DREAD_MMAP \
- -DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP -DOSS \
@@ -67,14 +75,14 @@
- OBJECTS='decode_i386.o dct64_i386.o audio_oss.o \
+ $(MAKE) OBJECTS='decode_i386.o ${ARCHFILES} dct64_i386.o audio_oss.o \
control_sajber.o control_tk3play.o' \
-- CFLAGS='-Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
+- CFLAGS='$(CFLAGS) -Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
- -funroll-all-loops -ffast-math -DROT_I386 \
- -DFRONTEND \
- -DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP -DOSS' \
$(FRONTEND)
-@@ -552,7 +559,7 @@
+@@ -567,7 +576,7 @@
@ $(MAKE) CFLAGS='$(CFLAGS)' BINNAME=mpg123m mpg123
mpg123-make: