aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg123
diff options
context:
space:
mode:
authorTom Rhodes <trhodes@FreeBSD.org>2004-09-11 04:55:48 +0000
committerTom Rhodes <trhodes@FreeBSD.org>2004-09-11 04:55:48 +0000
commit3b3f21b3624e40cbbc5a4a9abac8ff5a796bf5de (patch)
treea3b4f2c2b94b5203492a6e45a0f35335c20e2e8f /audio/mpg123
parent2fff28a2e431faf90f2aa71013e28cd8f60da51c (diff)
downloadports-3b3f21b3624e40cbbc5a4a9abac8ff5a796bf5de.tar.gz
ports-3b3f21b3624e40cbbc5a4a9abac8ff5a796bf5de.zip
Fix recently found bug.
Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer) Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=118147
Diffstat (limited to 'audio/mpg123')
-rw-r--r--audio/mpg123/Makefile2
-rw-r--r--audio/mpg123/files/patch-layer2.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index d2b516260a4c..8976b8e02972 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpg123
PORTVERSION= 0.59r
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= audio ipv6
MASTER_SITES= http://www.mpg123.de/mpg123/ \
http://www-ti.informatik.uni-tuebingen.de/~hippm/mpg123/
diff --git a/audio/mpg123/files/patch-layer2.c b/audio/mpg123/files/patch-layer2.c
new file mode 100644
index 000000000000..f87a4ff36913
--- /dev/null
+++ b/audio/mpg123/files/patch-layer2.c
@@ -0,0 +1,14 @@
+diff -u -r1.1.1.1 layer2.c
+--- layer2.c 1999/02/10 12:13:06 1.1.1.1
++++ layer2.c 2004/09/02 21:43:58
+@@ -265,6 +265,11 @@
+ fr->jsbound = (fr-&gt;>mode == MPG_MD_JOINT_STEREO) ?
+ (fr->mode_ext<<2)+4 : fr->II_sblimit;
+
++ if (fr->jsbound > fr->II_sblimit) {
++ fprintf(stderr, "Truncating stereo boundary to sideband limit.\n");
++ fr->jsbound=fr->II_sblimit;
++ }
++
+ if(stereo == 1 || single == 3)
+ single = 0;