aboutsummaryrefslogtreecommitdiff
path: root/audio/muine
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2005-11-10 04:40:30 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2005-11-10 04:40:30 +0000
commite36417a73f4e01defa542203fe249bc6c1490628 (patch)
treea4aa947f285bc5e5233ea787851ae33c8cd442be /audio/muine
parentdac91cd696829e906b3062113475a7fcbefe477d (diff)
downloadports-e36417a73f4e01defa542203fe249bc6c1490628.tar.gz
ports-e36417a73f4e01defa542203fe249bc6c1490628.zip
- Add fix for updated gtk# (patch-src_PlaylistWindow.cs: Muine mailing list)
- Correct pkg-plist for gacutil changes with Mono 1.1.9.x - Include bsd.mono.mk. Approved by: ahze (mentor) Project by: BSD# <http://www.mono-project.com/Mono:FreeBSD>
Notes
Notes: svn path=/head/; revision=147794
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile10
-rw-r--r--audio/muine/files/patch-src_PlaylistWindow.cs11
-rw-r--r--audio/muine/pkg-plist4
3 files changed, 21 insertions, 4 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index ae101478b206..db49130cb49d 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -3,11 +3,12 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.26 2005/06/30 01:05:54 tmclau02 Exp $
+# $Id: Makefile,v 1.39 2005/11/06 06:58:39 tmclau02 Exp $
+#
PORTNAME= muine
PORTVERSION= 0.8.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio gnome
MASTER_SITES= http://muine.gooeylinux.org/
@@ -25,7 +26,7 @@ RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
-USE_X_PREFIX= yes
+USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
@@ -46,7 +47,7 @@ CONFIGURE_ARGS+= --disable-faad2
.endif
.if defined (WITH_XINE)
-CONFIGURE_ARGS+= --enable-xine=yes
+CONFIGURE_ARGS+= --enable-xine=yes
LIB_DEPENDS+= xine.14:${PORTSDIR}/multimedia/libxine
.else
USE_GSTREAMER+= gconf
@@ -62,4 +63,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/plugins/${_plugin} ${PREFIX}/lib/muine/plugins
.endfor
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.post.mk>
diff --git a/audio/muine/files/patch-src_PlaylistWindow.cs b/audio/muine/files/patch-src_PlaylistWindow.cs
new file mode 100644
index 000000000000..410ecd0e949d
--- /dev/null
+++ b/audio/muine/files/patch-src_PlaylistWindow.cs
@@ -0,0 +1,11 @@
+--- src/PlaylistWindow.cs.orig Sun May 1 12:25:15 2005
++++ src/PlaylistWindow.cs Fri Sep 9 20:12:56 2005
+@@ -431,7 +431,7 @@
+ public void RestorePlaylist ()
+ {
+ // Load last playlist
+- if (!File.Exists (FileUtils.PlaylistFile))
++ if (!System.IO.File.Exists (FileUtils.PlaylistFile))
+ return;
+
+ OpenPlaylistInternal (FileUtils.PlaylistFile,
diff --git a/audio/muine/pkg-plist b/audio/muine/pkg-plist
index 548b325bd21e..d095568116d0 100644
--- a/audio/muine/pkg-plist
+++ b/audio/muine/pkg-plist
@@ -2,7 +2,11 @@ bin/muine
lib/mono/gac/muine-dbus/1.0.0.0__e6bf890338fa2913/muine-dbus.dll
lib/mono/gac/muine-plugin/1.0.0.0__e6bf890338fa2913/muine-plugin.dll
lib/mono/muine/muine-dbus.dll
+lib/mono/muine/muine-dbus.dll.config
+lib/mono/muine/muine-dbus.dll.mdb
lib/mono/muine/muine-plugin.dll
+lib/mono/muine/muine-plugin.dll.config
+lib/mono/muine/muine-plugin.dll.mdb
lib/monodoc/sources/muine-docs.source
lib/monodoc/sources/muine-docs.tree
lib/monodoc/sources/muine-docs.zip