aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd/Makefile
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-07-27 12:20:34 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-07-27 12:20:34 +0000
commit82aae15304aca8b3a2f3fe3af52beff1bc22aa93 (patch)
tree7a52e65b4527b4c6e76f06fca93700c9912cacc1 /audio/musicpd/Makefile
parent985a98e4f1849f5406f755be6dae6cfcc9b537ac (diff)
downloadports-82aae15304aca8b3a2f3fe3af52beff1bc22aa93.tar.gz
ports-82aae15304aca8b3a2f3fe3af52beff1bc22aa93.zip
- Update to 0.15 [1]
- Add new config knobs [1] - Add dependency on libcurl [2] - Use PLIST_FILES and PORTDOCS instead pkg-plist PR: ports/136305 [1], ports/131991 [2] Submitted by: David Horn <dhorn2000 AT gmail.com> [1], Rick Dicaire <kritek AT gmail.com> [2] Approved by: maintainer timeout, tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=238436
Diffstat (limited to 'audio/musicpd/Makefile')
-rw-r--r--audio/musicpd/Makefile85
1 files changed, 67 insertions, 18 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 38ac6207ae22..0634cf4184a8 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= musicpd
-PORTVERSION= 0.14.2
-PORTREVISION= 1
+PORTVERSION= 0.15
CATEGORIES= audio ipv6
MASTER_SITES= SF
DISTNAME= mpd-${PORTVERSION}
@@ -15,7 +14,8 @@ DISTNAME= mpd-${PORTVERSION}
MAINTAINER= jo.lindqvist@gmail.com
COMMENT= A remote-controllable music daemon
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad \
+ curl.5:${PORTSDIR}/ftp/curl
USE_GMAKE= yes
USE_BZIP2= yes
@@ -32,24 +32,32 @@ MAN1= mpd.1
MAN5= mpd.conf.5
DOCSDIR= ${PREFIX}/share/doc/mpd
+PORTDOCS= mpdconf.example AUTHORS README COPYING NEWS UPGRADING
SUB_FILES= pkg-message
-OPTIONS= FLAC "Support FLAC audio format" on \
- VORBIS "Support OGG Vorbis audio format" on \
+PLIST_FILES= bin/mpd
+
+OPTIONS= ID3TAG "Support ID3 v1/v2 tags" on \
+ IPV6 "Support IPv6 protocol" on \
+ FLAC "Support FLAC audio format" on \
+ VORBIS "Support OGG Vorbis audio format" on \
+ WAV "Support WAV audio format" on \
+ FFMPEG "Support FFMPEG (wma aiff ac3 ape...)" on \
TREMOR "Support Tremor (integer-only Vorbis)" off \
- WAV "Support WAV audio format" on \
AAC "Support MP4/AAC audio format" off \
MUSEPACK "Support MPC audio format" off \
- MOD "Support MOD audio format" off \
- FFMPEG "Support FFMPEG (wma aiff ac3 ape...)" on \
- ID3TAG "Support ID3 v1/v2 tags" on \
- IPV6 "Support IPv6 protocol" on \
+ MIKMOD "Support MOD audio format" off \
+ MODPLUG "Support MODPLUG decoder" off \
+ ARCHIVE "Support bzip2/zip/iso9660 archive" off \
+ MMS "Support MMS stream input" off \
+ LASTFM "Support Last.FM stream input (experimental)" off \
AO "Support libao audio library" off \
PULSEAUDIO "Support PulseAudio sound server" off \
JACK "Support JACK audio server" off \
SHOUTCAST "Support for OGG Icecast and Shoutcast" off \
LAME "Support for MP3 Icecast Streams" off \
+ HTTPD "Support for httpd output streaming" off \
SAMPLERATE "Support sample rate conversion" off
.include <bsd.port.pre.mk>
@@ -62,7 +70,7 @@ LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.endif
.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+=--disable-oggvorbis
+CONFIGURE_ARGS+=--disable-vorbis
.else
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
.endif
@@ -79,10 +87,17 @@ CONFIGURE_ARGS+=--disable-aac
.endif
.if defined(WITH_LAME)
-CONFIGURE_ARGS+=--enable-shout-mp3
+CONFIGURE_ARGS+=--enable-lame-encoder \
+ --enable-shout
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
-CONFIGURE_ARGS+=--disable-shout-mp3
+CONFIGURE_ARGS+=--disable-lame-encoder
+.endif
+
+.if defined(WITH_HTTPD)
+CONFIGURE_ARGS+=--enable-httpd-output
+.else
+CONFIGURE_ARGS+=--disable-httpd-output
.endif
.if defined(WITHOUT_WAV)
@@ -97,10 +112,26 @@ LIB_DEPENDS+= mpcdec.5:${PORTSDIR}/audio/libmpcdec
CONFIGURE_ARGS+=--disable-mpc
.endif
-.if defined(WITH_MOD)
+.if defined(WITH_MIKMOD)
LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+CONFIGURE_ARGS+=--enable-mikmod
.else
-CONFIGURE_ARGS+=--disable-mod
+CONFIGURE_ARGS+=--disable-mikmod
+.endif
+
+.if defined(WITH_MODPLUG)
+LIB_DEPENDS+= modplug.0:${PORTSDIR}/audio/libmodplug
+CONFIGURE_ARGS+=--enable-modplug
+.else
+CONFIGURE_ARGS+=--disable-modplug
+.endif
+
+.if defined(WITH_ARCHIVE)
+CONFIGURE_ARGS+=--enable-bzip2 \
+ --enable-zip \
+ --enable-iso9660
+LIB_DEPENDS+= zzip.13:${PORTSDIR}/devel/zziplib \
+ iso9660.5:${PORTSDIR}/sysutils/libcdio
.endif
.if defined(WITHOUT_FFMPEG)
@@ -111,6 +142,19 @@ LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
avutil.1:${PORTSDIR}/multimedia/ffmpeg
.endif
+.if defined(WITH_LASTFM)
+CONFIGURE_ARGS+=--enable-lastfm
+.else
+CONFIGURE_ARGS+=--disable-lastfm
+.endif
+
+.if defined(WITH_MMS)
+CONFIGURE_ARGS+=--enable-mms
+LIBDEPENDS+= libmms.0:${PORTSDIR}/net/libmms
+.else
+CONFIGURE_ARGS+=--disable-mms
+.endif
+
.if defined(WITHOUT_ID3TAG)
CONFIGURE_ARGS+=--disable-id3
.else
@@ -124,6 +168,8 @@ CONFIGURE_ARGS+=--disable-ipv6
.if defined(WITH_AO)
CONFIGURE_ARGS+=--enable-ao
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+.else
+CONFIGURE_ARGS+=--disable-ao
.endif
.if defined(WITH_PULSEAUDIO)
@@ -142,20 +188,23 @@ CONFIGURE_ARGS+=--disable-jack
# also with tremor since the latter does not support vorbis encoding
.if defined(WITH_SHOUTCAST) && !defined(WITH_TREMOR)
LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
+CONFIGURE_ARGS+=--enable-vorbis-encoder \
+ --enable-shout
.else
-CONFIGURE_ARGS+=--disable-shout-ogg
+CONFIGURE_ARGS+=--disable-vorbis-encoder
.endif
.if defined(WITHOUT_SAMPLERATE)
CONFIGURE_ARGS+=--disable-lsr
.else
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+CONFIGURE_ARGS+=--enable-lsr
.endif
.if defined(NOPORTDOCS)
post-patch:
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-docDATA||' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's|install-docDATA ||' \
+ ${WRKSRC}/Makefile.in
.endif
post-install: