aboutsummaryrefslogtreecommitdiff
path: root/audio/napster/Makefile
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>1999-11-18 09:17:15 +0000
committerDonald Burr <dburr@FreeBSD.org>1999-11-18 09:17:15 +0000
commit9663daef38f5e2874ae6aab37930cea67a06df4d (patch)
tree6faabe7af386d767ee65626ad4d4a93d2431e72f /audio/napster/Makefile
parent6ddc61a49947e1302d373fe8a1ef8dfcdf5c33cb (diff)
downloadports-9663daef38f5e2874ae6aab37930cea67a06df4d.tar.gz
ports-9663daef38f5e2874ae6aab37930cea67a06df4d.zip
New port napster, an MP3 search engine/file sharing tool/chat client
type thinigie. Kinda hard to explain. :)
Notes
Notes: svn path=/head/; revision=23179
Diffstat (limited to 'audio/napster/Makefile')
-rw-r--r--audio/napster/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/audio/napster/Makefile b/audio/napster/Makefile
new file mode 100644
index 000000000000..8d39e95d658f
--- /dev/null
+++ b/audio/napster/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: napster
+# Version required: 0.6b
+# Date created: Thu Nov 18 01:07:00 PST 1999
+# Whom: dburr@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+DISTNAME= nap-linux-0.6BETA
+PKGNAME= napster-0.6b
+CATEGORIES= audio net
+MASTER_SITES= http://www.gis.net/~nite/
+
+MAINTAINER= dburr@FreeBSD.org
+
+RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
+
+ONLY_FOR_ARCHS= i386
+WRKSRC= ${WRKDIR}/nap
+NO_BUILD= yes
+
+do-patch:
+ brandelf -t Linux ${WRKSRC}/nap
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nap ${PREFIX}/bin/nap
+ ${MKDIR} ${PREFIX}/share/nap
+ ${INSTALL_DATA} ${WRKSRC}/nap.conf ${PREFIX}/share/nap
+.if (!defined(NOPORTDOCS))
+ @${ECHO_MSG} "===> Installing README in ${PREFIX}/share/doc/nap"
+ ${MKDIR} ${PREFIX}/share/doc/nap
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/nap
+.endif
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>