aboutsummaryrefslogtreecommitdiff
path: root/audio/openspc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 12:39:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 12:39:11 +0000
commit202b9a5b244f70654d12daf1e1e2efed4603473c (patch)
tree7d93823208767eb16ba626396ae911f2406aa64a /audio/openspc
parent30f6e5094417902a71aa0dc88073644327379bfa (diff)
downloadports-202b9a5b244f70654d12daf1e1e2efed4603473c.tar.gz
ports-202b9a5b244f70654d12daf1e1e2efed4603473c.zip
OpenSPC is an SPC command line player created using a very modified SNEeSe SPC
CPU core. It was written in C (although the SPC core is in Assembly) using DJGPP. PR: ports/83222 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=139069
Diffstat (limited to 'audio/openspc')
-rw-r--r--audio/openspc/Makefile31
-rw-r--r--audio/openspc/distinfo2
-rw-r--r--audio/openspc/pkg-descr8
3 files changed, 41 insertions, 0 deletions
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
new file mode 100644
index 000000000000..7c2e971b6373
--- /dev/null
+++ b/audio/openspc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: openspc
+# Date created: 10 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openspc
+PORTVERSION= 0.3.1
+CATEGORIES= audio
+MASTER_SITES= http://membres.lycos.fr/pixels/
+DISTNAME= OpenSPC-${PORTVERSION}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line player for .spc and .zst files
+
+ONLY_FOR_ARCHS= i386 # contains x86 asm code
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=13
+
+PORTDOCS= README
+PLIST_FILES= bin/OpenSPClite include/OpenSPC.h lib/libOpenSPC.so lib/libOpenSPC.so.3 \
+ lib/libOpenSPC.la lib/libOpenSPC.a
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/openspc/distinfo b/audio/openspc/distinfo
new file mode 100644
index 000000000000..e26e3d428d24
--- /dev/null
+++ b/audio/openspc/distinfo
@@ -0,0 +1,2 @@
+MD5 (OpenSPC-0.3.1.tar.gz) = f39d88694eb31341420572872b1743c8
+SIZE (OpenSPC-0.3.1.tar.gz) = 155358
diff --git a/audio/openspc/pkg-descr b/audio/openspc/pkg-descr
new file mode 100644
index 000000000000..48cc23d847d4
--- /dev/null
+++ b/audio/openspc/pkg-descr
@@ -0,0 +1,8 @@
+OpenSPC is an SPC command line player created using a very modified SNEeSe SPC
+CPU core. It was written in C (although the SPC core is in Assembly) using
+DJGPP.
+
+WWW: http://membres.lycos.fr/pixels/OpenSPC.html
+
+- ehaupt
+ehaupt@critical.ch