aboutsummaryrefslogtreecommitdiff
path: root/audio/orpheus
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-04-27 10:30:10 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-04-27 10:30:10 +0000
commit4c165134cbc642e1251b42fc2e6eed430d3ef0d5 (patch)
tree226c5f0a2ac054eb7e713dbff25bfa9a7a7f8159 /audio/orpheus
parent2bad4f4ce0760b14c9e3731e58ef50e9979bcdb0 (diff)
downloadports-4c165134cbc642e1251b42fc2e6eed430d3ef0d5.tar.gz
ports-4c165134cbc642e1251b42fc2e6eed430d3ef0d5.zip
- fix segfault on attempt to play next track from empty playlist [1]
- make mpg321 be RUN_DEPEND instead of BUILD_DEPEND PR: 80365 [1] Submitted by: Andrej Zverev (maintainer)
Notes
Notes: svn path=/head/; revision=134245
Diffstat (limited to 'audio/orpheus')
-rw-r--r--audio/orpheus/Makefile5
-rw-r--r--audio/orpheus/files/patch-src-uitext.cc26
2 files changed, 25 insertions, 6 deletions
diff --git a/audio/orpheus/Makefile b/audio/orpheus/Makefile
index a3780ac2687d..b94e970b62cf 100644
--- a/audio/orpheus/Makefile
+++ b/audio/orpheus/Makefile
@@ -7,13 +7,14 @@
PORTNAME= orpheus
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://thekonst.net/download/
MAINTAINER= az@inec.ru
COMMENT= Light-weight console UI audio player application
-BUILD_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321
+RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -37,7 +38,7 @@ CONFIGURE_ARGS+= --enable-ghttp
.endif
.if defined(WITH_VORBIS)
-RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools
+RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --enable-vorbis
diff --git a/audio/orpheus/files/patch-src-uitext.cc b/audio/orpheus/files/patch-src-uitext.cc
index 72f1651dd0ca..7c57ca49adfa 100644
--- a/audio/orpheus/files/patch-src-uitext.cc
+++ b/audio/orpheus/files/patch-src-uitext.cc
@@ -1,6 +1,24 @@
---- src/uitext.cc Tue Feb 17 04:18:21 2004
-+++ src/uitext.cc Sun Dec 12 22:12:41 2004
-@@ -577,14 +577,16 @@
+diff -Nru src.orig/uitext.cc src/uitext.cc
+--- src.orig/uitext.cc Tue Feb 17 04:18:21 2004
++++ src/uitext.cc Tue Apr 26 19:49:01 2005
+@@ -125,6 +125,8 @@
+ }
+
+ void OrpheusTextUI::nexttrack() {
++ if (!plist.empty())
++ {
+ if(conf.getplaymode() == Random) {
+ int k;
+ while(*(plist.begin()+(k = randlimit(0, plist.size()-1))) == currenttrack);
+@@ -143,6 +145,7 @@
+ }
+ }
+ }
++ }
+ }
+
+ void OrpheusTextUI::prevtrack() {
+@@ -577,14 +580,16 @@
autosavepl = !autosavepl;
break;
case 41:
@@ -19,7 +37,7 @@
sortorder = byFileName;
break;
case 44:
-@@ -719,7 +721,8 @@
+@@ -719,7 +724,8 @@
while(!finished) {
m.clear();