aboutsummaryrefslogtreecommitdiff
path: root/audio/portaudio2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-03-04 18:02:45 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-03-04 18:02:45 +0000
commitb02ee49bcf9ed3cc67f8fd9f641e7e91e0bd8d25 (patch)
tree8c4f9a8202b1302531fb08bc42bcc669a5e89bd6 /audio/portaudio2
parent2258f2865647a5052d51fefb00dcc88958e77dd0 (diff)
downloadports-b02ee49bcf9ed3cc67f8fd9f641e7e91e0bd8d25.tar.gz
ports-b02ee49bcf9ed3cc67f8fd9f641e7e91e0bd8d25.zip
Upgrade to v19_20071207. This is the latest stable release.
The previous tarball portaudio-19.b1175 is dated Feb 11 2007. Note: the ancient port audio/portaudio should be deprecated, but it is still used by several ports; if you are still using it, please consider a migration towards portaudio2. Hint: if your port does not build with portaudio2, it may be outdated!
Notes
Notes: svn path=/head/; revision=229488
Diffstat (limited to 'audio/portaudio2')
-rw-r--r--audio/portaudio2/Makefile41
-rw-r--r--audio/portaudio2/distinfo6
-rw-r--r--audio/portaudio2/pkg-plist1
3 files changed, 34 insertions, 14 deletions
diff --git a/audio/portaudio2/Makefile b/audio/portaudio2/Makefile
index 4272c6bec400..a99747650b1f 100644
--- a/audio/portaudio2/Makefile
+++ b/audio/portaudio2/Makefile
@@ -6,25 +6,44 @@
#
PORTNAME= portaudio
-PORTVERSION= 19.b${SNAPREV}
+DISTVERSION= 19_20071207
CATEGORIES= audio
-MASTER_SITES= CENKES
-# svn export -rSNAPREV https://www.portaudio.com/repos/portaudio/branches/v19-devel
-LATEST_LINK= ${PORTNAME}2
+MASTER_SITES= http://www.portaudio.com/archives/
+DISTNAME= pa_stable_v${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Portable cross-platform Audio API
-SNAPREV= 1175
-USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static --without-alsa --without-jack --without-asihpi \
+CONFIGURE_ARGS= --without-alsa \
--libdir=${PREFIX}/lib/${PORTNAME}2 --includedir=${PREFIX}/include/${PORTNAME}2
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}2
-post-patch:
- @${GREP} -lre -lpthread ${WRKSRC}|${XARGS} ${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|'
- @${REINPLACE_CMD} -e '/pkgconfig/s|$$[(]libdir[)]|${PREFIX}/libdata|' ${WRKSRC}/Makefile.in
+LATEST_LINK= ${PORTNAME}2
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libjack.so)
+WITH_JACK= yes
+.endif
+.if !defined(WITH_JACK)
+CONFIGURE_ARGS+= --without-jack
+.else
+# Avoid a circular dependency
+CONFIGURE_ARGS+= --with-jack
+#LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+.endif
+
+pre-configure:
+# replace obsolete headers, and fix up thread library
+ ${FIND} ${WRKSRC} -type f \
+ | ${XARGS} -x -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's|malloc.h|stdlib.h|' \
+ -e 's|-lpthread|${PTHREAD_LIBS}|'
+ ${REINPLACE_CMD} -e '/pkgconfig/s|$$[(]libdir[)]|${PREFIX}/libdata|' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/portaudio2/distinfo b/audio/portaudio2/distinfo
index e4e45b9c26ee..acc2d055109e 100644
--- a/audio/portaudio2/distinfo
+++ b/audio/portaudio2/distinfo
@@ -1,3 +1,3 @@
-MD5 (portaudio-19.b1175.tar.bz2) = 64edb465b3997afda3533b2a73582b80
-SHA256 (portaudio-19.b1175.tar.bz2) = e3e9cd380d0d6ac201042e4e37606c0fc35c39ed7b1af614782c62ba8796a0fc
-SIZE (portaudio-19.b1175.tar.bz2) = 795225
+MD5 (pa_stable_v19_20071207.tar.gz) = d2943e4469834b25afe62cc51adc025f
+SHA256 (pa_stable_v19_20071207.tar.gz) = 06a17727d56d382a69036de2ed9aee9a15cac0329b995b8cfcd69b357f47bf2b
+SIZE (pa_stable_v19_20071207.tar.gz) = 1113282
diff --git a/audio/portaudio2/pkg-plist b/audio/portaudio2/pkg-plist
index 2bc5fa7cc783..c08fc50c55e9 100644
--- a/audio/portaudio2/pkg-plist
+++ b/audio/portaudio2/pkg-plist
@@ -1,4 +1,5 @@
include/portaudio2/portaudio.h
+lib/portaudio2/libportaudio.a
lib/portaudio2/libportaudio.la
lib/portaudio2/libportaudio.so
lib/portaudio2/libportaudio.so.2