aboutsummaryrefslogtreecommitdiff
path: root/audio/py-speex
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-20 10:42:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-20 10:42:32 +0000
commit2067d06e397de874c19d0fd3d4a69afa8d853829 (patch)
tree60bd11d9de6893f3a234faae6f07a7726d839f6f /audio/py-speex
parent92838820f81e0e026f42c73baf4d6f32e0efd844 (diff)
downloadports-2067d06e397de874c19d0fd3d4a69afa8d853829.tar.gz
ports-2067d06e397de874c19d0fd3d4a69afa8d853829.zip
- Strip library
- Pet portlint - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=394847
Diffstat (limited to 'audio/py-speex')
-rw-r--r--audio/py-speex/Makefile7
-rw-r--r--audio/py-speex/files/patch-setup.py6
-rw-r--r--audio/py-speex/files/patch-speex.pyx8
3 files changed, 12 insertions, 9 deletions
diff --git a/audio/py-speex/Makefile b/audio/py-speex/Makefile
index 41210daff1e4..1c7891b7d1df 100644
--- a/audio/py-speex/Makefile
+++ b/audio/py-speex/Makefile
@@ -3,7 +3,7 @@
PORTNAME= speex
PORTVERSION= 0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio python
MASTER_SITES= http://freenet.mcnabhosting.com/python/pySpeex/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,10 +17,13 @@ BUILD_DEPENDS= pyrex>=0.9.6.2:${PORTSDIR}/devel/pyrex
LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/setup.py
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/speex.so
+
.include <bsd.port.mk>
diff --git a/audio/py-speex/files/patch-setup.py b/audio/py-speex/files/patch-setup.py
index 7c0ccbd89982..b685e56c3624 100644
--- a/audio/py-speex/files/patch-setup.py
+++ b/audio/py-speex/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig Sun Oct 30 13:10:14 2005
-+++ setup.py Sat Mar 3 00:40:44 2007
-@@ -5,9 +5,9 @@
+--- setup.py.orig 2005-10-30 12:10:14 UTC
++++ setup.py
+@@ -5,9 +5,9 @@ import sys
from distutils.core import setup, Extension
from Pyrex.Distutils import build_ext
diff --git a/audio/py-speex/files/patch-speex.pyx b/audio/py-speex/files/patch-speex.pyx
index 98d8385197e4..f50bb08b057c 100644
--- a/audio/py-speex/files/patch-speex.pyx
+++ b/audio/py-speex/files/patch-speex.pyx
@@ -1,6 +1,6 @@
---- speex.pyx.orig Sat Mar 3 00:32:39 2007
-+++ speex.pyx Sat Mar 3 00:33:01 2007
-@@ -365,7 +365,7 @@
+--- speex.pyx.orig 2003-11-24 05:29:33 UTC
++++ speex.pyx
+@@ -365,7 +365,7 @@ cdef class new:
bufOut[bufOutSiz] = nBytes % 256
bufOut[bufOutSiz+1] = nBytes / 256
bufOutSiz = bufOutSiz + 2
@@ -9,7 +9,7 @@
# printf("ok5\n")
bufOutSiz = bufOutSiz + nBytes
# printf("ok6\n")
-@@ -522,7 +522,7 @@
+@@ -522,7 +522,7 @@ cdef class new:
# Copy from float to short (16 bits) for output
for i from 0 <= i < self.encFramesPerBlock: