aboutsummaryrefslogtreecommitdiff
path: root/audio/replay
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-10-28 16:01:04 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-10-28 16:01:04 +0000
commit5d74a881b01df0d3087add00f5dfb66a9d2fcaf4 (patch)
tree0f644e4bf9f2e4968a7668645b4106f8c46e7c38 /audio/replay
parentdc714fff8d83b4818902dd79651cddd042c7770f (diff)
downloadports-5d74a881b01df0d3087add00f5dfb66a9d2fcaf4.tar.gz
ports-5d74a881b01df0d3087add00f5dfb66a9d2fcaf4.zip
Import replay, it's another gtk-base mp3 player.
Notes
Notes: svn path=/head/; revision=14237
Diffstat (limited to 'audio/replay')
-rw-r--r--audio/replay/Makefile27
-rw-r--r--audio/replay/distinfo1
-rw-r--r--audio/replay/files/patch-aa11
-rw-r--r--audio/replay/files/patch-ab40
-rw-r--r--audio/replay/files/patch-ac11
-rw-r--r--audio/replay/files/patch-ad12
-rw-r--r--audio/replay/pkg-comment1
-rw-r--r--audio/replay/pkg-descr17
-rw-r--r--audio/replay/pkg-plist1
9 files changed, 121 insertions, 0 deletions
diff --git a/audio/replay/Makefile b/audio/replay/Makefile
new file mode 100644
index 000000000000..6e5df28263a6
--- /dev/null
+++ b/audio/replay/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: replay
+# Version required: 0.56
+# Date created: Oct 27 1998
+# Whom: Vanilla Pooh Shu <vanilla@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= replay-source-dgtk_0.56
+PKGNAME= replay-0.56
+CATEGORIES= audio
+MASTER_SITES= http://replay.linuxpower.org/files/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gtk11.1:${PORTSDIR}/x11-toolkits/gtk11 \
+ esd.0:${PORTSDIR}/audio/esound
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-esd
+CONFIGURE_ENV= LIBS="-L${PREFIX}/lib"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/replay ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/replay/distinfo b/audio/replay/distinfo
new file mode 100644
index 000000000000..954e11aae7e7
--- /dev/null
+++ b/audio/replay/distinfo
@@ -0,0 +1 @@
+MD5 (replay-source-dgtk_0.56.tar.gz) = ae348e0528f37527d5c0bf14dffee660
diff --git a/audio/replay/files/patch-aa b/audio/replay/files/patch-aa
new file mode 100644
index 000000000000..dadd271e675a
--- /dev/null
+++ b/audio/replay/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Oct 28 00:22:43 1998
++++ Makefile.in Wed Oct 28 00:23:24 1998
+@@ -3,7 +3,7 @@
+ #DEBUG = -DDEBUG
+
+ # Make sure the path is correct!
+-GTK-CONFIG = "gtk-config"
++GTK-CONFIG = "gtk11-config"
+
+ # ---- @OS_TYPE@/@ARCH_TYPE@ ----
+
diff --git a/audio/replay/files/patch-ab b/audio/replay/files/patch-ab
new file mode 100644
index 000000000000..c1b6e17300e2
--- /dev/null
+++ b/audio/replay/files/patch-ab
@@ -0,0 +1,40 @@
+--- audioIO_Linux.c.orig Sat Oct 24 22:22:41 1998
++++ audioIO_Linux.c Wed Oct 28 01:27:43 1998
+@@ -26,7 +26,7 @@
+
+ /* optimal fragment size */
+
+-#ifndef OS_FreeBSD
++#ifndef OS_BSD
+ int AUSIZ = 0;
+ #endif
+
+@@ -44,7 +44,7 @@
+ void
+ audioOpen(int frequency, int stereo, int volume)
+ {
+- #ifdef OS_FreeBSD
++ #ifdef OS_BSD
+ int temp;
+ #endif
+ int supportedMixers, play_format=AFMT_S16_LE;
+@@ -83,7 +83,7 @@
+ if (volume != -1)
+ audioSetVolume(volume);
+
+-#ifdef OS_FreeBSD
++#ifdef OS_BSD
+ temp = AUSIZ;
+ if (ioctl(audio_fd, SNDCTL_DSP_GETBLKSIZE, &temp) == -1)
+ #else
+--- buffer.c.orig Wed Oct 28 01:26:57 1998
++++ buffer.c Wed Oct 28 01:27:05 1998
+@@ -31,7 +31,7 @@
+ #include "audio.h"
+
+ #ifndef OS_SunOS
+-#ifndef OS_FreeBSD
++#ifndef OS_BSD
+ extern int AUSIZ;
+ #endif
+ #endif
diff --git a/audio/replay/files/patch-ac b/audio/replay/files/patch-ac
new file mode 100644
index 000000000000..1284ecc26f3f
--- /dev/null
+++ b/audio/replay/files/patch-ac
@@ -0,0 +1,11 @@
+--- replay.c.orig Wed Oct 28 01:34:31 1998
++++ replay.c Wed Oct 28 01:34:46 1998
+@@ -1163,7 +1163,7 @@
+ DPRINT("\tglobbing: ");
+ DPRINT(buffer2);
+ DPRINT("\n");
+- if (glob(buffer2, GLOB_ERR, NULL, &match) == GLOB_NOMATCH) {
++ if (glob(buffer2, GLOB_ERR, NULL, &match) == GLOB_NOCHECK) {
+ DPRINT("\tmatched nothing\n");
+ return;
+ }
diff --git a/audio/replay/files/patch-ad b/audio/replay/files/patch-ad
new file mode 100644
index 000000000000..43c8cec7cad7
--- /dev/null
+++ b/audio/replay/files/patch-ad
@@ -0,0 +1,12 @@
+--- audioIO_esd.c.orig Wed Oct 28 21:38:30 1998
++++ audioIO_esd.c Wed Oct 28 21:39:01 1998
+@@ -19,7 +19,9 @@
+
+ /* declare these static to effectively isolate the audio device */
+
++#ifndef OS_BSD
+ int AUSIZ=0;
++#endif
+ static int audio_fd;
+
+ /* audioOpen() */
diff --git a/audio/replay/pkg-comment b/audio/replay/pkg-comment
new file mode 100644
index 000000000000..d9a0a7ceecb9
--- /dev/null
+++ b/audio/replay/pkg-comment
@@ -0,0 +1 @@
+Another GTK-base mp3 player.
diff --git a/audio/replay/pkg-descr b/audio/replay/pkg-descr
new file mode 100644
index 000000000000..a5cf7bc86fa9
--- /dev/null
+++ b/audio/replay/pkg-descr
@@ -0,0 +1,17 @@
+Replay is an MP3 player with a GTK interface. It is based on amp. It
+has the following features as of today:
+
+- Cool GTK interface.
+- Theme support.
+- Plays layer 3 and layer 2 files.
+- Playlists (load/edit/save).
+- Y2K compliant. ;)
+- Can save to WAV.
+- Stereo/mono playing.
+- Fully controllable from command line, with options and signals.
+- Double click in playlist to jump to that track.
+- Seeking within a track.
+- Display playing time/number of files/size for whole playlist.
+
+-Pooh
+vanilla@FreeBSD.ORG
diff --git a/audio/replay/pkg-plist b/audio/replay/pkg-plist
new file mode 100644
index 000000000000..86e03f35af28
--- /dev/null
+++ b/audio/replay/pkg-plist
@@ -0,0 +1 @@
+bin/replay