aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-18 17:20:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-18 17:20:19 +0000
commitb879855e145107516c9e3b104432b15797f8e53b (patch)
tree2d3a12dfe0285c4acafeaeedd24aa7d2b187dd0f /audio/rhythmbox
parenta7ebc6b6af894137049859619789b9d49f53d4cd (diff)
downloadports-b879855e145107516c9e3b104432b15797f8e53b.tar.gz
ports-b879855e145107516c9e3b104432b15797f8e53b.zip
Add net-rhythmbox, an audio and Internet radio player for the GNOME 2
desktop. Submitted by: Hendrik Scholz <hendrik@scholz.net>
Notes
Notes: svn path=/head/; revision=81256
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile60
-rw-r--r--audio/rhythmbox/distinfo1
-rw-r--r--audio/rhythmbox/files/patch-lib_getline.c12
-rw-r--r--audio/rhythmbox/files/patch-library_rb-library-main-thread.c11
-rw-r--r--audio/rhythmbox/files/patch-library_rb-library-walker-thread.c11
-rw-r--r--audio/rhythmbox/files/patch-library_rb-node.c11
-rw-r--r--audio/rhythmbox/pkg-descr12
-rw-r--r--audio/rhythmbox/pkg-plist146
8 files changed, 264 insertions, 0 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
new file mode 100644
index 000000000000..8c2e17caf9e3
--- /dev/null
+++ b/audio/rhythmbox/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: net-rhythmbox
+# Date created: 14 February 2003
+# Whom: Hendrik Scholz <hendrik@scholz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= net-rhythmbox
+PORTVERSION= 0.4.8
+CATEGORIES= audio gnome
+MASTER_SITES= http://web.verbum.org/net-rhythmbox/
+
+MAINTAINER= hendrik@scholz.net
+COMMENT= Audio player for the Gnome 2 desktop environment
+
+LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/libmusicbrainz \
+ gstplay-0.6.0:${PORTSDIR}/multimedia/gstreamer-plugins \
+ FLAC.5:${PORTSDIR}/audio/flac
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_LIBTOOL= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+CONFIGURE_ARGS= --disable-lirc
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libxosd.so)
+WITH_XOSD= yes
+.endif
+.if exists(${LOCALBASE}/lib/libogg.so)
+WITH_OGG= yes
+.endif
+
+.ifdef (WITH_XOSD)
+LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
+.else
+CONFIGURE_ARGS+= --disable-xosd
+.endif
+.ifdef (WITH_OGG)
+LIB_DEPENDS+= ogg.4:${PORTSDIR}/audio/libogg
+.else
+CONFIGURE_ARGS+= --disable-oggtest
+.endif
+
+pre-everything::
+.if !defined(WITH_XOSD)
+ @${ECHO_CMD}
+ @${ECHO_CMD} "define WITH_XOSD to enable On-Screen-Display support"
+ @${ECHO_CMD}
+.endif
+.if !defined(WITH_OGG)
+ @${ECHO_CMD}
+ @${ECHO_CMD} "define WITH_OGG to enable Ogg support"
+ @${ECHO_CMD}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
new file mode 100644
index 000000000000..235294717ff8
--- /dev/null
+++ b/audio/rhythmbox/distinfo
@@ -0,0 +1 @@
+MD5 (net-rhythmbox-0.4.8.tar.gz) = e2dd382da135ea00ac93b0f27c12bcb9
diff --git a/audio/rhythmbox/files/patch-lib_getline.c b/audio/rhythmbox/files/patch-lib_getline.c
new file mode 100644
index 000000000000..448b0d9d0780
--- /dev/null
+++ b/audio/rhythmbox/files/patch-lib_getline.c
@@ -0,0 +1,12 @@
+--- lib/getline.c.orig Fri Feb 14 20:42:13 2003
++++ lib/getline.c Fri Feb 14 20:44:09 2003
+@@ -43,6 +43,9 @@
+
+ # include "getstr.h"
+
++int getline (char **, size_t *, FILE *);
++int getdelim (char **, size_t *, int, FILE *);
++
+ int
+ getline (char **lineptr, size_t *n, FILE *stream)
+ {
diff --git a/audio/rhythmbox/files/patch-library_rb-library-main-thread.c b/audio/rhythmbox/files/patch-library_rb-library-main-thread.c
new file mode 100644
index 000000000000..44611505c449
--- /dev/null
+++ b/audio/rhythmbox/files/patch-library_rb-library-main-thread.c
@@ -0,0 +1,11 @@
+--- library/rb-library-main-thread.c.orig Sat May 17 20:56:40 2003
++++ library/rb-library-main-thread.c Sat May 17 20:56:47 2003
+@@ -325,7 +325,7 @@
+ rb_echo_area_end_task (echoarea, taskid);
+ g_mutex_unlock (priv->lock);
+
+- g_usleep (10);
++ g_usleep (10000);
+ }
+
+ return NULL;
diff --git a/audio/rhythmbox/files/patch-library_rb-library-walker-thread.c b/audio/rhythmbox/files/patch-library_rb-library-walker-thread.c
new file mode 100644
index 000000000000..1301febfd7cc
--- /dev/null
+++ b/audio/rhythmbox/files/patch-library_rb-library-walker-thread.c
@@ -0,0 +1,11 @@
+--- library/rb-library-walker-thread.c.orig Sun Feb 9 13:09:48 2003
++++ library/rb-library-walker-thread.c Sat May 17 21:02:36 2003
+@@ -325,7 +325,7 @@
+
+ g_mutex_unlock (thread->priv->lock);
+
+- g_usleep (10);
++ g_usleep (10000);
+ }
+
+ return NULL;
diff --git a/audio/rhythmbox/files/patch-library_rb-node.c b/audio/rhythmbox/files/patch-library_rb-node.c
new file mode 100644
index 000000000000..ec9a5c35830d
--- /dev/null
+++ b/audio/rhythmbox/files/patch-library_rb-node.c
@@ -0,0 +1,11 @@
+--- library/rb-node.c.orig Sun Feb 9 03:12:01 2003
++++ library/rb-node.c Mon Apr 21 20:27:45 2003
+@@ -852,7 +861,7 @@
+ int property_id)
+ {
+ GValue *ret;
+- long mtime;
++ time_t mtime;
+ char *retval;
+
+ g_return_val_if_fail (RB_IS_NODE (node), NULL);
diff --git a/audio/rhythmbox/pkg-descr b/audio/rhythmbox/pkg-descr
new file mode 100644
index 000000000000..c60e36a5ddb4
--- /dev/null
+++ b/audio/rhythmbox/pkg-descr
@@ -0,0 +1,12 @@
+netRhythmbox is a branch of Rhythmbox focusing on feature completion and
+stability. Most interesting features in addition to the features of the
+main tree are:
+
+ - Internet radio
+ - Playlist file (.pls) support
+ - Real error handling
+ - X OnScreen Display support
+ - A dynamic progress statusbar
+
+WWW: http://web.verbum.org/net-rhythmbox/
+-- Hendrik Scholz <hendrik@scholz.net>
diff --git a/audio/rhythmbox/pkg-plist b/audio/rhythmbox/pkg-plist
new file mode 100644
index 000000000000..f13e84904774
--- /dev/null
+++ b/audio/rhythmbox/pkg-plist
@@ -0,0 +1,146 @@
+bin/net-rhythmbox
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/state/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/state/iradio/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/state/library/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/ui/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/ui/iradio/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/ui/library/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/state/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/state/iradio/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/state/library/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/ui/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/ui/iradio/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/ui/library/%gconf.xml
+etc/gconf/schemas/net-rhythmbox.schemas
+libdata/bonobo/servers/GNOME_netRhythmbox_Shell.server
+share/gnome/application-registry/net-rhythmbox.applications
+share/gnome/applications/net-rhythmbox.desktop
+share/gnome/gnome-2.0/ui/net-rhythmbox-audiocd-view.xml
+share/gnome/gnome-2.0/ui/net-rhythmbox-group-view.xml
+share/gnome/gnome-2.0/ui/net-rhythmbox-iradio-view.xml
+share/gnome/gnome-2.0/ui/net-rhythmbox-library-view.xml
+share/gnome/gnome-2.0/ui/net-rhythmbox-test-view-2.xml
+share/gnome/gnome-2.0/ui/net-rhythmbox-ui.xml
+share/gnome/help/net-rhythmbox/C/authors.xml
+share/gnome/help/net-rhythmbox/C/fdl-appendix.xml
+share/gnome/help/net-rhythmbox/C/figures/rb-adv.png
+share/gnome/help/net-rhythmbox/C/figures/rb-audio-cd.png
+share/gnome/help/net-rhythmbox/C/figures/rb-basic.png
+share/gnome/help/net-rhythmbox/C/figures/rb-browser.png
+share/gnome/help/net-rhythmbox/C/figures/rb-empty.png
+share/gnome/help/net-rhythmbox/C/figures/rb-full-play.png
+share/gnome/help/net-rhythmbox/C/figures/rb-group-create.png
+share/gnome/help/net-rhythmbox/C/figures/rb-group.png
+share/gnome/help/net-rhythmbox/C/figures/rb-imported.png
+share/gnome/help/net-rhythmbox/C/figures/rb-internet-radio.png
+share/gnome/help/net-rhythmbox/C/figures/rb-iradio-prefs.png
+share/gnome/help/net-rhythmbox/C/figures/rb-library-prefs.png
+share/gnome/help/net-rhythmbox/C/figures/rb-nextprev.png
+share/gnome/help/net-rhythmbox/C/figures/rb-nobrowse-play.png
+share/gnome/help/net-rhythmbox/C/figures/rb-notification-area-menu.png
+share/gnome/help/net-rhythmbox/C/figures/rb-notification-area.png
+share/gnome/help/net-rhythmbox/C/figures/rb-player.png
+share/gnome/help/net-rhythmbox/C/figures/rb-prefs.png
+share/gnome/help/net-rhythmbox/C/figures/rb-repeat.png
+share/gnome/help/net-rhythmbox/C/figures/rb-search.png
+share/gnome/help/net-rhythmbox/C/figures/rb-shuffle.png
+share/gnome/help/net-rhythmbox/C/figures/rb-sidebar.png
+share/gnome/help/net-rhythmbox/C/figures/rb-stats.png
+share/gnome/help/net-rhythmbox/C/figures/rb-toolbar-editor.png
+share/gnome/help/net-rhythmbox/C/figures/rb-toolbar.png
+share/gnome/help/net-rhythmbox/C/figures/rb-volume-mute.png
+share/gnome/help/net-rhythmbox/C/figures/rb-window.png
+share/gnome/help/net-rhythmbox/C/figures/rhythmbox-group.png
+share/gnome/help/net-rhythmbox/C/figures/rhythmbox-tray-icon.png
+share/gnome/help/net-rhythmbox/C/internet-radio.xml
+share/gnome/help/net-rhythmbox/C/legal.xml
+share/gnome/help/net-rhythmbox/C/net-rhythmbox.xml
+share/gnome/help/net-rhythmbox/C/quick-reference.xml
+share/gnome/help/net-rhythmbox/C/user-guide.xml
+share/gnome/net-rhythmbox/art/about-logo.png
+share/gnome/net-rhythmbox/art/rhythmbox-album.png
+share/gnome/net-rhythmbox/art/rhythmbox-audiocd.png
+share/gnome/net-rhythmbox/art/rhythmbox-dnd.png
+share/gnome/net-rhythmbox/art/rhythmbox-group.png
+share/gnome/net-rhythmbox/art/rhythmbox-iradio.png
+share/gnome/net-rhythmbox/art/rhythmbox-library.png
+share/gnome/net-rhythmbox/art/rhythmbox-next.png
+share/gnome/net-rhythmbox/art/rhythmbox-no-star.png
+share/gnome/net-rhythmbox/art/rhythmbox-pause.png
+share/gnome/net-rhythmbox/art/rhythmbox-play.png
+share/gnome/net-rhythmbox/art/rhythmbox-playing.png
+share/gnome/net-rhythmbox/art/rhythmbox-playlist.png
+share/gnome/net-rhythmbox/art/rhythmbox-previous.png
+share/gnome/net-rhythmbox/art/rhythmbox-repeat.png
+share/gnome/net-rhythmbox/art/rhythmbox-rewind.png
+share/gnome/net-rhythmbox/art/rhythmbox-set-star.png
+share/gnome/net-rhythmbox/art/rhythmbox-shuffle.png
+share/gnome/net-rhythmbox/art/rhythmbox-stop.png
+share/gnome/net-rhythmbox/art/rhythmbox-tray-icon.png
+share/gnome/net-rhythmbox/art/rhythmbox-unset-star.png
+share/gnome/net-rhythmbox/art/rhythmbox-visuals.png
+share/gnome/net-rhythmbox/art/rhythmbox-volume-max.png
+share/gnome/net-rhythmbox/art/rhythmbox-volume-medium.png
+share/gnome/net-rhythmbox/art/rhythmbox-volume-min.png
+share/gnome/net-rhythmbox/art/rhythmbox-volume-mute.png
+share/gnome/net-rhythmbox/art/rhythmbox-volume-zero.png
+share/gnome/net-rhythmbox/glade/buffering-dialog.glade
+share/gnome/net-rhythmbox/glade/general-prefs.glade
+share/gnome/net-rhythmbox/glade/iradio-prefs.glade
+share/gnome/net-rhythmbox/glade/library-prefs.glade
+share/gnome/net-rhythmbox/glade/song-info.glade
+share/gnome/net-rhythmbox/glade/station-new.glade
+share/gnome/net-rhythmbox/glade/station-properties.glade
+share/gnome/net-rhythmbox/glade/toolbar-editor.glade
+share/gnome/net-rhythmbox/glade/uri.glade
+share/gnome/net-rhythmbox/iradio-initial.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-albums.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-artists.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-cdaudio.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-genres.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-iradio-genres.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-iradio-stations.xml
+share/gnome/net-rhythmbox/node-views/rb-node-view-songs.xml
+share/gnome/omf/net-rhythmbox/rhythmbox-C.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/net-rhythmbox/rhythmbox-C.omf 2>/dev/null || /usr/bin/true
+share/gnome/pixmaps/net-rhythmbox.png
+share/locale/cs/LC_MESSAGES/netrhythmbox.mo
+share/locale/da/LC_MESSAGES/netrhythmbox.mo
+share/locale/de/LC_MESSAGES/netrhythmbox.mo
+share/locale/el/LC_MESSAGES/netrhythmbox.mo
+share/locale/es/LC_MESSAGES/netrhythmbox.mo
+share/locale/fr/LC_MESSAGES/netrhythmbox.mo
+share/locale/it/LC_MESSAGES/netrhythmbox.mo
+share/locale/ja/LC_MESSAGES/netrhythmbox.mo
+share/locale/ko/LC_MESSAGES/netrhythmbox.mo
+share/locale/ms/LC_MESSAGES/netrhythmbox.mo
+share/locale/no/LC_MESSAGES/netrhythmbox.mo
+share/locale/ru/LC_MESSAGES/netrhythmbox.mo
+share/locale/sv/LC_MESSAGES/netrhythmbox.mo
+share/locale/tr/LC_MESSAGES/netrhythmbox.mo
+share/locale/vi/LC_MESSAGES/netrhythmbox.mo
+@dirrm share/gnome/omf/net-rhythmbox
+@dirrm share/gnome/net-rhythmbox/node-views
+@dirrm share/gnome/net-rhythmbox/glade
+@dirrm share/gnome/net-rhythmbox/art
+@dirrm share/gnome/net-rhythmbox
+@dirrm share/gnome/help/net-rhythmbox/C/figures
+@dirrm share/gnome/help/net-rhythmbox/C
+@dirrm share/gnome/help/net-rhythmbox
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/ui/library
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/ui/iradio
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/ui
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/state/library
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/state/iradio
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox/state
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/net-rhythmbox
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/ui/library
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/ui/iradio
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/ui
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/state/library
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/state/iradio
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox/state
+@dirrm etc/gconf/gconf.xml.defaults/apps/net-rhythmbox
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/net-rhythmbox/rhythmbox-C.omf 2>/dev/null || /usr/bin/true