aboutsummaryrefslogtreecommitdiff
path: root/audio/ripit
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-01 17:46:49 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-01 17:46:49 +0000
commit74401ae82418e846e6131dbb5dff61b06744d7eb (patch)
treec89e15a7fe9239b6af82a95fd0b7b6083aa80b07 /audio/ripit
parent7e5683c484a8d8f27f1dae77090b128c5496aa39 (diff)
downloadports-74401ae82418e846e6131dbb5dff61b06744d7eb.tar.gz
ports-74401ae82418e846e6131dbb5dff61b06744d7eb.zip
Update to 1.6. Add some more runtime dependencies.
PR: 18166 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=29068
Diffstat (limited to 'audio/ripit')
-rw-r--r--audio/ripit/Makefile4
-rw-r--r--audio/ripit/distinfo2
-rw-r--r--audio/ripit/files/patch-aa54
3 files changed, 33 insertions, 27 deletions
diff --git a/audio/ripit/Makefile b/audio/ripit/Makefile
index d3513451f7e2..7bc1893c98b2 100644
--- a/audio/ripit/Makefile
+++ b/audio/ripit/Makefile
@@ -6,14 +6,16 @@
#
PORTNAME= ripit
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= audio
MASTER_SITES= http://www.initio.no/~oyvindmo/distfiles/
MAINTAINER= oyvindmo@initio.no
RUN_DEPENDS= bladeenc:${PORTSDIR}/audio/bladeenc \
+ lame:${PORTSDIR}/audio/lame \
tosha:${PORTSDIR}/audio/tosha \
+ cdda2wav:${PORTSDIR}/sysutils/cdrecord \
cda:${PORTSDIR}/audio/xmcd
NO_BUILD= yes
diff --git a/audio/ripit/distinfo b/audio/ripit/distinfo
index a9d1946ff0e5..c5140a53ad84 100644
--- a/audio/ripit/distinfo
+++ b/audio/ripit/distinfo
@@ -1 +1 @@
-MD5 (ripit-1.5.tar.gz) = ad796d63c258a68de7edc800bfc67e9b
+MD5 (ripit-1.6.tar.gz) = b46334c00712b65f6b59ad23caab2b94
diff --git a/audio/ripit/files/patch-aa b/audio/ripit/files/patch-aa
index ce2fc3226a34..6d4e646f7f63 100644
--- a/audio/ripit/files/patch-aa
+++ b/audio/ripit/files/patch-aa
@@ -1,6 +1,6 @@
---- ripit.pl.orig Wed Sep 1 13:51:06 1999
-+++ ripit.pl Wed Sep 1 13:53:12 1999
-@@ -26,10 +26,10 @@
+--- ripit.pl.orig Fri Apr 21 12:11:23 2000
++++ ripit.pl Fri Apr 21 12:16:20 2000
+@@ -26,12 +26,12 @@
# User configurable variables
#
@@ -9,35 +9,39 @@
+$cddev = "/dev/rcd0c"; # CD Audio device
+$outputdir = "/home/mp3/"; # Where the MP3s should go
$bitrate = 160; # Bitrate for MP3s
--$encoder = 1; # 0 - Bladeenc, 1 - Lame
-+$encoder = 0; # 0 - Bladeenc, 1 - Lame
+ $encoder = 1; # 0 - Bladeenc, 1 - Lame
+ $encopt = ""; # options for mp3 encoder
+-$cdripper = 0; # 0 - cdparanoia, 1 - cdda2wav
++$cdripper = 2; # 0 - cdparanoia, 1 - cdda2wav, 2 - tosha
+ $cdopt = ""; # options for cdaudio ripper
$use_underscore = 0; # Use _ instead of spaces in filenames (1 yes, 0 no)
-
-@@ -329,14 +329,11 @@
-
- &printflush(RIPLOG,"Ripping $tracklist[$_ - 1]...\n");
-
-- if (system("cdparanoia -d $cddev $riptrackno \"$riptrackname.rip\"")) {
-- &printflush(RIPLOG,"cdparanoia failed on $tracklist[$_ - 1]\n");
-- die "cdparanoia failed on $tracklist[$_ - 1]";
-+ if (system("tosha -d $cddev -f wav -t $riptrackno -o \"$riptrackname.wav\"")) {
-+ &printflush(RIPLOG,"tosha failed on $tracklist[$_ - 1]\n");
-+ die "tosha failed on $tracklist[$_ - 1]";
+@@ -340,12 +340,18 @@
+ die "cdparanoia failed on $tracklist[$_ - 1]";
+ }
}
-
-- # Rename rip file to a wav for encoder
-- rename "$riptrackname.rip","$riptrackname.wav";
--
- &printflush(RIPLOG,"Rip complete $tracklist[$_ - 1]\n");
-
- # Start the Encoder in the background. but only once
-@@ -367,7 +364,7 @@
+- else {
++ elsif ($cdripper == 1) {
+ if (system("cdda2wav -D $cddev -Q -H $cdopt -t $riptrackno \"$riptrackname.rip\"")) {
+ &printflush(RIPLOG,"cdda2wav failed on $tracklist[$_ - 1]\n");
+ die "cdda2wav failed on $tracklist[$_ - 1]";
+ }
+ }
++ else {
++ if (system("tosha -d $cddev -f wav -t $riptrackno -o \"$riptrackname.rip\"")) {
++ &printflush(RIPLOG,"tosha failed on $tracklist[$_ - 1]\n");
++ die "tosha failed on $tracklist[$_ - 1]";
++ }
++ }
+
+ # Rename rip file to a wav for encoder
+ rename "$riptrackname.rip","$riptrackname.wav";
+@@ -380,7 +386,7 @@
print "\nMP3 Encoding track ".$ncount." of ".($#seltrack + 1)."\n";
&printflush(RIPLOG,"Encoding $tracklist[$_ - 1]...\n");
- # Keep looping until the file appears, ie wait for cdparanoia
-+ # Keep looping until the file appears, ie wait for tosha
++ # Keep looping until the file appears, ie wait for cdripper
# timeout after 30 minutes
$x=0;
while( ! -r "$riptrackname.wav" ){