aboutsummaryrefslogtreecommitdiff
path: root/audio/rosegarden/Makefile
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1996-08-06 17:37:34 +0000
committerChuck Robey <chuckr@FreeBSD.org>1996-08-06 17:37:34 +0000
commita86ff94fa8d0b389c577f9a5f2ab45f07493602c (patch)
tree64ab735418ec6ec971b317f36950e968f3dc40f0 /audio/rosegarden/Makefile
parent9938e91b30bfaf2fb2bb4c5aeb8018b87b20bf3c (diff)
downloadports-a86ff94fa8d0b389c577f9a5f2ab45f07493602c.tar.gz
ports-a86ff94fa8d0b389c577f9a5f2ab45f07493602c.zip
New audio port, Rosegarden, a midi musical sequencer and notation editor.
Submitted by: Andreas Kohout
Notes
Notes: svn path=/head/; revision=3533
Diffstat (limited to 'audio/rosegarden/Makefile')
-rw-r--r--audio/rosegarden/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
new file mode 100644
index 000000000000..9daf65da3785
--- /dev/null
+++ b/audio/rosegarden/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rosegarden
+# Version required: 2.0b3
+# Date created: 04 Aug 1996
+# Whom: shanee
+#
+# $Id: Makefile,v 1.0 1996/08/04 01:14:40 shanee Exp $
+#
+
+DISTNAME= rosegarden
+PKGNAME= rosegarden-2.0
+MASTER_SITES= ftp://ftp.maths.bath.ac.uk/pub/dream/ROSE/
+CATEGORIES= audio
+EXTRACT_SUFX= -2.0-BETA3-sources.tgz
+
+MAINTAINER= shanee@rabbit.augusta.de
+
+LIB_DEPENDS= Xaw3d\\.6\\.:$(PORTSDIR)/x11/Xaw3d
+RUN_DEPENDS= playmidi:${PORTSDIR}/audio/playmidi
+
+ALL_TARGET= all ROSEGARDEN=$(WRKSRC) SYSLIBS="\"-lmalloc -lXaw3d -lXext -lXmu -lXt -lX11\""
+
+.include <bsd.port.mk>