aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-mp3tag
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-29 15:56:31 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-29 15:56:31 +0000
commitc081b5710e61bdeb7876fd54b131e387baebc8cf (patch)
tree2675a9e011a5b92d69a2693f14e418e9cd8a6480 /audio/ruby-mp3tag
parent8478d99838e07750afc8e8b4ad30bb35bcae9b2a (diff)
downloadports-c081b5710e61bdeb7876fd54b131e387baebc8cf.tar.gz
ports-c081b5710e61bdeb7876fd54b131e387baebc8cf.zip
Add ruby-mp3tag, a Ruby module to manipulate ID3v1.1 tags in MP3
files.
Notes
Notes: svn path=/head/; revision=45585
Diffstat (limited to 'audio/ruby-mp3tag')
-rw-r--r--audio/ruby-mp3tag/Makefile34
-rw-r--r--audio/ruby-mp3tag/distinfo1
-rw-r--r--audio/ruby-mp3tag/pkg-comment1
-rw-r--r--audio/ruby-mp3tag/pkg-descr6
-rw-r--r--audio/ruby-mp3tag/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/audio/ruby-mp3tag/Makefile b/audio/ruby-mp3tag/Makefile
new file mode 100644
index 000000000000..82fda38ff64a
--- /dev/null
+++ b/audio/ruby-mp3tag/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Ruby/Mp3Tag
+# Date created: 30 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3tag
+PORTVERSION= 1.0
+CATEGORIES= audio ruby
+MASTER_SITES= http://www.cs.auc.dk/~larsch/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= README mp3tag.html
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/mp3tag.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/mp3tag_test.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/ruby-mp3tag/distinfo b/audio/ruby-mp3tag/distinfo
new file mode 100644
index 000000000000..82f0c6ed7156
--- /dev/null
+++ b/audio/ruby-mp3tag/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/mp3tag-1.0.tar.gz) = ed8cbc1e2def150eeb194b1311ea5008
diff --git a/audio/ruby-mp3tag/pkg-comment b/audio/ruby-mp3tag/pkg-comment
new file mode 100644
index 000000000000..9157b613e894
--- /dev/null
+++ b/audio/ruby-mp3tag/pkg-comment
@@ -0,0 +1 @@
+A Ruby module to manipulate ID3v1.1 tags in MP3 files
diff --git a/audio/ruby-mp3tag/pkg-descr b/audio/ruby-mp3tag/pkg-descr
new file mode 100644
index 000000000000..9487dc732e11
--- /dev/null
+++ b/audio/ruby-mp3tag/pkg-descr
@@ -0,0 +1,6 @@
+Mp3Tag is a ruby module that handles ID3v1.1 tags in MP3 files. It
+can read ID3v1.0 and ID3v1.1 but only write ID3v1.1 tags. It can save
+new tags and remove tags.
+
+Author: Lars Christensen <larsch@cs.auc.dk>
+WWW: http://www.cs.auc.dk/~larsch/ruby/mp3tag.html
diff --git a/audio/ruby-mp3tag/pkg-plist b/audio/ruby-mp3tag/pkg-plist
new file mode 100644
index 000000000000..2e4d7cf20200
--- /dev/null
+++ b/audio/ruby-mp3tag/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITELIBDIR%%/mp3tag.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/mp3tag/mp3tag_test.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/mp3tag
+%%PORTDOCS%%%%RUBY_DOCDIR%%/mp3tag/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/mp3tag/mp3tag.html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/mp3tag