aboutsummaryrefslogtreecommitdiff
path: root/audio/sbagen
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 02:35:01 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 02:35:01 +0000
commit6097f03e914afc72ab11bca0cf311ad5f1fd15e3 (patch)
treea7f557a98d36da0017550c4118cccf1e4d496c25 /audio/sbagen
parenta6429924fc57a145369eb5b2d3d0f45c65656b19 (diff)
downloadports-6097f03e914afc72ab11bca0cf311ad5f1fd15e3.tar.gz
ports-6097f03e914afc72ab11bca0cf311ad5f1fd15e3.zip
PERL -> REINPLACE
Noticed on: bento
Notes
Notes: svn path=/head/; revision=69424
Diffstat (limited to 'audio/sbagen')
-rw-r--r--audio/sbagen/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/sbagen/Makefile b/audio/sbagen/Makefile
index 04d67c1d7168..ace8eadc8bab 100644
--- a/audio/sbagen/Makefile
+++ b/audio/sbagen/Makefile
@@ -24,13 +24,15 @@ SHAREFILES= t-alpha t-beta t-calm t-calm2 t-delta t-focus t-focus-1 \
DOCFILES= sbagen.txt theory.txt theory2.txt
+USE_REINPLACE= yes
+
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/sbagen.c
post-patch:
.for F in ${SHAREFILES}
- @${PERL} -pi -e 's,/bin/bash,/bin/sh,g' ${WRKSRC}/$F
+ @${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,g' ${WRKSRC}/$F
.endfor
do-build: