aboutsummaryrefslogtreecommitdiff
path: root/audio/sfront/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-05 05:27:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-05 05:27:45 +0000
commit4f3ebdc703bd9d87b0ad5216e782a0260d4c72e7 (patch)
treeb85805c1d7d6cc279048ae4133be15b38e08581d /audio/sfront/Makefile
parent9cd03fe53ca767825d336a42b8b7142a16d87842 (diff)
downloadports-4f3ebdc703bd9d87b0ad5216e782a0260d4c72e7.tar.gz
ports-4f3ebdc703bd9d87b0ad5216e782a0260d4c72e7.zip
add sfront
A translator that converts MP4-SA files into efficient C programs
Notes
Notes: svn path=/head/; revision=49585
Diffstat (limited to 'audio/sfront/Makefile')
-rw-r--r--audio/sfront/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/sfront/Makefile b/audio/sfront/Makefile
new file mode 100644
index 000000000000..0d345c679f19
--- /dev/null
+++ b/audio/sfront/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: sfront
+# Date created: Nov 4, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sfront
+PORTVERSION= 0.7.8
+CATEGORIES= audio
+MASTER_SITES= http://www.cs.berkeley.edu/~lazzaro/sa/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BISON= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+ALL_TARGET= # empty
+
+post-patch:
+ @${PERL} -pi -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/../bin/sfront ${PREFIX}/bin
+
+.include <bsd.port.mk>