aboutsummaryrefslogtreecommitdiff
path: root/audio/sidplayer
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-05-27 08:24:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-05-27 08:24:44 +0000
commit45d7ea76933c2492ac37433bf5b0db613a01a6c1 (patch)
treec8a75feaba12c3e90263a112dbe4a527671b2e71 /audio/sidplayer
parent95b2561585e0886b96a6d99eb0defff06b99c8a9 (diff)
downloadports-45d7ea76933c2492ac37433bf5b0db613a01a6c1.tar.gz
ports-45d7ea76933c2492ac37433bf5b0db613a01a6c1.zip
Add sidplayer 4.4,
SIDPlayer is a replayer program for C64 music (SID tunes). You can think of it as being a stripped-down C64 emulator that only emulates the processor and the sound chip of the C64. It also supports the SID option of the Catweasel MK3 PCI card. PR: ports/81537 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=136256
Diffstat (limited to 'audio/sidplayer')
-rw-r--r--audio/sidplayer/Makefile47
-rw-r--r--audio/sidplayer/distinfo2
-rw-r--r--audio/sidplayer/pkg-descr9
-rw-r--r--audio/sidplayer/pkg-plist22
4 files changed, 80 insertions, 0 deletions
diff --git a/audio/sidplayer/Makefile b/audio/sidplayer/Makefile
new file mode 100644
index 000000000000..5ddbb5f32833
--- /dev/null
+++ b/audio/sidplayer/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: sidplayer
+# Date created: 27 May 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sidplayer
+PORTVERSION= 4.4
+CATEGORIES= audio
+MASTER_SITES= http://wwwthep.physik.uni-mainz.de/~cbauer/
+DISTNAME= SIDPlayer-${PORTVERSION}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A C64 SID tune player
+
+USE_SDL= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+SDLINCLUDEDIR= SDL11
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/SDL_endian\.h|${SDLINCLUDEDIR}/SDL_endian\.h|' \
+ ${WRKSRC}/src/main_sdl.cpp
+
+do-install:
+ ${INSTALL} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/PSID\ Demo/* ${DOCSDIR}/
+.endif
+
+post-install:
+ @${ECHO_MSG} "=============================================================="
+ @${ECHO_MSG} "A huge SID tune archive can be found at http://hvsc.c64.org/"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "You can find a few examples in ${DOCSDIR}"
+.endif
+ @${ECHO_MSG} "=============================================================="
+
+.include <bsd.port.mk>
diff --git a/audio/sidplayer/distinfo b/audio/sidplayer/distinfo
new file mode 100644
index 000000000000..0db748f3eea0
--- /dev/null
+++ b/audio/sidplayer/distinfo
@@ -0,0 +1,2 @@
+MD5 (SIDPlayer-4.4.tar.gz) = bf066aa9b83b561a72ebf19947eb764c
+SIZE (SIDPlayer-4.4.tar.gz) = 230703
diff --git a/audio/sidplayer/pkg-descr b/audio/sidplayer/pkg-descr
new file mode 100644
index 000000000000..b3bcba412915
--- /dev/null
+++ b/audio/sidplayer/pkg-descr
@@ -0,0 +1,9 @@
+SIDPlayer is a replayer program for C64 music (SID tunes). You can think of it
+as being a stripped-down C64 emulator that only emulates the processor and the
+sound chip of the C64. It also supports the SID option of the
+Catweasel MK3 PCI card.
+
+WWW: http://www.students.uni-mainz.de/bauec002/SPMain.html
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/sidplayer/pkg-plist b/audio/sidplayer/pkg-plist
new file mode 100644
index 000000000000..6b7fda13768e
--- /dev/null
+++ b/audio/sidplayer/pkg-plist
@@ -0,0 +1,22 @@
+bin/sidplayer
+%%PORTDOCS%%%%DOCSDIR%%/Antics
+%%PORTDOCS%%%%DOCSDIR%%/Arkanoid
+%%PORTDOCS%%%%DOCSDIR%%/Bombo
+%%PORTDOCS%%%%DOCSDIR%%/Bulldog
+%%PORTDOCS%%%%DOCSDIR%%/Cybernoid_II
+%%PORTDOCS%%%%DOCSDIR%%/Dance_At_Night
+%%PORTDOCS%%%%DOCSDIR%%/Deflektor
+%%PORTDOCS%%%%DOCSDIR%%/F1_Simulator
+%%PORTDOCS%%%%DOCSDIR%%/Geir_Tjelta-01
+%%PORTDOCS%%%%DOCSDIR%%/Immortal_Flash_2
+%%PORTDOCS%%%%DOCSDIR%%/Lightforce
+%%PORTDOCS%%%%DOCSDIR%%/Master_Of_Magic
+%%PORTDOCS%%%%DOCSDIR%%/Ocean_Loader_v3.0
+%%PORTDOCS%%%%DOCSDIR%%/Parallax
+%%PORTDOCS%%%%DOCSDIR%%/Spellbound
+%%PORTDOCS%%%%DOCSDIR%%/Thrust
+%%PORTDOCS%%%%DOCSDIR%%/Times_of_Lore
+%%PORTDOCS%%%%DOCSDIR%%/W.A.R
+%%PORTDOCS%%%%DOCSDIR%%/Yie_Ar_Kung_Fu
+%%PORTDOCS%%%%DOCSDIR%%/Zoids
+%%PORTDOCS%%@dirrm %%DOCSDIR%%