aboutsummaryrefslogtreecommitdiff
path: root/audio/smasher
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-09 03:25:56 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-09 03:25:56 +0000
commit1cd27c01634d1cf29cec805adc17c4eed2704d46 (patch)
tree958311389b7dad173d282f424d48ea949b84396c /audio/smasher
parente4624659dc347450133908642d4dc7fdb4788650 (diff)
downloadports-1cd27c01634d1cf29cec805adc17c4eed2704d46.tar.gz
ports-1cd27c01634d1cf29cec805adc17c4eed2704d46.zip
Cross-platform audio loop slicer designed to create sliced loops from WAV, MP3,
FLAC or AIFF files in seconds without a sequencer. Effects include filter sweeps, phasing, flanging, delay, and distortion. Chris Petrik (chris@officialunix.com) WWW: http://smasher.sourceforge.net/ PR: ports/135937 Submitted by: chris at officialunix.com
Notes
Notes: svn path=/head/; revision=237469
Diffstat (limited to 'audio/smasher')
-rw-r--r--audio/smasher/Makefile49
-rw-r--r--audio/smasher/distinfo3
-rw-r--r--audio/smasher/pkg-descr7
-rw-r--r--audio/smasher/pkg-plist51
4 files changed, 110 insertions, 0 deletions
diff --git a/audio/smasher/Makefile b/audio/smasher/Makefile
new file mode 100644
index 000000000000..359a444fea16
--- /dev/null
+++ b/audio/smasher/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: smasher
+# Date created: 22 June 2009
+# Whom: chris@officialunix.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= smasher
+PORTVERSION= 1.0.5
+CATEGORIES= audio
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+
+MAINTAINER= chris@officialunix.com
+COMMENT= Cross platform audio loop slicer
+
+LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
+ mad.2:${PORTSDIR}/audio/libmad
+
+ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS_REASON= At the momment does not build on AMD64 ia64
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-wx-config=${LOCALBASE}/bin/wxgtk2-2.8-config \
+ --datarootdir="${PREFIX}/share" --libdir="${LOCALBASE}/lib" \
+ --localedir="${PREFIX}/share/locale" --includedir="${LOCALBASE}/include"
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
+USE_XORG= x11
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_WX= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/pixmaps|${LOCALBASE}/share/pixmaps|g' \
+ ${WRKSRC}/src/Makefile.am ${WRKSRC}/src/Makefile.in
+
+ @${REINPLACE_CMD} -e 's|/usr/share/applications|${LOCALBASE}/share/applications|g' \
+ ${WRKSRC}/src/Makefile.am ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 604000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/smasher/distinfo b/audio/smasher/distinfo
new file mode 100644
index 000000000000..c04c43d68fbb
--- /dev/null
+++ b/audio/smasher/distinfo
@@ -0,0 +1,3 @@
+MD5 (smasher-1.0.5-source.tar.gz) = 44f227ac74a27301eb5b645c56ad1d03
+SHA256 (smasher-1.0.5-source.tar.gz) = 84c5995e367dd49e7065b405895d7b41d349ea82cd7dc18322bfad7ecdb381c5
+SIZE (smasher-1.0.5-source.tar.gz) = 1581424
diff --git a/audio/smasher/pkg-descr b/audio/smasher/pkg-descr
new file mode 100644
index 000000000000..47fe127a2e87
--- /dev/null
+++ b/audio/smasher/pkg-descr
@@ -0,0 +1,7 @@
+Cross-platform audio loop slicer designed to create sliced loops from WAV, MP3,
+FLAC or AIFF files in seconds without a sequencer.
+
+Effects include filter sweeps, phasing, flanging, delay, and distortion.
+
+Chris Petrik (chris@officialunix.com)
+WWW: http://smasher.sourceforge.net/
diff --git a/audio/smasher/pkg-plist b/audio/smasher/pkg-plist
new file mode 100644
index 000000000000..65ebbbca8506
--- /dev/null
+++ b/audio/smasher/pkg-plist
@@ -0,0 +1,51 @@
+bin/smasher
+%%DATADIR%%/png/applications-system.png
+%%DATADIR%%/png/dialog-information.png
+%%DATADIR%%/png/edit-clear-gs.png
+%%DATADIR%%/png/edit-redo_gs.png
+%%DATADIR%%/png/edit-undo_gs.png
+%%DATADIR%%/png/fileopen.png
+%%DATADIR%%/png/filesave.png
+%%DATADIR%%/png/filesave_gs.png
+%%DATADIR%%/png/gtk-media-play-inv.png
+%%DATADIR%%/png/logviewer_gs.png
+%%DATADIR%%/png/media-playback-pause.png
+%%DATADIR%%/png/player_play.png
+%%DATADIR%%/png/player_play_inv.png
+%%DATADIR%%/png/player_stop.png
+%%DATADIR%%/png/player_stop_inv.png
+%%DATADIR%%/png/preferences-desktop.png
+%%DATADIR%%/png/reload.png
+%%DATADIR%%/png/smasher.png
+%%DATADIR%%/png/stock_data-next.png
+%%DATADIR%%/png/stock_data-previous.png
+%%DATADIR%%/png/stock_draw-line.png
+%%DATADIR%%/png/stock_draw-line_r.png
+%%DATADIR%%/png/stock_filters-invert.png
+%%DATADIR%%/png/stock_filters.png
+%%DATADIR%%/png/stock_function-autopilot.png
+%%DATADIR%%/png/stock_gamma.png
+%%DATADIR%%/png/stock_headphones.png
+%%DATADIR%%/png/stock_hyperlink.png
+%%DATADIR%%/png/stock_id.png
+%%DATADIR%%/png/stock_keyring.png
+%%DATADIR%%/png/stock_next.png
+%%DATADIR%%/png/stock_open.png
+%%DATADIR%%/png/stock_pin_gs_min.png
+%%DATADIR%%/png/stock_previous.png
+%%DATADIR%%/png/stock_repeat.png
+%%DATADIR%%/png/stock_repeat_inv.png
+%%DATADIR%%/png/stock_shuffle.png
+%%DATADIR%%/png/stock_standard-filter.png
+%%DATADIR%%/png/system-run.png
+%%DATADIR%%/png/window_nofullscreen_gs.png
+%%DATADIR%%/samples/Amen_Break.wav
+%%DATADIR%%/xpm/smashericon.xpm
+share/applications/smasher.desktop
+share/pixmaps/smasher.png
+@dirrmtry share/applications
+@dirrmtry share/pixmaps
+@dirrm %%DATADIR%%/xpm
+@dirrm %%DATADIR%%/samples
+@dirrm %%DATADIR%%/png
+@dirrm %%DATADIR%%