aboutsummaryrefslogtreecommitdiff
path: root/audio/snd/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-19 08:35:30 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-19 08:35:30 +0000
commitb2381b3e703dfc35624bed713718796eaf61bd05 (patch)
tree8f4703d2733aca5a3eca48166677e7357391df25 /audio/snd/Makefile
parentcc26da9fea75608d102c004d544f4c927821f90a (diff)
downloadports-b2381b3e703dfc35624bed713718796eaf61bd05.tar.gz
ports-b2381b3e703dfc35624bed713718796eaf61bd05.zip
Rename sndinfo to snd-info, to avoid conflict with audio/csound
port. Tell users about the change. Add "PLIST=${WRKDIR}/pkg-plist" to fix a problem found by bento. Add a patch needed for compiling without GUILE. Increment PORTREVISION.
Notes
Notes: svn path=/head/; revision=33987
Diffstat (limited to 'audio/snd/Makefile')
-rw-r--r--audio/snd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 7e0a67916087..a35f726ca150 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= snd
PORTVERSION= 4.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ftp://ccrma-ftp.stanford.edu/pub/Lisp/ \
${MASTER_SITE_SOURCEFORGE}
@@ -50,6 +51,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GNU_CONFIGURE= yes
MAKEFILE= makefile
+PLIST= ${WRKDIR}/pkg-plist
PREFIX= /
.if !defined(WITHOUT_X)
USE_GLIB= yes
@@ -62,7 +64,7 @@ post-configure:
@${PERL} -pi -e "s:^LIBS = :LIBS = -lm:g" ${WRKSRC}/makefile
do-install:
-.for i in audinfo sndinfo sndplay sndrecord sndsine
+.for i in audinfo snd-info sndplay sndrecord sndsine
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${LOCALBASE}/bin
.endfor
.if !defined(WITHOUT_X)
@@ -102,4 +104,7 @@ pre-build:
${ECHO} "@dirrm %%LOCALBASE%%/share/doc/snd" >> ${PLIST}
.endif
+post-build:
+ ${MV} ${WRKSRC}/sndinfo ${WRKSRC}/snd-info
+
.include <bsd.port.mk>