aboutsummaryrefslogtreecommitdiff
path: root/audio/solfege/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-21 19:57:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-21 19:57:39 +0000
commit848649ad939fed7a374181c280bd219fb0f09632 (patch)
tree778b049bb1a168b963fc11262e087d7062e027ff /audio/solfege/Makefile
parent01d009dbeacfb5952619d3b510c2600fb34504c9 (diff)
downloadports-848649ad939fed7a374181c280bd219fb0f09632.tar.gz
ports-848649ad939fed7a374181c280bd219fb0f09632.zip
- Update to 3.6.4
PR: 106986 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=180376
Diffstat (limited to 'audio/solfege/Makefile')
-rw-r--r--audio/solfege/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/audio/solfege/Makefile b/audio/solfege/Makefile
index 49435e76135a..447138116385 100644
--- a/audio/solfege/Makefile
+++ b/audio/solfege/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= solfege
-PORTVERSION= 3.6.3
+PORTVERSION= 3.6.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,18 +16,15 @@ PKGNAMESUFFIX= -nosound
MAINTAINER= ports@FreeBSD.org
COMMENT= Free eartraining software
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- swig:${PORTSDIR}/devel/swig13 \
- ${STYLESHEET}:${PORTSDIR}/textproc/docbook-xsl
+BUILD_DEPENDS= ${STYLESHEET}:${PORTSDIR}/textproc/docbook-xsl
-USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix pygnomeextras
+USE_GNOME= gnomehack gnomeprefix libxslt pygtk2
+WANT_GNOME= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4 \
- ac_cv_path_XML2PO=""
+CONFIGURE_ENV= ac_cv_path_XML2PO=""
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
--disable-oss-sound \
--enable-docbook-stylesheet=${STYLESHEET}
@@ -37,6 +34,12 @@ MAN1= lessonfile_editor.1 solfege.1
STYLESHEET= ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mpygnomeextras}!=""
+USE_GNOME+= pygnomeextras
+.endif
+
.if defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT} \
${X11BASE}/lib/X11/fonts/misc/8x13O.pcf.gz:${X_FONTS_MISC_PORT}
@@ -58,4 +61,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|(datadir)/locale|(prefix)/share/locale|g' \
${WRKSRC}/po/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>