aboutsummaryrefslogtreecommitdiff
path: root/audio/sound-juicer/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /audio/sound-juicer/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Notes
Notes: svn path=/head/; revision=160863
Diffstat (limited to 'audio/sound-juicer/Makefile')
-rw-r--r--audio/sound-juicer/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 0f6ca61cced3..e212a38eab09 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -3,32 +3,34 @@
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/sound-juicer/Makefile,v 1.29 2005/09/19 13:18:32 marcus Exp $
+# $MCom: ports/audio/sound-juicer/Makefile,v 1.49 2006/04/14 15:06:00 ahze Exp $
#
PORTNAME= sound-juicer
-PORTVERSION= 2.12.3
+PORTVERSION= 2.14.3
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Clean, mean and lean CD ripper for GNOME2
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
- gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2
+ gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2 \
+ cdio.6:${PORTSDIR}/sysutils/libcdio
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-USE_REINPLACE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui nautiluscdburner \
gnomedocutils
USE_GSTREAMER= cdparanoia vorbis flac gconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ignore-missing-cd
+INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -36,5 +38,7 @@ GCONF_SCHEMAS= sound-juicer.schemas
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS = .*\)tests\(.*\)|\1\2|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|--parents|-p|g' \
+ ${WRKSRC}/data/Makefile.in
.include <bsd.port.mk>