aboutsummaryrefslogtreecommitdiff
path: root/audio/sound-juicer
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-14 18:57:53 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-02-14 18:57:53 +0000
commitb93a80c99281466281db26011356c75bd54ea36c (patch)
treecb5a8a1108829deee66dbb334ff2a733162448c6 /audio/sound-juicer
parentb78527376a1d11bef820d5e9fe86d3c524ea6acf (diff)
downloadports-b93a80c99281466281db26011356c75bd54ea36c.tar.gz
ports-b93a80c99281466281db26011356c75bd54ea36c.zip
The FreeBSD GNOME team proudly presents GNOME 3.18 for FreeBSD.
The offical GNOME 3.18 release notes can be found at https://help.gnome.org/misc/release-notes/3.18/ This update doesn't contain the glib/gtk c++ bindings which will be done in a another update due to the requirement on c++11 and the amount of fallout this probably will give. GDM is still at version 3.16 due to some issues. Bump mate-themes to use the gtk 3.18 version of the themes. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 207006
Notes
Notes: svn path=/head/; revision=408881
Diffstat (limited to 'audio/sound-juicer')
-rw-r--r--audio/sound-juicer/Makefile5
-rw-r--r--audio/sound-juicer/distinfo4
-rw-r--r--audio/sound-juicer/files/patch-libjuicer_sj-metadata-musicbrainz5.c11
3 files changed, 15 insertions, 5 deletions
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index a43282953dcb..1a8283c906c9 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sound-juicer
-PORTVERSION= 3.16.1
-PORTREVISION= 1
+PORTVERSION= 3.18.1
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -21,7 +20,7 @@ LIB_DEPENDS= libmusicbrainz5.so:${PORTSDIR}/audio/libmusicbrainz5 \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake pathfix pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake gnome pathfix pkgconfig tar:xz
USE_GNOME= gnomeprefix intlhack
USE_GSTREAMER1= cdparanoia flac good vorbis
GNU_CONFIGURE= yes
diff --git a/audio/sound-juicer/distinfo b/audio/sound-juicer/distinfo
index 323a8e676a7e..2735bb54e2e0 100644
--- a/audio/sound-juicer/distinfo
+++ b/audio/sound-juicer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/sound-juicer-3.16.1.tar.xz) = dfb744504a60f8069257584b74d90cba1ce99c744a7106b68627ad1d40b2a657
-SIZE (gnome3/sound-juicer-3.16.1.tar.xz) = 811148
+SHA256 (gnome3/sound-juicer-3.18.1.tar.xz) = 526d5a84d9b6b8f002f82f9d5678e3850c48e3b5692a499451fc5f36eef0de76
+SIZE (gnome3/sound-juicer-3.18.1.tar.xz) = 819428
diff --git a/audio/sound-juicer/files/patch-libjuicer_sj-metadata-musicbrainz5.c b/audio/sound-juicer/files/patch-libjuicer_sj-metadata-musicbrainz5.c
new file mode 100644
index 000000000000..2f759c4e9f09
--- /dev/null
+++ b/audio/sound-juicer/files/patch-libjuicer_sj-metadata-musicbrainz5.c
@@ -0,0 +1,11 @@
+--- libjuicer/sj-metadata-musicbrainz5.c.orig 2015-08-17 21:51:58.000000000 +0200
++++ libjuicer/sj-metadata-musicbrainz5.c 2015-08-17 21:52:28.000000000 +0200
+@@ -757,7 +757,7 @@
+ if (*error != NULL) {
+ track_details_free (track);
+ g_list_free_full (tracks, (GDestroyNotify) track_details_free);
+- return NULL;
++ return;
+ }
+
+ if (track->duration == 0)