aboutsummaryrefslogtreecommitdiff
path: root/audio/squeezeboxserver
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-07-04 20:50:08 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-07-04 20:50:08 +0000
commit6a6ae1551bb9b6038581b31c0d6ebb2d8c32d0a4 (patch)
tree790f4298e4d17bdac2d2746074617957186ff38d /audio/squeezeboxserver
parent31ec0f5e13a11e0ee7059b96f57eb4a0b7595a36 (diff)
downloadports-6a6ae1551bb9b6038581b31c0d6ebb2d8c32d0a4.tar.gz
ports-6a6ae1551bb9b6038581b31c0d6ebb2d8c32d0a4.zip
- Fix for mysql50+ [1]
- Remove dependency for p5-Mysql50 (replace with p5-Mysql) [2] PR: ports/164177 Reported by: Daniel Pritts <danno@umich.edu> Submitted by: the_mix_room@hotmail.com [1] Reviewed by: scheidell@ (me) [2] Approved by: The little dancing elves
Notes
Notes: svn path=/head/; revision=300491
Diffstat (limited to 'audio/squeezeboxserver')
-rw-r--r--audio/squeezeboxserver/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 7fe1dfe8f176..a1d33083119a 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squeezeboxserver
PORTVERSION= 7.5.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeboxServer_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-noCPAN
@@ -30,7 +30,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-32171-noCPAN
RUN_DEPENDS+= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
p5-URI-Find>=0:${PORTSDIR}/textproc/p5-URI-Find \
- p5-DBD-mysql50>=0:${PORTSDIR}/databases/p5-DBD-mysql50 \
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-Encode-Detect>=0:${PORTSDIR}/converters/p5-Encode-Detect \
p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
@@ -57,7 +57,6 @@ RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
.endif
USE_MYSQL= server
-WANT_MYSQL_VER= 50
.if ${PORT_OPTIONS:MAPE}
RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
@@ -173,6 +172,12 @@ post-patch:
-e 's|%%TMP_SLIMDIR%%|${TMP_SLIMDIR}|g' \
${WRKSRC}/scanner.pl \
${WRKSRC}/slimserver.pl
+ ${REINPLACE_CMD} \
+ -e 's/skip-locking/skip-external-locking/' \
+ -e 's/default-character-set/character-set-server/'\
+ -e 's/default-collation/collation-server/' ${WRKSRC}/MySQL/my.tt
+ ${REINPLACE_CMD} \
+ -e 's/TYPE=InnoDB/ENGINE=InnoDB/' ${WRKSRC}/SQL/mysql/schema_*.sql
do-build:
@${MKDIR} -m 0755 ${TMP_SLIMDIR}