aboutsummaryrefslogtreecommitdiff
path: root/audio/squeezecenter/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2008-04-04 15:48:14 +0000
committerBrooks Davis <brooks@FreeBSD.org>2008-04-04 15:48:14 +0000
commit4d1add55bb5123255c41e852ee5e6ea66a805316 (patch)
tree918b0c3830328d1b6919c0abbe1bad035e790454 /audio/squeezecenter/Makefile
parentbd7c364d36883b2c67b392d3d7cc838ed6d3a780 (diff)
downloadports-4d1add55bb5123255c41e852ee5e6ea66a805316.tar.gz
ports-4d1add55bb5123255c41e852ee5e6ea66a805316.zip
Install squeezecenter with more normal permissions using the COPYTREE_SHARE
macro. Use rc.subr's user and group startup functionality instead of the poorly supported code in squeezecenter. Switch to the default log layout where mutiple log files end up in /var/log/slimserver. Changing location is required due to the startup change and the split layout is easier to handle.
Notes
Notes: svn path=/head/; revision=210521
Diffstat (limited to 'audio/squeezecenter/Makefile')
-rw-r--r--audio/squeezecenter/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/audio/squeezecenter/Makefile b/audio/squeezecenter/Makefile
index 8f073a356146..75f9df5e8411 100644
--- a/audio/squeezecenter/Makefile
+++ b/audio/squeezecenter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squeezecenter
PORTVERSION= 7.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.slimdevices.com/downloads/SqueezeCenter_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-7.0-noCPAN
@@ -183,9 +183,9 @@ pre-install:
do-install:
@${MKDIR} -m 0755 ${PREFIX}/${SLIMDIR}
@${LN} -s ${SLIMDBDIR}/cache ${PREFIX}/${SLIMDIR}/Cache
- @cd ${TMP_SLIMDIR} && \
- ${FIND} . | \
- ${CPIO} ${CPIOARGS} ${BINOWN}:${BINGRP} ${PREFIX}/${SLIMDIR}
+ @cd ${TMP_SLIMDIR} && ${COPYTREE_SHARE} . ${PREFIX}/${SLIMDIR}
+ @${CHMOD} 755 ${PREFIX}/${SLIMDIR}/slimserver.pl
+ @${CHMOD} 755 ${PREFIX}/${SLIMDIR}/scanner.pl
@${LN} -s ${LOCALBASE}/share/mysql/errmsg.txt \
${PREFIX}/${SLIMDIR}/MySQL/
@${LN} -s ${LOCALBASE}/share/mysql/english/errmsg.sys \
@@ -193,9 +193,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/softsqueeze.sh ${PREFIX}/bin/softsqueeze
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @cd ${TMP_DOCSDIR} && \
- ${FIND} . | \
- ${CPIO} ${CPIOARGS} ${BINOWN}:${BINGRP} ${DOCSDIR}
+ @cd ${TMP_DOCSDIR} && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
post-install: