aboutsummaryrefslogtreecommitdiff
path: root/audio/teamspeak_client
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-08 16:44:27 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-08 16:44:27 +0000
commitf15572920f5175e97e70472aab8e995c2a16ccb0 (patch)
tree90718463a632060e968462a415013b516fbf25e8 /audio/teamspeak_client
parent781eccbe54ee08f604dcfbd36d0358f2e007cd06 (diff)
downloadports-f15572920f5175e97e70472aab8e995c2a16ccb0.tar.gz
ports-f15572920f5175e97e70472aab8e995c2a16ccb0.zip
- Add a menu item
- Add amd64 to ONLY_FOR_ARCHS (I can not test this, but it should work) - Use exec in the wrapper script: http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/dads-sh-exec.html - Install with ${INSTALL_PROGRAM} and ${INSTALL_DATA}, to ensure proper permissions/stripping/ownerships - This program uses X: move to ${X11BASE} - Install documentation in ${DOCSDIR} - Cleanups (SUB_FILES, PORTDOCS) PR: ports/93931 Submitted by: jylefort Approved by: maintainer timeout (39 days)
Notes
Notes: svn path=/head/; revision=159134
Diffstat (limited to 'audio/teamspeak_client')
-rw-r--r--audio/teamspeak_client/Makefile55
-rw-r--r--audio/teamspeak_client/files/TeamSpeak.in (renamed from audio/teamspeak_client/files/TeamSpeak)4
-rw-r--r--audio/teamspeak_client/pkg-plist101
3 files changed, 50 insertions, 110 deletions
diff --git a/audio/teamspeak_client/Makefile b/audio/teamspeak_client/Makefile
index 18d151392e76..c1657744fc51 100644
--- a/audio/teamspeak_client/Makefile
+++ b/audio/teamspeak_client/Makefile
@@ -7,6 +7,7 @@
PORTNAME= teamspeak_client
PORTVERSION= 2.0.32
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.freenet.de/pub/4players/teamspeak.org/releases/:main \
http://www.gsoft.com.au/~doconnor/:misc
@@ -19,17 +20,57 @@ COMMENT= Client side of a group voice chat system
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_LINUX= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
+TSIMG= ${WRKSRC}/setup.data/image
+TSHOME= ${PREFIX}/lib/teamspeak_client
+
+SUB_FILES= TeamSpeak
+SUB_LIST= TSHOME="${TSHOME}"
+
+PORTDOCS= *
+
+DESKTOP_ENTRIES="TeamSpeak" \
+ "Voice-chat with people" \
+ "${TSHOME}/icon.xpm" \
+ "TeamSpeak" \
+ "Application;Audio;Network;" \
+ false
+
+post-extract:
+ @${MKDIR} ${WRKDIR}/programs
+ @${GZIP_CMD} -dc ${DISTDIR}/setduplexfake.so.gz >${WRKDIR}/programs/setduplexfake.so
+
+post-patch:
+ @${RM} -f ${TSIMG}/TeamSpeak
+ @${MKDIR} ${WRKDIR}/doc
+.for f in Readme.txt clicense.txt manual
+ @${MV} -f ${TSIMG}/${f} ${WRKDIR}/doc
+.endfor
+.for f in TeamSpeak.bin lib*
+ @${MV} ${TSIMG}/${f} ${WRKDIR}/programs
+.endfor
+ @${MKDIR} ${WRKDIR}/programs/client_sdk
+.for f in lib* tsControl
+ @${MV} ${TSIMG}/client_sdk/${f} ${WRKDIR}/programs/client_sdk
+.endfor
+
do-install:
- ${MKDIR} ${PREFIX}/lib/teamspeak_client
- ${TAR} -C ${WRKSRC}/setup.data/image -cf ${WRKSRC}/files.tar ./
- ${TAR} -C ${PREFIX}/lib/teamspeak_client -xf ${WRKSRC}/files.tar
- ${GZIP_CMD} -dc ${DISTDIR}/setduplexfake.so.gz >${PREFIX}/lib/teamspeak_client/setduplexfake.so
- ${SED} -e 's#%%TSHOME%%#${PREFIX}/lib/teamspeak_client#' <${FILESDIR}/TeamSpeak >${WRKSRC}/TeamSpeak
- ${INSTALL_SCRIPT} ${WRKSRC}/TeamSpeak ${PREFIX}/bin/
+ cd ${TSIMG} && \
+ ${FIND} * -type d -exec ${MKDIR} "${TSHOME}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${TSHOME}/{}" \;
+ cd ${WRKDIR}/programs && \
+ ${FIND} * -type d -exec ${MKDIR} "${TSHOME}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${TSHOME}/{}" \;
+ ${INSTALL_SCRIPT} ${WRKDIR}/TeamSpeak ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ cd ${WRKDIR}/doc && \
+ ${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+.endif
.include <bsd.port.mk>
diff --git a/audio/teamspeak_client/files/TeamSpeak b/audio/teamspeak_client/files/TeamSpeak.in
index 42bde1205d61..72db77c9b8c8 100644
--- a/audio/teamspeak_client/files/TeamSpeak
+++ b/audio/teamspeak_client/files/TeamSpeak.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# This starup script will set the correct library path
+# This startup script will set the correct library path
# and then startup the teamspeak binary.
#
@@ -19,4 +19,4 @@ if [ -r $TSHOME/setduplexfake.so ]; then
fi
fi
-$TSHOME/TeamSpeak.bin "$@"
+exec $TSHOME/TeamSpeak.bin "$@"
diff --git a/audio/teamspeak_client/pkg-plist b/audio/teamspeak_client/pkg-plist
index e0d7d09d9d15..592493dd9693 100644
--- a/audio/teamspeak_client/pkg-plist
+++ b/audio/teamspeak_client/pkg-plist
@@ -1,8 +1,5 @@
bin/TeamSpeak
-lib/teamspeak_client/Readme.txt
-lib/teamspeak_client/TeamSpeak
lib/teamspeak_client/TeamSpeak.bin
-lib/teamspeak_client/clicense.txt
lib/teamspeak_client/client_sdk/SDK_readme.txt
lib/teamspeak_client/client_sdk/TsRemoteImport.pas
lib/teamspeak_client/client_sdk/tsControl
@@ -12,103 +9,6 @@ lib/teamspeak_client/icon.xpm
lib/teamspeak_client/libHVDI.so.0.8.0
lib/teamspeak_client/libborqt-6.9-qt2.3.so
lib/teamspeak_client/libspeex.so.1.0.0
-lib/teamspeak_client/manual/registerwithserver.gif
-lib/teamspeak_client/manual/registerwithserver.htm
-lib/teamspeak_client/manual/soundinputoutputsettings.gif
-lib/teamspeak_client/manual/soundinputoutputsettings.htm
-lib/teamspeak_client/manual/autooperator.htm
-lib/teamspeak_client/manual/adminregisterplayerwithserver.htm
-lib/teamspeak_client/manual/definekeys.gif
-lib/teamspeak_client/manual/getconnectioninfo.htm
-lib/teamspeak_client/manual/options.htm
-lib/teamspeak_client/manual/ts03-toc.htm
-lib/teamspeak_client/manual/closed.gif
-lib/teamspeak_client/manual/channeladmin.htm
-lib/teamspeak_client/manual/FAQ.htm
-lib/teamspeak_client/manual/quickconnect.gif
-lib/teamspeak_client/manual/quickconnect.htm
-lib/teamspeak_client/manual/optionssoundnotifications.gif
-lib/teamspeak_client/manual/allowregistration.htm
-lib/teamspeak_client/manual/default.htm
-lib/teamspeak_client/manual/keybindings.gif
-lib/teamspeak_client/manual/allowregisterwithserver.gif
-lib/teamspeak_client/manual/howtostartteamspeak.htm
-lib/teamspeak_client/manual/closeteamspeak.htm
-lib/teamspeak_client/manual/switchtochannel.htm
-lib/teamspeak_client/manual/optionssounddevices.gif
-lib/teamspeak_client/manual/playerflags.gif
-lib/teamspeak_client/manual/away.gif
-lib/teamspeak_client/manual/away.htm
-lib/teamspeak_client/manual/topic.gif
-lib/teamspeak_client/manual/teamspeak.gif
-lib/teamspeak_client/manual/serverconnectioninfo.gif
-lib/teamspeak_client/manual/serverconnectioninfo.htm
-lib/teamspeak_client/manual/optionsother.gif
-lib/teamspeak_client/manual/createsubchannel.gif
-lib/teamspeak_client/manual/createsubchannel.htm
-lib/teamspeak_client/manual/menuself.gif
-lib/teamspeak_client/manual/menuself.htm
-lib/teamspeak_client/manual/voice.htm
-lib/teamspeak_client/manual/keysettings.htm
-lib/teamspeak_client/manual/blockwhispers.htm
-lib/teamspeak_client/manual/whatists.htm
-lib/teamspeak_client/manual/connectioninfo.gif
-lib/teamspeak_client/manual/inputmuted.gif
-lib/teamspeak_client/manual/inputmuted.htm
-lib/teamspeak_client/manual/editchannel.htm
-lib/teamspeak_client/manual/ts03-index.htm
-lib/teamspeak_client/manual/removeregistration.htm
-lib/teamspeak_client/manual/disconnect.htm
-lib/teamspeak_client/manual/button.gif
-lib/teamspeak_client/manual/toc.css
-lib/teamspeak_client/manual/serveradmin.htm
-lib/teamspeak_client/manual/outpumuted.gif
-lib/teamspeak_client/manual/lastnotes.htm
-lib/teamspeak_client/manual/C1H_HTML.css
-lib/teamspeak_client/manual/sendtextmessagetoall.htm
-lib/teamspeak_client/manual/open.gif
-lib/teamspeak_client/manual/adminregisterwithserver.gif
-lib/teamspeak_client/manual/texttochannel.gif
-lib/teamspeak_client/manual/featurelist.htm
-lib/teamspeak_client/manual/usedcodecsandsomewordsaboutquality.htm
-lib/teamspeak_client/manual/menusettings.gif
-lib/teamspeak_client/manual/menusettings.htm
-lib/teamspeak_client/manual/kickplayerwithreason.htm
-lib/teamspeak_client/manual/kickplayer.htm
-lib/teamspeak_client/manual/menuconnection.gif
-lib/teamspeak_client/manual/menuconnection.htm
-lib/teamspeak_client/manual/menuhelp.htm
-lib/teamspeak_client/manual/channelcommander.htm
-lib/teamspeak_client/manual/linkbar.gif
-lib/teamspeak_client/manual/DocToHelp.js
-lib/teamspeak_client/manual/clientmanual.htm
-lib/teamspeak_client/manual/back.gif
-lib/teamspeak_client/manual/kickplayerfromchannel.htm
-lib/teamspeak_client/manual/general.htm
-lib/teamspeak_client/manual/createchannel.gif
-lib/teamspeak_client/manual/createchannel.htm
-lib/teamspeak_client/manual/whatdoineedforts.htm
-lib/teamspeak_client/manual/glossaryofterms.htm
-lib/teamspeak_client/manual/sendtextmessagetochannel.htm
-lib/teamspeak_client/manual/outputmuted.gif
-lib/teamspeak_client/manual/outputmuted.htm
-lib/teamspeak_client/manual/menuplayers.gif
-lib/teamspeak_client/manual/menuplayers.htm
-lib/teamspeak_client/manual/connect.gif
-lib/teamspeak_client/manual/connect.htm
-lib/teamspeak_client/manual/requestvoice.gif
-lib/teamspeak_client/manual/requestvoice.htm
-lib/teamspeak_client/manual/generalinformationaboutportsandfirewallsforservers.htm
-lib/teamspeak_client/manual/theteamspeakclientgui.htm
-lib/teamspeak_client/manual/howitworks.htm
-lib/teamspeak_client/manual/autovoice.htm
-lib/teamspeak_client/manual/ts03-blank.htm
-lib/teamspeak_client/manual/textingall.gif
-lib/teamspeak_client/manual/deletechannel.htm
-lib/teamspeak_client/manual/menuchannels.gif
-lib/teamspeak_client/manual/menuchannels.htm
-lib/teamspeak_client/manual/operator.htm
-lib/teamspeak_client/manual/channel.gif
lib/teamspeak_client/sounds/17.welcome.wav
lib/teamspeak_client/sounds/36.v_stat_revoked.wav
lib/teamspeak_client/sounds/09.newspeaker.wav
@@ -161,6 +61,5 @@ lib/teamspeak_client/sounds/11.memberjoined.wav
lib/teamspeak_client/sounds/35.v_stat_granted.wav
lib/teamspeak_client/setduplexfake.so
@dirrm lib/teamspeak_client/client_sdk
-@dirrm lib/teamspeak_client/manual
@dirrm lib/teamspeak_client/sounds
@dirrm lib/teamspeak_client