aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-05-31 04:30:53 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-05-31 04:30:53 +0000
commit147273eda9f41a57c3d509d3284136effff222b5 (patch)
tree47191626e82e32032cfde82e0a78b0ad149c36e2 /audio/timidity
parent34557987a91fe6cdf47146ee9b75998b6033d887 (diff)
downloadports-147273eda9f41a57c3d509d3284136effff222b5.tar.gz
ports-147273eda9f41a57c3d509d3284136effff222b5.zip
audio/timidity installs files with invalid uid and gid.
audio/timidity installs some files with invalid uid and gid. This is caused by installing the files directly from an archive. Tar with a root priviledge preserves owners and permissions by default. PR: ports/67397 Submitted by: Taoka Fumiyoshi <fmysh@iijmio-mail.jp>
Notes
Notes: svn path=/head/; revision=110472
Diffstat (limited to 'audio/timidity')
-rw-r--r--audio/timidity/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/audio/timidity/Makefile b/audio/timidity/Makefile
index bbb98b7028ae..dffb7c0984d9 100644
--- a/audio/timidity/Makefile
+++ b/audio/timidity/Makefile
@@ -23,18 +23,16 @@ NO_CDROM= "Uses copyrighted patches"
TIINS= goemon.tgz
INSTALL_TARGET= install.all
MAN1= timidity.1
+USE_REINPLACE= yes
post-patch:
- @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
- ${WRKSRC}/linux_a.c > ${WRKSRC}/linux_a.c.new
- @${MV} ${WRKSRC}/linux_a.c.new ${WRKSRC}/linux_a.c
+ ${REINPLACE_CMD} -e 's,machine/soundcard.h,sys/soundcard.h,' \
+ ${WRKSRC}/linux_a.c
post-install:
cd ${PREFIX}/lib/timidity && \
- ${TAR} zxf ${DISTDIR}/${TIINS} && \
- ${CP} goemon.cfg goemon.cfg.bak && \
- ${SED} 's=dir goemon=dir ${PREFIX}/lib/timidity/goemon=' \
- < goemon.cfg.bak > goemon.cfg && \
- ${RM} goemon.cfg.bak
+ ${TAR} --no-same-owner --no-same-permissions -zxf ${DISTDIR}/${TIINS} && \
+ ${REINPLACE_CMD} -i "" -e 's,dir goemon,dir ${PREFIX}/lib/timidity/goemon,' \
+ goemon.cfg
.include <bsd.port.mk>