aboutsummaryrefslogtreecommitdiff
path: root/audio/vorbisgain
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 11:09:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 11:09:45 +0000
commitf1af7415164bba9dc75886444b0c9a8ecf49297b (patch)
tree926af49822338f8055b987a9a2992e8b6065128a /audio/vorbisgain
parent407c8d97194c1321d469264ea500181b9a15cd3d (diff)
downloadports-f1af7415164bba9dc75886444b0c9a8ecf49297b.tar.gz
ports-f1af7415164bba9dc75886444b0c9a8ecf49297b.zip
add vorbisgain 0.32
Calculates a percieved sound level of an Ogg Vorbis file
Notes
Notes: svn path=/head/; revision=72374
Diffstat (limited to 'audio/vorbisgain')
-rw-r--r--audio/vorbisgain/Makefile31
-rw-r--r--audio/vorbisgain/distinfo1
-rw-r--r--audio/vorbisgain/files/patch-Makefile.in11
-rw-r--r--audio/vorbisgain/pkg-comment1
-rw-r--r--audio/vorbisgain/pkg-descr14
-rw-r--r--audio/vorbisgain/pkg-plist1
6 files changed, 59 insertions, 0 deletions
diff --git a/audio/vorbisgain/Makefile b/audio/vorbisgain/Makefile
new file mode 100644
index 000000000000..bd08c82ceced
--- /dev/null
+++ b/audio/vorbisgain/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: vorbisgain
+# Date created: Jan 3, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= vorbisgain
+PORTVERSION= 0.32
+CATEGORIES= audio
+MASTER_SITES= http://sjeng.sourceforge.net/ftp/vorbis/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
+ vorbis.2:${PORTSDIR}/audio/libvorbis
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lm -logg -lvorbis -lvorbisfile"
+USE_GMAKE= yes
+
+MAN1= vorbisgain.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-ldir,," ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/audio/vorbisgain/distinfo b/audio/vorbisgain/distinfo
new file mode 100644
index 000000000000..6079ca062877
--- /dev/null
+++ b/audio/vorbisgain/distinfo
@@ -0,0 +1 @@
+MD5 (vorbisgain-0.32.zip) = 9bd34aff8540961ab2b2ef873caeabb1
diff --git a/audio/vorbisgain/files/patch-Makefile.in b/audio/vorbisgain/files/patch-Makefile.in
new file mode 100644
index 000000000000..a736a798d363
--- /dev/null
+++ b/audio/vorbisgain/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Jan 3 19:03:10 2003
++++ Makefile.in Fri Jan 3 19:04:08 2003
+@@ -71,7 +71,7 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+
+-mandir = @MANDIR@
++mandir = @prefix@/man
+
+ AUTOMAKE_OPTIONS = foreign dist-zip
+
diff --git a/audio/vorbisgain/pkg-comment b/audio/vorbisgain/pkg-comment
new file mode 100644
index 000000000000..9ac08a6852ed
--- /dev/null
+++ b/audio/vorbisgain/pkg-comment
@@ -0,0 +1 @@
+Calculates a percieved sound level of an Ogg Vorbis file
diff --git a/audio/vorbisgain/pkg-descr b/audio/vorbisgain/pkg-descr
new file mode 100644
index 000000000000..558b47fbaf08
--- /dev/null
+++ b/audio/vorbisgain/pkg-descr
@@ -0,0 +1,14 @@
+When listening to Ogg Vorbis (or MP3) files on your computer, you may have
+noticed that some songs are louder than others. To a degree, this can be
+what the artist or producer intended, at least when comparing songs from the
+same CD. However, when (randomly) listening to songs from different CDs, the
+sound level can vary quite much, so much that you need to adjust the volume
+every now and then, to get a comfortable sound level. Wouldn't it be nice if
+that could be handled automatically?
+
+This is where VorbisGain comes in. It calculates a percieved sound level of
+an Ogg Vorbis file using the ReplayGain algorithm. VorbisGain then stores in
+the comments (tags) in the file a suggestion on how the volume should be
+changed during playback, to get a uniform sound level. However, this only
+solves half the problem; the player application needs to act on that
+suggestion for it to be any useful.
diff --git a/audio/vorbisgain/pkg-plist b/audio/vorbisgain/pkg-plist
new file mode 100644
index 000000000000..a305441366d3
--- /dev/null
+++ b/audio/vorbisgain/pkg-plist
@@ -0,0 +1 @@
+bin/vorbisgain