aboutsummaryrefslogtreecommitdiff
path: root/audio/wavplay
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-12-11 23:18:07 +0000
committerSimon Barner <barner@FreeBSD.org>2005-12-11 23:18:07 +0000
commit4130d887b2b2073dcc404bcd6bfea6472bff6d41 (patch)
tree622a272ec9d38df9714a6717d5991ebdc8ac86fc /audio/wavplay
parent05c2bf47adc57a1e67bcc9853fd4b71d264f3101 (diff)
downloadports-4130d887b2b2073dcc404bcd6bfea6472bff6d41.tar.gz
ports-4130d887b2b2073dcc404bcd6bfea6472bff6d41.zip
- Open sound device in read-only mode so it works also on the second, third,...
invokation if the soundcard is in half-duplex mode. - Bump PORTREVISION Submitted by: Watanabe Kazuhiro <CQG00620@nifty.ne.jp> PR: ports/90226
Notes
Notes: svn path=/head/; revision=150927
Diffstat (limited to 'audio/wavplay')
-rw-r--r--audio/wavplay/Makefile2
-rw-r--r--audio/wavplay/files/patch-af53
2 files changed, 31 insertions, 24 deletions
diff --git a/audio/wavplay/Makefile b/audio/wavplay/Makefile
index 308aa50b82b0..4e5b0ff9bc9f 100644
--- a/audio/wavplay/Makefile
+++ b/audio/wavplay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wavplay
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/sound/players
diff --git a/audio/wavplay/files/patch-af b/audio/wavplay/files/patch-af
index 84ada821a3b6..6cb5bd7940a3 100644
--- a/audio/wavplay/files/patch-af
+++ b/audio/wavplay/files/patch-af
@@ -1,23 +1,30 @@
-*** recplay.c.orig Sat Jan 15 12:56:46 2000
---- recplay.c Sat Jan 15 13:16:42 2000
-***************
-*** 52,63 ****
---- 52,69 ----
- #include <stdio.h>
- #include <stdarg.h>
- #include <stdlib.h>
-+ #ifndef FREEBSD
- #include <malloc.h>
-+ #endif
- #include <string.h>
- #include <fcntl.h>
- #include <errno.h>
- #include <sys/stat.h>
-+ #ifndef FREEBSD
- #include <linux/soundcard.h>
-+ #else
-+ #include <sys/soundcard.h>
-+ #endif
- #include "wavplay.h"
- #include "server.h"
-
+--- recplay.c.orig Sat Dec 4 09:06:42 1999
++++ recplay.c Sun Dec 11 12:56:34 2005
+@@ -52,12 +52,18 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
++#ifndef FREEBSD
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <sys/stat.h>
++#ifndef FREEBSD
+ #include <linux/soundcard.h>
++#else
++#include <sys/soundcard.h>
++#endif
+ #include "wavplay.h"
+ #include "server.h"
+
+@@ -184,7 +190,7 @@
+ wfile = svr.wfile; /* And the file is already opened */
+ }
+
+- if ( (dfile = OpenDSP(wfile,O_RDWR,v_erf)) == NULL )
++ if ( (dfile = OpenDSP(wfile,O_RDONLY,v_erf)) == NULL )
+ goto errxit;
+
+ if ( RecordDSP(dfile,wfile,samples,svr_work_proc,v_erf) )