aboutsummaryrefslogtreecommitdiff
path: root/audio/wsoundserver
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 05:19:38 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 05:19:38 +0000
commit712a2199384437ea262fe698b283e4f616362747 (patch)
tree945bab070253f362d6ebb5a75a9c90ce751c10c7 /audio/wsoundserver
parent48f4e97e04d74b70c63f73cf44de3e75c99fdfaa (diff)
downloadports-712a2199384437ea262fe698b283e4f616362747.tar.gz
ports-712a2199384437ea262fe698b283e4f616362747.zip
Implement WANT_ESOUND, USE_ESOUND.
Notes
Notes: svn path=/head/; revision=33420
Diffstat (limited to 'audio/wsoundserver')
-rw-r--r--audio/wsoundserver/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/wsoundserver/Makefile b/audio/wsoundserver/Makefile
index 0bfa0f1ee90d..33abdf8fd177 100644
--- a/audio/wsoundserver/Makefile
+++ b/audio/wsoundserver/Makefile
@@ -16,21 +16,14 @@ MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= wmaker:${PORTSDIR}/x11-wm/windowmaker
LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
- dockapp.1:${PORTSDIR}/x11-wm/libdockapp \
- ${ESD_DEPENDS}
+ dockapp.1:${PORTSDIR}/x11-wm/libdockapp
RUN_DEPENDS= wmaker:${PORTSDIR}/x11-wm/windowmaker
USE_X_PREFIX= yes
+WANT_ESOUND= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-.if defined(WITH_ESD)
-ESD_DEPENDS= esd.2:${PORTSDIR}/audio/esound
-CONFIGURE_ARGS+=--enable-esd
-.else
-ESD_DEPENDS=
-.endif
-
MAN1= get-wsound-flags.1x getsoundset.1x setsoundset.1x \
wsoundplay.1x wsoundserver.1x
@@ -40,4 +33,11 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/WMSound \
${PREFIX}/etc/WindowMaker/WMSound
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+CONFIGURE_ARGS+=--enable-esd
+.endif
+
+.include <bsd.port.post.mk>