aboutsummaryrefslogtreecommitdiff
path: root/audio/x11amp/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-02-04 18:25:36 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-02-04 18:25:36 +0000
commit3eaff25cc8249f109dc7507bdab39b05ca9c2680 (patch)
tree9489d68a7f94fe90b8ed6132b50361220c21d074 /audio/x11amp/Makefile
parentaa55e9f3e14b2e20e692f622caa71f73fe09467c (diff)
downloadports-3eaff25cc8249f109dc7507bdab39b05ca9c2680.tar.gz
ports-3eaff25cc8249f109dc7507bdab39b05ca9c2680.zip
- /objformat=/s|=.*|=elf| [1]
- Don't build static lib Reported by: pointyhat via kris [1] Approved by: Beech Rintoul <freebsd@alaskaparadise.com> (maintainer)
Notes
Notes: svn path=/head/; revision=184147
Diffstat (limited to 'audio/x11amp/Makefile')
-rw-r--r--audio/x11amp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index ed3221c84211..6d41f9affe73 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -21,6 +21,7 @@ USE_XLIB= yes
USE_GNOME= gtk12 esound
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -30,4 +31,7 @@ post-extract:
@${CP} ${FILESDIR}/main.xpm ${WRKSRC}/x11amp/defskin
@${CHMOD} a+x ${WRKSRC}/ltconfig
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.post.mk>