aboutsummaryrefslogtreecommitdiff
path: root/audio/xmixer
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-26 19:36:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-26 19:36:41 +0000
commit427c611e69989ede626afd4661f0ba9341f036ae (patch)
tree364d118927443a4c62285cce0813db632f3021c4 /audio/xmixer
parentbbe10a6dc6d236b92ae5caa8574f8cf78a4ac040 (diff)
downloadports-427c611e69989ede626afd4661f0ba9341f036ae.tar.gz
ports-427c611e69989ede626afd4661f0ba9341f036ae.zip
- Fix MASTER_SITES
- Optionalize GTK support - Add WWW: line PR: ports/81504 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=136201
Diffstat (limited to 'audio/xmixer')
-rw-r--r--audio/xmixer/Makefile39
-rw-r--r--audio/xmixer/files/patch-aa55
-rw-r--r--audio/xmixer/files/patch-ab21
-rw-r--r--audio/xmixer/files/patch-ad16
-rw-r--r--audio/xmixer/files/patch-ae18
-rw-r--r--audio/xmixer/pkg-descr2
6 files changed, 30 insertions, 121 deletions
diff --git a/audio/xmixer/Makefile b/audio/xmixer/Makefile
index 10e1514cab74..89f80a2894c8 100644
--- a/audio/xmixer/Makefile
+++ b/audio/xmixer/Makefile
@@ -7,31 +7,48 @@
PORTNAME= xmixer
PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
-# Master site seems to be MIA and no replacement could be found
-MASTER_SITES= #http://www.hdk-berlin.de/~rasca/
+MASTER_SITES= http://mpx.freeshell.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= Audio mixer (gtk and Xlib) for X11R6
WRKSRC= ${WRKDIR}/${PORTNAME}
+WANT_GNOME= yes
USE_REINPLACE= yes
-USE_GNOME= gtk12
-USE_AUTOCONF_VER= 213
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PROGRAMS}
-PLIST_FILES= bin/xmixer bin/xgmixer
MAN1= xmixer.1
-MLINKS= xmixer.1 xgmixer.1
+PLIST_FILES= bin/xmixer
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+.if ${HAVE_GNOME:Mgtk12}!=""
+PKGNAMESUFFIX= -gtk
+USE_GNOME+= gtk12
+PROGRAMS= xmixer xgmixer
+MLINKS+= xmixer.1 xgmixer.1
+PLIST_FILES+= bin/xgmixer
+.else
+USE_XLIB= yes
+PROGRAMS= xmixer
.endif
-pre-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's|rxvt -e|xterm -e|g'
+post-patch:
+ @${GREP} -lR "rxvt -e" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|rxvt -e|xterm -e|g'
+ @${REINPLACE_CMD} -e 's|-O -Wall||g ; \
+ s|^%\.o:.*$$|.c.o:|g ; \
+ s|gtk-config|pkg-config gtk+|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|<getopt\.h>|<unistd.h>|g' ${WRKSRC}/main.c
+
+do-install:
+.for file in ${PROGRAMS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin/${file}
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/xmixer.man ${MANPREFIX}/man/man1/xmixer.1
.include <bsd.port.post.mk>
diff --git a/audio/xmixer/files/patch-aa b/audio/xmixer/files/patch-aa
deleted file mode 100644
index 6139566d9078..000000000000
--- a/audio/xmixer/files/patch-aa
+++ /dev/null
@@ -1,55 +0,0 @@
---- Makefile.in.orig Thu Nov 16 17:12:29 2000
-+++ Makefile.in Tue Feb 20 02:03:56 2001
-@@ -13,7 +13,7 @@
- DEF_MIXER = /dev/mixer
- VERSION = 0.9.4
-
--CFLAGS = -O -Wall @CFLAGS@ @X_CFLAGS@ -DDEFAULT_MIXER=\"$(DEF_MIXER)\" \
-+CFLAGS = @CFLAGS@ @X_CFLAGS@ -DDEFAULT_MIXER=\"$(DEF_MIXER)\" \
- -DOSS -I$(top_srcdir) -I$(top_srcdir)/icons \
- -DVERSION=\"$(VERSION)\"
- LDFLAGS = @LDFLAGS@
-@@ -25,7 +25,7 @@
- OBJS = main.o mixer.o gui_xaw.o chglbl.o scf.o
- G_OBJS = main.o mixer.o gui_gtk.o scf.o
-
--default: $(PROGS) README
-+all: $(PROGS)
-
- gui_xaw.o: fallback.h
-
-@@ -33,27 +33,27 @@
- mkfb.pl < XMixer.ad > fallback.h
-
- gui_gtk.o: gui_gtk.c
-- $(CC) $(CFLAGS) $(INCS) `gtk-config --cflags` -c $<
-+ $(CC) $(CFLAGS) $(INCS) `$(GTK_CONFIG) --cflags` -c $<
-
--%.o: %.c
-+.c.o:
- $(CC) $(CFLAGS) $(INCS) -c $<
-
- xmixer: Xw/libXw.a $(OBJS)
- $(LD) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
-
- xgmixer: $(G_OBJS)
-- $(LD) $(LDFLAGS) -o $@ $(G_OBJS) `gtk-config --libs`
-+ $(LD) $(LDFLAGS) -o $@ $(G_OBJS) `$(GTK_CONFIG) --libs`
-
- Xw/libXw.a:
-- cd Xw && make libXw.a
-+ cd Xw && $(MAKE) libXw.a
-
- README: index.html
- lynx -dump http://www/~rasca/xmixer/index.html | sed "s%//www/%//home.pages.de/%" > README
-
- install: $(PROGS)
-- install -o bin xmixer $(bindir)
-- install xmixer.man $(mandir)/xmixer.1
-- install -o bin xgmixer $(bindir)
-+ ${BSD_INSTALL_PROGRAM} xmixer $(bindir)
-+ ${BSD_INSTALL_MAN} xmixer.man $(mandir)/xmixer.1
-+ ${BSD_INSTALL_PROGRAM} xgmixer $(bindir)
-
- install.lib: libmixer.a
- install libsmixer.a $(LIBDIR)
diff --git a/audio/xmixer/files/patch-ab b/audio/xmixer/files/patch-ab
deleted file mode 100644
index 71805804f34f..000000000000
--- a/audio/xmixer/files/patch-ab
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.in.orig Thu Nov 16 17:13:39 2000
-+++ configure.in Tue Feb 20 02:04:19 2001
-@@ -23,15 +23,15 @@
- AC_CHECK_LIB(Xaw, XawPanedGetNumSub)
-
- __cflags=$CFLAGS
--CFLAGS="$CFLAGS `gtk-config --cflags`"
-+CFLAGS="$CFLAGS `$GTK_CONFIG --cflags`"
- __libs=$LIBS
--LIBS="$LIBS `gtk-config --libs`"
-+LIBS="$LIBS `$GTK_CONFIG --libs`"
- AC_CHECK_LIB(gdk, gdk_init)
- AC_CHECK_LIB(gtk, gtk_main)
- CFLAGS=$__cflags
- LIBS=$__libs
-
--__gtk=`gtk-config --version`
-+__gtk=`$GTK_CONFIG --version`
- case "$__gtk" in
- 1.2*)
- x_progs="xmixer xgmixer"
diff --git a/audio/xmixer/files/patch-ad b/audio/xmixer/files/patch-ad
deleted file mode 100644
index 143f3e07bcc1..000000000000
--- a/audio/xmixer/files/patch-ad
+++ /dev/null
@@ -1,16 +0,0 @@
---- main.c.orig Sat Aug 21 15:26:37 1999
-+++ main.c Tue Oct 26 23:47:37 1999
-@@ -22,7 +22,13 @@
-
- #include <stdio.h>
- #include <stdlib.h> /* free() */
-+#if HAVE_GETOPT_H
- #include <getopt.h>
-+#else
-+extern int getopt();
-+extern char *optarg;
-+extern int optind;
-+#endif
- #include <limits.h>
- #include "gui.h"
- #include "mixer.h"
diff --git a/audio/xmixer/files/patch-ae b/audio/xmixer/files/patch-ae
deleted file mode 100644
index 192e7965af29..000000000000
--- a/audio/xmixer/files/patch-ae
+++ /dev/null
@@ -1,18 +0,0 @@
---- mixer.c.orig Sun Sep 8 02:03:09 2002
-+++ mixer.c Sun Sep 8 02:04:25 2002
-@@ -46,7 +46,14 @@
- # include <sys/asound.h>
- #endif
- #ifdef OSS
--# include <sys/soundcard.h>
-+/* "The nice thing about standards..." */
-+#if defined (__linux__) || defined (__bsdi__) || defined(__FreeBSD__)
-+#include <sys/soundcard.h>
-+#else
-+#if defined (__NetBSD__) || defined (__OpenBSD__)
-+#include <soundcard.h> /* OSS emulation */
-+#endif
-+#endif
- #endif
- #include "mixer.h"
-
diff --git a/audio/xmixer/pkg-descr b/audio/xmixer/pkg-descr
index cb933f61a57b..3cffa9fb2931 100644
--- a/audio/xmixer/pkg-descr
+++ b/audio/xmixer/pkg-descr
@@ -12,3 +12,5 @@ uses the Athena toolkit, and xgmixer, based on GTK+. From the README:
* Hide devices which you don't want to see.
* Batch support - just read and evaluate the settings in the
configuration file.
+
+WWW: http://mpx.freeshell.net/