aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-flac
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2007-03-27 23:47:50 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2007-03-27 23:47:50 +0000
commitf630b1a36eb584fdca6ced4bb1fff4aa16eb9cfe (patch)
tree874405f08056a5d4192b97330fe09908fc725d1d /audio/xmms-flac
parent0c7b5c2581a39c67e2ad82fd38b3c1a3666fac6b (diff)
downloadports-f630b1a36eb584fdca6ced4bb1fff4aa16eb9cfe.tar.gz
ports-f630b1a36eb584fdca6ced4bb1fff4aa16eb9cfe.zip
Use ports libtool instead of the included one. This should fix building
on 7.0-CURRENT. Notified by: kris (pointyhat)
Notes
Notes: svn path=/head/; revision=188603
Diffstat (limited to 'audio/xmms-flac')
-rw-r--r--audio/xmms-flac/Makefile4
-rw-r--r--audio/xmms-flac/files/patch-configure10
-rw-r--r--audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in9
3 files changed, 12 insertions, 11 deletions
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 52d3337d68e3..dd9468d52e91 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
FLAC.7:${PORTSDIR}/audio/flac
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${X11BASE}"
@@ -33,6 +33,6 @@ post-configure:
# XXX
post-install:
- @${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la
+ ${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la
.include <bsd.port.mk>
diff --git a/audio/xmms-flac/files/patch-configure b/audio/xmms-flac/files/patch-configure
index 21b1a45cd09e..e335f4533ff4 100644
--- a/audio/xmms-flac/files/patch-configure
+++ b/audio/xmms-flac/files/patch-configure
@@ -3,15 +3,7 @@ $FreeBSD$
--- configure.orig
+++ configure
-@@ -7976,6 +7976,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -10541,9 +10542,9 @@
+@@ -10541,9 +10541,9 @@
if test x$debug = xtrue; then
OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -g -O0 -DDEBUG"
else
diff --git a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
index 5470ca6c20bd..e5fa56dc7d07 100644
--- a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
+++ b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
@@ -13,6 +13,15 @@ $FreeBSD$
am__objects_1 = charset.lo configure.lo fileinfo.lo http.lo plugin.lo \
tag.lo
am_libxmms_flac_la_OBJECTS = $(am__objects_1)
+@@ -189,7 +188,7 @@
+ LIBS = @LIBS@
+
+ # Don't build a static library
+-LIBTOOL = $(top_builddir)/libtool-disable-static
++LIBTOOL = @LIBTOOL@ --tag=disable-static
+ LN_S = @LN_S@
+ LTLIBICONV = @LTLIBICONV@
+ LTLIBOBJS = @LTLIBOBJS@
@@ -296,8 +295,7 @@
$(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
$(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \